aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-01-14 01:13:11 +0800
committermarino <marino@FreeBSD.org>2014-01-14 01:13:11 +0800
commitebb12f6e7de96baff3e3bcaf5fec77fc00707e55 (patch)
treee5f2c5968dff2ad90432d3df5501fad4600674ac /audio
parente4d9efe36abe6b4e7abcf4e56c31252c0a655d5a (diff)
downloadfreebsd-ports-gnome-ebb12f6e7de96baff3e3bcaf5fec77fc00707e55.tar.gz
freebsd-ports-gnome-ebb12f6e7de96baff3e3bcaf5fec77fc00707e55.tar.zst
freebsd-ports-gnome-ebb12f6e7de96baff3e3bcaf5fec77fc00707e55.zip
audio/xmms-mp3cue: Unbreak and support stage
This port had two major c++ issues. The first was missing <cstlib> header and using <string> instead of <cstring>. The second was the default setting of CC to "g++" which fails on F10+. Unbreak and stagify under the "Just fix it" blanket.
Diffstat (limited to 'audio')
-rw-r--r--audio/xmms-mp3cue/Makefile2
-rw-r--r--audio/xmms-mp3cue/files/patch-ID3tag.C12
-rw-r--r--audio/xmms-mp3cue/files/patch-Makefile.in15
3 files changed, 28 insertions, 1 deletions
diff --git a/audio/xmms-mp3cue/Makefile b/audio/xmms-mp3cue/Makefile
index 51c7485af6f8..d3dd328e0ff7 100644
--- a/audio/xmms-mp3cue/Makefile
+++ b/audio/xmms-mp3cue/Makefile
@@ -15,12 +15,12 @@ LIB_DEPENDS= libxmms.so:${PORTSDIR}/multimedia/xmms
GNU_CONFIGURE= yes
USES= gmake
-NO_STAGE= yes
PLIST_SUB= PORTDOCS=${DISTNAME}
CFLAGS_amd64= -fPIC
CFLAGS_ia64= -fPIC
+MAKE_ARGS+= CC="${CXX}"
post-patch:
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/*.c
diff --git a/audio/xmms-mp3cue/files/patch-ID3tag.C b/audio/xmms-mp3cue/files/patch-ID3tag.C
new file mode 100644
index 000000000000..045eee4a6531
--- /dev/null
+++ b/audio/xmms-mp3cue/files/patch-ID3tag.C
@@ -0,0 +1,12 @@
+--- ID3tag.C.orig 2003-10-22 08:23:00.000000000 +0000
++++ ID3tag.C
+@@ -27,7 +27,8 @@ Pune 411001
+ INDIA
+ */
+
+-#include <string>
++#include <cstring>
++#include <cstdlib>
+ #include <iostream>
+ using namespace std;
+
diff --git a/audio/xmms-mp3cue/files/patch-Makefile.in b/audio/xmms-mp3cue/files/patch-Makefile.in
new file mode 100644
index 000000000000..2a1500da21cb
--- /dev/null
+++ b/audio/xmms-mp3cue/files/patch-Makefile.in
@@ -0,0 +1,15 @@
+--- Makefile.in.orig 2003-10-22 08:23:00.000000000 +0000
++++ Makefile.in
+@@ -33,9 +33,9 @@ distclean: clean
+ rm -rf config.* Makefile tmp *.tar.gz
+
+ install: mp3cue
+- $(mkinstalldirs) $(INSTALLPATH) $(PREFIX)/share/doc/$(PACKAGE)-$(VERSION)
+- $(INSTALL) -s $(TARGET) $(INSTALLPATH)
+- $(INSTALL) $(DOCS) $(PREFIX)/share/doc/$(PACKAGE)-$(VERSION)
++ $(mkinstalldirs) $(DESTDIR)$(INSTALLPATH) $(DESTDIR)$(PREFIX)/share/doc/$(PACKAGE)-$(VERSION)
++ $(INSTALL) -s $(TARGET) $(DESTDIR)$(INSTALLPATH)
++ $(INSTALL) $(DOCS) $(DESTDIR)$(PREFIX)/share/doc/$(PACKAGE)-$(VERSION)
+
+ mp3cue: $(OBJS)
+ $(CC) -o $(TARGET) $(OBJS) $(LDFLAGS)