aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-10-15 19:43:25 +0800
committerpav <pav@FreeBSD.org>2004-10-15 19:43:25 +0800
commited9a6fe55043b23b8c0ea99671e8a70004aa8ad7 (patch)
tree900b311f5dcd7d555dfa1bb2ded90856bfdc4316 /audio
parent32a7eb3434e15e9ae3d3d4655b2d83c1adeb2ad6 (diff)
downloadfreebsd-ports-gnome-ed9a6fe55043b23b8c0ea99671e8a70004aa8ad7.tar.gz
freebsd-ports-gnome-ed9a6fe55043b23b8c0ea99671e8a70004aa8ad7.tar.zst
freebsd-ports-gnome-ed9a6fe55043b23b8c0ea99671e8a70004aa8ad7.zip
- Make sndfile-play work
PR: ports/72716 Submitted by: Michael Johnson <ahze@ahze.net>
Diffstat (limited to 'audio')
-rw-r--r--audio/libsndfile/Makefile1
-rw-r--r--audio/libsndfile/files/patch-examples_sndfile-play.c29
2 files changed, 30 insertions, 0 deletions
diff --git a/audio/libsndfile/Makefile b/audio/libsndfile/Makefile
index 173515ee01d5..97185be9c014 100644
--- a/audio/libsndfile/Makefile
+++ b/audio/libsndfile/Makefile
@@ -8,6 +8,7 @@
PORTNAME= libsndfile
PORTVERSION= 1.0.10
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://www.mega-nerd.com/libsndfile/
diff --git a/audio/libsndfile/files/patch-examples_sndfile-play.c b/audio/libsndfile/files/patch-examples_sndfile-play.c
new file mode 100644
index 000000000000..ceecb8e27b52
--- /dev/null
+++ b/audio/libsndfile/files/patch-examples_sndfile-play.c
@@ -0,0 +1,29 @@
+--- examples/sndfile-play.c.orig Thu Oct 14 18:07:25 2004
++++ examples/sndfile-play.c Thu Oct 14 18:11:13 2004
+@@ -34,7 +34,7 @@
+ #include <sys/time.h>
+ #endif
+
+-#if defined (__linux__)
++#if defined (__linux__) || defined (__FreeBSD__)
+ #include <fcntl.h>
+ #include <sys/ioctl.h>
+ #include <sys/soundcard.h>
+@@ -326,7 +326,7 @@
+ ** Linux/OSS functions for playing a sound.
+ */
+
+-#if defined (__linux__)
++#if defined (__linux__) || defined (__FreeBSD__)
+
+ static int linux_open_dsp_device (int channels, int srate) ;
+
+@@ -869,7 +869,7 @@
+ return 1 ;
+ } ;
+
+-#if defined (__linux__)
++#if defined (__linux__) || defined(__FreeBSD__)
+ #if HAVE_ALSA_ASOUNDLIB_H
+ if (access ("/proc/asound/cards", R_OK) == 0)
+ alsa_play (argc, argv) ;