aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-12-14 08:53:42 +0800
committerbapt <bapt@FreeBSD.org>2013-12-14 08:53:42 +0800
commitf09215ae827a6f1d811c8077e731048f2fec99fc (patch)
tree50b60ab8e4c2387f410a74f69a1db94f67f55a0a /audio
parent689ad37d3bcfc9dbc2bf4508acb8558432c3bd91 (diff)
downloadfreebsd-ports-gnome-f09215ae827a6f1d811c8077e731048f2fec99fc.tar.gz
freebsd-ports-gnome-f09215ae827a6f1d811c8077e731048f2fec99fc.tar.zst
freebsd-ports-gnome-f09215ae827a6f1d811c8077e731048f2fec99fc.zip
Support stage
Diffstat (limited to 'audio')
-rw-r--r--audio/libsndfile/Makefile17
-rw-r--r--audio/libsndfile/pkg-plist9
2 files changed, 13 insertions, 13 deletions
diff --git a/audio/libsndfile/Makefile b/audio/libsndfile/Makefile
index 146e76fb134a..acab7f2c1dc5 100644
--- a/audio/libsndfile/Makefile
+++ b/audio/libsndfile/Makefile
@@ -11,10 +11,8 @@ MAINTAINER= multimedia@FreeBSD.org
COMMENT= Reading and writing files containing sampled sound (like WAV or AIFF)
LICENSE= LGPL21
-LICENSE_FILE= ${WRKSRC}/COPYING
USES= gmake pathfix pkgconfig
-NO_STAGE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-gcc-pipe \
--disable-sqlite \
@@ -24,10 +22,6 @@ CPPFLAGS+= -isystem /usr/include -isystem ${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
-MAN1= sndfile-concat.1 sndfile-cmp.1 sndfile-convert.1 \
- sndfile-info.1 sndfile-metadata-get.1 sndfile-metadata-set.1 \
- sndfile-play.1 sndfile-deinterleave.1 sndfile-interleave.1
-
PORTDOCS= AUTHORS ChangeLog NEWS README libsndfile.css \
new_file_type.HOWTO libsndfile.jpg *.html
@@ -36,7 +30,7 @@ OPTIONS_DEFAULT= EXTERNAL
CPU_CLIP_DESC= Allow machine-dependent clipping
EXTERNAL_DESC= Enable FLAC and Ogg Vorbis support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCPU_CLIP}
MANUAL_PACKAGE_BUILD= WITH_CPU_CLIP may customize the package for the build machine
@@ -59,11 +53,8 @@ check regression-test test: build
check
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
@${TAR} -C ${WRKSRC}/doc --exclude "*Makefile*" --exclude "*.in" \
- -cf - . | ${TAR} -C ${DOCSDIR} --unlink -xf -
- @${CHOWN} ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
-.endif
+ -cf - . | ${TAR} -C ${STAGEDIR}${DOCSDIR} --unlink -xf -
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/libsndfile/pkg-plist b/audio/libsndfile/pkg-plist
index 606fce428fe9..c5a2ad4a6215 100644
--- a/audio/libsndfile/pkg-plist
+++ b/audio/libsndfile/pkg-plist
@@ -16,3 +16,12 @@ lib/libsndfile.la
lib/libsndfile.so
lib/libsndfile.so.1
libdata/pkgconfig/sndfile.pc
+man/man1/sndfile-cmp.1.gz
+man/man1/sndfile-concat.1.gz
+man/man1/sndfile-convert.1.gz
+man/man1/sndfile-deinterleave.1.gz
+man/man1/sndfile-info.1.gz
+man/man1/sndfile-interleave.1.gz
+man/man1/sndfile-metadata-get.1.gz
+man/man1/sndfile-metadata-set.1.gz
+man/man1/sndfile-play.1.gz