aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2003-04-24 05:13:58 +0800
committerlioux <lioux@FreeBSD.org>2003-04-24 05:13:58 +0800
commitf1450c4aadff77890eb6e2341299d3b351ad54d8 (patch)
tree91611cced7158a8a5d6c377ee485ba61e1de4a0b /audio
parent071fd1b0356958b66049a12eaf406131d023e773 (diff)
downloadfreebsd-ports-gnome-f1450c4aadff77890eb6e2341299d3b351ad54d8.tar.gz
freebsd-ports-gnome-f1450c4aadff77890eb6e2341299d3b351ad54d8.tar.zst
freebsd-ports-gnome-f1450c4aadff77890eb6e2341299d3b351ad54d8.zip
New port mctoolame-decoder version 0.1.a: A LayerII MPEG Audio
decoder which supports multi-channel encoding
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/mctoolame-decoder/Makefile66
-rw-r--r--audio/mctoolame-decoder/distinfo1
-rw-r--r--audio/mctoolame-decoder/pkg-descr24
-rw-r--r--audio/mctoolame-decoder/pkg-plist6
5 files changed, 98 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 1f0032bf9b4d..0858d34ec7a4 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -143,6 +143,7 @@
SUBDIR += lplayer
SUBDIR += mad
SUBDIR += maplay
+ SUBDIR += mctoolame-decoder
SUBDIR += mhwaveedit
SUBDIR += midimountain
SUBDIR += mikmod
diff --git a/audio/mctoolame-decoder/Makefile b/audio/mctoolame-decoder/Makefile
new file mode 100644
index 000000000000..ec859489d3ab
--- /dev/null
+++ b/audio/mctoolame-decoder/Makefile
@@ -0,0 +1,66 @@
+# New ports collection makefile for: mctooLAME decoder
+# Date created: Thu Mar 27 20:32:42 UTC 2003
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mctoolame
+PORTVERSION= 0.1.a
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMESUFFIX= -decoder
+DISTNAME= ${PORTNAME}d-${PORTVERSION:C/\.//g}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= A LayerII MPEG Audio decoder which supports multi-channel encoding
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+ALL_TARGET=
+PLIST_SUB= PKGNAMESUFFIX="${PKGNAMESUFFIX}"
+
+pre-everything::
+.ifndef(WITH_OPTIMIZED_CFLAGS)
+ @${ECHO_MSG} '>>>'
+ @${ECHO_MSG} '>>> You can enable extra optimizations by defining WITH_OPTIMIZED_CFLAGS'
+ @${ECHO_MSG} ">>> For example, 'make WITH_OPTIMIZED_CFLAGS=yes'"
+.endif
+ @${ECHO_MSG} '>>>'
+.ifndef(WITH_PROFILED)
+ @${ECHO_MSG} ">>> You can enable profiling by defining WITH_PROFILED"
+.endif
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+.ifndef(WITH_OPTIMIZED_CFLAGS)
+ @${REINPLACE_CMD} -E \
+ -e 's|\$$\(TWEAKS\)||' \
+ ${WRKSRC}/Makefile
+.endif
+.ifndef(WITH_PROFILED)
+ @${REINPLACE_CMD} -E \
+ -e 's|\$$\(PG\)||' \
+ ${WRKSRC}/Makefile
+.endif
+ @${REINPLACE_CMD} -E \
+ -e 's@\$$\((ARCH|OPTIM|WARNINGS)\)@@g' \
+ ${WRKSRC}/Makefile
+
+post-configure:
+# C{C,FLAGS} safeness
+ @${REINPLACE_CMD} -E \
+ -e 's|^(CC[[:space:]]*=).+$$|\1${CC} ${CFLAGS}|' \
+ ${WRKSRC}/Makefile
+
+do-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}/html
+ @${INSTALL_DATA} ${WRKSRC}/html/* ${DOCSDIR}/html
+.endif
+ @${INSTALL_PROGRAM} ${WRKSRC}/mctoolamed ${PREFIX}/bin
+
+.include <bsd.port.post.mk>
diff --git a/audio/mctoolame-decoder/distinfo b/audio/mctoolame-decoder/distinfo
new file mode 100644
index 000000000000..e70d7f17dc90
--- /dev/null
+++ b/audio/mctoolame-decoder/distinfo
@@ -0,0 +1 @@
+MD5 (mctoolamed-01a.tgz) = 03b8d015057b537ecce0c8011181c0ec
diff --git a/audio/mctoolame-decoder/pkg-descr b/audio/mctoolame-decoder/pkg-descr
new file mode 100644
index 000000000000..b6e48678aab1
--- /dev/null
+++ b/audio/mctoolame-decoder/pkg-descr
@@ -0,0 +1,24 @@
+[ excerpt from developer's WWW site ]
+
+A multi-channel MPEG encoder, using the ISO13818 standard and the
+dist10 source code. Multi-channel files may have up to 6 defined
+channels: Left(L), Right(R), Center(C), Left Surround (LS), Right
+Surround (RS) and a Low Frequency Enhancement channel (LFE).
+
+ISO13818 defines 5 multichannel modes (on top of the normal stereo
+mode), each of these modes may have an optional LFE channel:
+
+3/2: L, R, C, LS, RS
+3/1: L, R, C, mono surround
+2/2: L, R, LS, RS
+2/1: L, R, mono surround
+3/0: L, R, C
+
+The "standard" surround sound encoding of "5.1 channels" is achieved
+by using mode 3/2 plus an LFE channel.
+
+A multi-channel MPEG file should decode OK on any MPEG decoder. If
+the decoder doesn't recognize the multi-channel extensions, then
+you'll just get a stereo file containing a down mix of the 5 channels.
+
+WWW: http://www.planckenergy.com/
diff --git a/audio/mctoolame-decoder/pkg-plist b/audio/mctoolame-decoder/pkg-plist
new file mode 100644
index 000000000000..08a8f793b061
--- /dev/null
+++ b/audio/mctoolame-decoder/pkg-plist
@@ -0,0 +1,6 @@
+bin/mctoolamed
+%%PORTDOCS%%%%DOCSDIR%%%%PKGNAMESUFFIX%%/html/default.html
+%%PORTDOCS%%%%DOCSDIR%%%%PKGNAMESUFFIX%%/html/history.html
+%%PORTDOCS%%%%DOCSDIR%%%%PKGNAMESUFFIX%%/html/readme.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%%%PKGNAMESUFFIX%%/html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%%%PKGNAMESUFFIX%%