aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2015-12-25 20:12:25 +0800
committerriggs <riggs@FreeBSD.org>2015-12-25 20:12:25 +0800
commitf7cb3e6b7e8a2848170eca51276480ee235d5d2e (patch)
treeee146e3804ccbbc6be2abeac0ebfe5ce7e183357 /audio
parent93211a2047157101a51b6829388903ea9e8175ad (diff)
downloadfreebsd-ports-gnome-f7cb3e6b7e8a2848170eca51276480ee235d5d2e.tar.gz
freebsd-ports-gnome-f7cb3e6b7e8a2848170eca51276480ee235d5d2e.tar.zst
freebsd-ports-gnome-f7cb3e6b7e8a2848170eca51276480ee235d5d2e.zip
Add support for ffmpeg and add non-default OPTION
PR: 205484 Submitted by: tatsuki_makino@hotmail.com Approved by: xxjack12xx@gmail.com (maintainer)
Diffstat (limited to 'audio')
-rw-r--r--audio/audacity/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/audio/audacity/Makefile b/audio/audacity/Makefile
index 17f9a6e7dcd0..2d3c077bdf47 100644
--- a/audio/audacity/Makefile
+++ b/audio/audacity/Makefile
@@ -36,7 +36,7 @@ PORTDOCS= README.txt
INSTALL_TARGET= install-strip
DOS2UNIX_GLOB= Makefile.* *.c* *.h
-OPTIONS_DEFINE= NLS DEBUG DOCS FLAC ID3TAG LADSPA LAME MAD MIDI \
+OPTIONS_DEFINE= NLS DEBUG DOCS FFMPEG FLAC ID3TAG LADSPA LAME MAD MIDI \
SBSMS SOUNDTOUCH TWOLAME VAMP VORBIS VST
OPTIONS_DEFAULT= FLAC ID3TAG LADSPA MAD MIDI \
SBSMS SOUNDTOUCH TWOLAME VAMP VORBIS VST
@@ -59,7 +59,7 @@ VST_DESC= VST plug-in support
CONFIGURE_ENV+= WX_CONFIG="${WX_CONFIG}"
-CONFIGURE_ARGS+= --with-lib-preference="local system" --without-lv2 --without-ffmpeg \
+CONFIGURE_ARGS+= --with-lib-preference="local system" --without-lv2 \
--enable-portaudio --enable-unicode --with-libsoxr
CONFIGURE_SHELL?=${LOCALBASE}/bin/bash
@@ -69,6 +69,9 @@ DEBUG_CONFIGURE_WITH= debug
DOCS_BUILD_DEPENDS= docbook-to-man:${PORTSDIR}/textproc/docbook-to-man \
docbook2man:${PORTSDIR}/textproc/docbook-utils
+FFMPEG_CONFIGURE_WITH= ffmpeg=system
+FFMPEG_LIB_DEPENDS= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
+
FLAC_CONFIGURE_WITH= libflac
FLAC_LIB_DEPENDS= libFLAC.so:${PORTSDIR}/audio/flac