aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authortrasz <trasz@FreeBSD.org>2008-11-08 20:09:28 +0800
committertrasz <trasz@FreeBSD.org>2008-11-08 20:09:28 +0800
commitfab65d713c41c7ee0c82c3a4eb44cbbbfd9f5f97 (patch)
treefca811609a57ab25769471ee460468f2250477fa /audio
parent783544b14ed58580fc23e084d5cac9cbb9d37b54 (diff)
downloadfreebsd-ports-gnome-fab65d713c41c7ee0c82c3a4eb44cbbbfd9f5f97.tar.gz
freebsd-ports-gnome-fab65d713c41c7ee0c82c3a4eb44cbbbfd9f5f97.tar.zst
freebsd-ports-gnome-fab65d713c41c7ee0c82c3a4eb44cbbbfd9f5f97.zip
Fix build after recent audio/jack update.
PR: ports/125900
Diffstat (limited to 'audio')
-rw-r--r--audio/ghostess/Makefile9
-rw-r--r--audio/ghostess/files/patch-src-ghostess.c22
-rw-r--r--audio/specimen/Makefile7
-rw-r--r--audio/specimen/files/patch-src-jackdriver.c20
4 files changed, 53 insertions, 5 deletions
diff --git a/audio/ghostess/Makefile b/audio/ghostess/Makefile
index 50ab6f532c0f..464c7dc892c3 100644
--- a/audio/ghostess/Makefile
+++ b/audio/ghostess/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ghostess
PORTVERSION= 20061127
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= http://home.jps.net/~musound/
@@ -17,7 +17,12 @@ COMMENT= Graphical DSSI host with JACK MIDI support
LIB_DEPENDS= dssialsacompat.0:${PORTSDIR}/audio/libdssialsacompat \
lo.6:${PORTSDIR}/audio/liblo \
jack.0:${PORTSDIR}/audio/jack
-BUILD_DEPENDS= ${LOCALBASE}/include/dssi.h:${PORTSDIR}/audio/dssi
+BUILD_DEPENDS= ${LOCALBASE}/include/dssi.h:${PORTSDIR}/audio/dssi \
+ jackit>=0.109.2:${PORTSDIR}/audio/jack
+
+# Between 0.109.0 and earlier versions there was an api change in JACK.
+# However, the library version number was not changed. The line above
+# is supposed to work around that.
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-jackmidi
diff --git a/audio/ghostess/files/patch-src-ghostess.c b/audio/ghostess/files/patch-src-ghostess.c
index 3f50304bc872..910215fe1730 100644
--- a/audio/ghostess/files/patch-src-ghostess.c
+++ b/audio/ghostess/files/patch-src-ghostess.c
@@ -1,5 +1,5 @@
---- src/ghostess.c.orig Sat Jan 13 19:36:01 2007
-+++ src/ghostess.c Sat Jan 13 19:36:18 2007
+--- src/ghostess.c.orig 2006-11-28 06:39:41.000000000 +0100
++++ src/ghostess.c 2008-07-23 01:33:28.000000000 +0200
@@ -56,6 +56,7 @@
#include <dirent.h>
#include <pthread.h>
@@ -8,3 +8,21 @@
#include <gtk/gtk.h>
+@@ -232,7 +233,7 @@
+ void* midi_port_buf = jack_port_get_buffer(midi_input_port, nframes);
+ jack_midi_event_t jack_midi_event;
+ jack_nframes_t jack_midi_event_index = 0;
+- jack_nframes_t jack_midi_event_count = jack_midi_get_event_count(midi_port_buf, nframes);
++ jack_nframes_t jack_midi_event_count = jack_midi_get_event_count(midi_port_buf);
+ static snd_seq_event_t jack_seq_event_holder[3];
+ snd_seq_event_t *jack_seq_event = NULL, *osc_seq_event = NULL;
+ int had_midi_overflow = 0;
+@@ -258,7 +259,7 @@
+
+ int count;
+
+- jack_midi_event_get(&jack_midi_event, midi_port_buf, jack_midi_event_index, nframes);
++ jack_midi_event_get(&jack_midi_event, midi_port_buf, jack_midi_event_index);
+ jack_midi_event_index++;
+
+ jack_seq_event = jack_seq_event_holder;
diff --git a/audio/specimen/Makefile b/audio/specimen/Makefile
index 72ac5023988e..2c48756d1824 100644
--- a/audio/specimen/Makefile
+++ b/audio/specimen/Makefile
@@ -7,7 +7,7 @@
PORTNAME= specimen
DISTVERSION= 0.5.2-rc3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://zhevny.com/specimen/files/
@@ -19,6 +19,11 @@ LIB_DEPENDS= phat.0:${PORTSDIR}/x11-toolkits/phat \
samplerate.1:${PORTSDIR}/audio/libsamplerate \
sndfile.1:${PORTSDIR}/audio/libsndfile \
lash.2:${PORTSDIR}/audio/lash
+BUILD_DEPENDS= jackit>=0.109.2:${PORTSDIR}/audio/jack
+
+# Between 0.109.0 and earlier versions there was an api change in JACK.
+# However, the library version number was not changed. The line above
+# is supposed to work around that.
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/audio/specimen/files/patch-src-jackdriver.c b/audio/specimen/files/patch-src-jackdriver.c
new file mode 100644
index 000000000000..289e7750ce61
--- /dev/null
+++ b/audio/specimen/files/patch-src-jackdriver.c
@@ -0,0 +1,20 @@
+--- src/jackdriver.c.orig 2008-07-23 13:54:34.000000000 +0200
++++ src/jackdriver.c 2008-07-23 13:54:49.000000000 +0200
+@@ -81,7 +81,7 @@
+ jack_midi_event_t jack_midi_event;
+ jack_nframes_t event_index = 0;
+ #ifdef HAVE_JACK_MIDI
+- jack_nframes_t event_count = jack_midi_get_event_count(midi_buf, frames);
++ jack_nframes_t event_count = jack_midi_get_event_count(midi_buf);
+ #endif /* HAVE_JACK_MIDI */
+ #ifdef HAVE_OLD_JACK_MIDI
+ jack_nframes_t event_count = jack_midi_port_get_info(midi_buf, frames)->event_count;
+@@ -123,7 +123,7 @@
+ /* send the JACK MIDI events to the mixer */
+ while (event_index < event_count) {
+
+- jack_midi_event_get(&jack_midi_event, midi_buf,event_index, frames);
++ jack_midi_event_get(&jack_midi_event, midi_buf,event_index);
+ midi_data = jack_midi_event.buffer;
+
+ /* TODO: handle 14-bit controllers and RPNs and NRPNs */