aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/autobench
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-05-26 05:38:13 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-05-26 05:38:13 +0800
commit33949394b5b97efbd5ff6e418b9860a636490acc (patch)
tree45912870eb6a537755186b4aec55272c37c5d298 /benchmarks/autobench
parent0d1ba21250701a0e12db6c7a6cf8b4f7b1095a2a (diff)
downloadfreebsd-ports-gnome-33949394b5b97efbd5ff6e418b9860a636490acc.tar.gz
freebsd-ports-gnome-33949394b5b97efbd5ff6e418b9860a636490acc.tar.zst
freebsd-ports-gnome-33949394b5b97efbd5ff6e418b9860a636490acc.zip
- Install programs/scripts/manpages/data files with corresponding INSTALL_* commands, which fixes permissions and stripping
- Add LICENSE_FILE - Pet portlint
Diffstat (limited to 'benchmarks/autobench')
-rw-r--r--benchmarks/autobench/Makefile7
-rw-r--r--benchmarks/autobench/files/patch-Makefile13
2 files changed, 11 insertions, 9 deletions
diff --git a/benchmarks/autobench/Makefile b/benchmarks/autobench/Makefile
index 542a332a3e0f..611593340835 100644
--- a/benchmarks/autobench/Makefile
+++ b/benchmarks/autobench/Makefile
@@ -3,7 +3,7 @@
PORTNAME= autobench
PORTVERSION= 2.1.2
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= benchmarks www
MASTER_SITES= http://www.xenoclast.org/autobench/downloads/ \
http://www.sfr-fresh.com/unix/privat/
@@ -11,12 +11,13 @@ MASTER_SITES= http://www.xenoclast.org/autobench/downloads/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Automating the process of benchmarking a web server
+LICENSE= GPLv2 # or later
+LICENSE_FILE= ${WRKSRC}/LICENCE
+
RUN_DEPENDS= httperf:${PORTSDIR}/benchmarks/httperf \
gawk:${PORTSDIR}/lang/gawk \
gnuplot:${PORTSDIR}/math/gnuplot
-LICENSE= GPLv2
-
USES= gmake perl5 shebangfix
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" DEBUG_FLAGS= \
PREFIX=${PREFIX}
diff --git a/benchmarks/autobench/files/patch-Makefile b/benchmarks/autobench/files/patch-Makefile
index ede19bb0eaa7..4a1bac0a4440 100644
--- a/benchmarks/autobench/files/patch-Makefile
+++ b/benchmarks/autobench/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2004-05-28 00:59:27.000000000 +0800
-+++ Makefile 2014-06-13 22:45:30.432113271 +0800
-@@ -51,11 +51,11 @@ debug: crfile.c
+--- Makefile.orig 2004-05-27 16:59:27 UTC
++++ Makefile
+@@ -51,11 +51,12 @@ debug: crfile.c
$(CC) $(DEBUG_FLAGS) -o crfile crfile.c
install: crfile sesslog
@@ -10,9 +10,10 @@
- cp crfile autobench autobenchd autobench_admin sesslog bench2graph $(BINDIR)
- cp autobenchd.1 autobench_admin.1 crfile.1 autobench.1 sesslog.1 bench2graph.1 $(MANDIR)
- cp autobench.conf $(ETCDIR)
-+ cp crfile autobench autobenchd autobench_admin sesslog bench2graph $(DESTDIR)$(BINDIR)
-+ cp autobenchd.1 autobench_admin.1 crfile.1 autobench.1 sesslog.1 bench2graph.1 $(DESTDIR)$(MANDIR)
-+ cp autobench.conf $(DESTDIR)$(ETCDIR)/autobench.conf.sample
++ ${BSD_INSTALL_PROGRAM} crfile sesslog $(DESTDIR)$(BINDIR)
++ ${BSD_INSTALL_SCRIPT} autobench autobenchd autobench_admin bench2graph $(DESTDIR)$(BINDIR)
++ ${BSD_INSTALL_MAN} autobenchd.1 autobench_admin.1 crfile.1 autobench.1 sesslog.1 bench2graph.1 $(DESTDIR)$(MANDIR)
++ ${BSD_INSTALL_DATA} autobench.conf $(DESTDIR)$(ETCDIR)/autobench.conf.sample
clean:
rm -f crfile sesslog