aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/dbs/Makefile
diff options
context:
space:
mode:
authorjkoshy <jkoshy@FreeBSD.org>1998-08-02 07:34:42 +0800
committerjkoshy <jkoshy@FreeBSD.org>1998-08-02 07:34:42 +0800
commit4720d265b88a9a7b75a9f7db4285d70f2bd2254a (patch)
treef9869c57254f54303d9bc2e6e7d4f11abfd2f7d8 /benchmarks/dbs/Makefile
parentacd4bcafbe6a83888b9ce3c0224d2e3146ee1d52 (diff)
downloadfreebsd-ports-gnome-4720d265b88a9a7b75a9f7db4285d70f2bd2254a.tar.gz
freebsd-ports-gnome-4720d265b88a9a7b75a9f7db4285d70f2bd2254a.tar.zst
freebsd-ports-gnome-4720d265b88a9a7b75a9f7db4285d70f2bd2254a.zip
A distributed benchmarking system for TCP networks.
Diffstat (limited to 'benchmarks/dbs/Makefile')
-rw-r--r--benchmarks/dbs/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/benchmarks/dbs/Makefile b/benchmarks/dbs/Makefile
new file mode 100644
index 000000000000..1d5458a3b956
--- /dev/null
+++ b/benchmarks/dbs/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: dbs
+# Version required: 1.1.5
+# Date created: 1 August 1998
+# Whom: jkoshy
+#
+# $Id$
+#
+
+DISTNAME= dbs-1.1.5
+CATEGORIES= benchmarks
+MASTER_SITES= http://shika.aist-nara.ac.jp/member/yukio-m/dbs/software1.1.5/
+
+MAINTAINER= jkoshy@freebsd.org
+
+DOCDIR= ${PREFIX}/share/doc/dbs/
+DOCS= dbs.man dbs.man.jis dbs_paper.ps Copyright
+EXDIR= ${PREFIX}/share/examples/dbs/
+EXS= TCP2.cmd TCPvsMPEG.cmd
+
+do-build:
+ cd ${WRKSRC}/src; ${MAKE} dir
+ cd ${WRKSRC}/obj/${OPSYS}; ${MAKE} ${ALL_TARGET} PREFIX=${PREFIX}
+
+do-install:
+ cd ${WRKSRC}/obj/${OPSYS}; ${MAKE} ${INSTALL_TARGET} PREFIX=${PREFIX}
+ strip ${PREFIX}/bin/dbsc ${PREFIX}/bin/dbsd
+ ${MKDIR} ${EXDIR}
+ cd ${WRKSRC}/sample; ${CP} -p ${EXS} ${EXDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCDIR}
+ cd ${WRKSRC}/doc; ${CP} -p ${DOCS} ${DOCDIR}
+.endif
+
+.include <bsd.port.mk>