aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/fio
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-06-11 13:02:04 +0800
committerMark Linimon <linimon@FreeBSD.org>2018-06-11 13:02:04 +0800
commitc9a131d26bec93e503f488f63f7f36a5a261b8af (patch)
tree0263f00b9b05793ce21a6d36589f8d83a90d0d3e /benchmarks/fio
parentc412683a95bf11420aefc1a0978ef930a639c576 (diff)
downloadfreebsd-ports-gnome-c9a131d26bec93e503f488f63f7f36a5a261b8af.tar.gz
freebsd-ports-gnome-c9a131d26bec93e503f488f63f7f36a5a261b8af.tar.zst
freebsd-ports-gnome-c9a131d26bec93e503f488f63f7f36a5a261b8af.zip
Apparently works on aarch64.
While here, pet portlint. PR: 228042 (partial) Submitted by: mikael.urankar
Diffstat (limited to 'benchmarks/fio')
-rw-r--r--benchmarks/fio/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/benchmarks/fio/Makefile b/benchmarks/fio/Makefile
index 442aee87eefb..e7e68a5dd42c 100644
--- a/benchmarks/fio/Makefile
+++ b/benchmarks/fio/Makefile
@@ -11,6 +11,9 @@ COMMENT= FIO - flexible IO tester
LICENSE= GPLv2
+BROKEN_armv6= Fails to compile: unsupported ARM architecture
+BROKEN_armv7= Fails to compile: unsupported ARM architecture
+
USES= gmake tar:bzip2
OPTIONS_DEFINE= GNUPLOT EXAMPLES
@@ -18,9 +21,6 @@ GNUPLOT_DESC= Support for plotting graphs
GNUPLOT_BUILD_DEPENDS= ${LOCALBASE}/bin/gnuplot:math/gnuplot
-BROKEN_aarch64= Fails to compile: undefined symbol: getauxval
-BROKEN_armv6= Fails to compile: unsupported ARM architecture
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fio ${STAGEDIR}${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/tools/fio_generate_plots ${STAGEDIR}${PREFIX}/bin