aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/hpl
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-02-17 01:15:31 +0800
committertijl <tijl@FreeBSD.org>2014-02-17 01:15:31 +0800
commitf86cbfadd2dbfab1dc1ea72e5084a23c10b1dc6c (patch)
tree49e521faa408bc4bd163bfb0febf91e262772c1c /benchmarks/hpl
parente04e533cf1bc01e44ad69d14d5c6c205e25bfe3a (diff)
downloadfreebsd-ports-gnome-f86cbfadd2dbfab1dc1ea72e5084a23c10b1dc6c.tar.gz
freebsd-ports-gnome-f86cbfadd2dbfab1dc1ea72e5084a23c10b1dc6c.tar.zst
freebsd-ports-gnome-f86cbfadd2dbfab1dc1ea72e5084a23c10b1dc6c.zip
Convert all USE_FORTRAN=yes to "USES=fortran, USE_GCC=yes". In most cases
USE_GCC=yes has been omitted though. Remove USE_FORTRAN handling from bsd.port.mk and bsd.gcc.mk. Minor cleanups in some ports like USE_GMAKE, NOPORTDOCS,... Exp-run: bdrewery Approved by: portmgr (bdrewery)
Diffstat (limited to 'benchmarks/hpl')
-rw-r--r--benchmarks/hpl/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/benchmarks/hpl/Makefile b/benchmarks/hpl/Makefile
index 2db524d36734..3a302e8b5073 100644
--- a/benchmarks/hpl/Makefile
+++ b/benchmarks/hpl/Makefile
@@ -14,7 +14,7 @@ COMMENT= High Performance Computing Linpack Benchmark
LIB_DEPENDS= libblas.so:${PORTSDIR}/math/blas \
libmpich.so:${PORTSDIR}/net/mpich2
-USE_FORTRAN= yes
+USES= fortran
USE_LDCONFIG= yes
HPL_ARCH?= FreeBSD_PIV_CBLAS
MAKE_ARGS= arch=${HPL_ARCH}