aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/iozone
diff options
context:
space:
mode:
authorjmz <jmz@FreeBSD.org>2006-02-10 18:12:29 +0800
committerjmz <jmz@FreeBSD.org>2006-02-10 18:12:29 +0800
commitc15d237e9cc760963bd63dc56684704bf349d98a (patch)
treeb5d15b3410f352a32b5a3c12eb4dc08a08a82e99 /benchmarks/iozone
parent6e83b9be336e78cd165306aa08af871f076ea71b (diff)
downloadfreebsd-ports-gnome-c15d237e9cc760963bd63dc56684704bf349d98a.tar.gz
freebsd-ports-gnome-c15d237e9cc760963bd63dc56684704bf349d98a.tar.zst
freebsd-ports-gnome-c15d237e9cc760963bd63dc56684704bf349d98a.zip
Use the right fix (PTHREAD_LIBS) to build on all OS versions.
Eagle eyes: kris
Diffstat (limited to 'benchmarks/iozone')
-rw-r--r--benchmarks/iozone/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/benchmarks/iozone/Makefile b/benchmarks/iozone/Makefile
index 146c7004f769..047ff0c21b5b 100644
--- a/benchmarks/iozone/Makefile
+++ b/benchmarks/iozone/Makefile
@@ -27,15 +27,13 @@ ALL_TARGET=
MAN1= iozone.1
PLIST_FILES= bin/iozone
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} > 500000
OPTIONS= THREADS "Enable threading (uses pthreads)" on
-.endif
+
+.include <bsd.port.pre.mk>
.if defined (WITH_THREADS)
-CFLAGS+= -pthread
-MAKE_ENV= LDFLAGS=-lpthread
+CFLAGS+= ${PTHREAD_CFLAGS}
+MAKE_ENV= LDFLAGS=${PTHREAD_LIBS}
.else
CFLAGS+=-DNO_THREADS
.endif