aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/py-locust/Makefile
diff options
context:
space:
mode:
authoregypcio <egypcio@FreeBSD.org>2019-01-20 20:54:30 +0800
committeregypcio <egypcio@FreeBSD.org>2019-01-20 20:54:30 +0800
commit86a8074f0f8ce58b0350db4a5fa01a97e908eec0 (patch)
treecf48db9b35cfc5a7de462164883277362c465afe /benchmarks/py-locust/Makefile
parent6cb3f6fbae1ed2f93dfc554b37e8e48e96b85c4a (diff)
downloadfreebsd-ports-gnome-86a8074f0f8ce58b0350db4a5fa01a97e908eec0.tar.gz
freebsd-ports-gnome-86a8074f0f8ce58b0350db4a5fa01a97e908eec0.tar.zst
freebsd-ports-gnome-86a8074f0f8ce58b0350db4a5fa01a97e908eec0.zip
[NEW] benchmarks/py-locust: Python utility for doing distributed load tests
Locust is an easy-to-use, distributed, user load testing tool. It is intended for load-testing web sites (or other systems) and figuring out how many concurrent users a system can handle. The behavior of each locust (or test user if you will) is defined by you and the swarming process is monitored from a web UI in real-time. This will help you battle test and identify bottlenecks in your code before letting real users in. WWW: https://locust.io/ Approved by: araujo (mentor), rene (mentor) Sponsored by: cleverbridge AG Differential Revision: https://reviews.freebsd.org/D18895
Diffstat (limited to 'benchmarks/py-locust/Makefile')
-rw-r--r--benchmarks/py-locust/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/benchmarks/py-locust/Makefile b/benchmarks/py-locust/Makefile
new file mode 100644
index 000000000000..780e7dd8d8bd
--- /dev/null
+++ b/benchmarks/py-locust/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= locust
+PORTVERSION= 0.9.0
+CATEGORIES= benchmarks www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= locustio-${PORTVERSION}
+
+MAINTAINER= egypcio@FreeBSD.org
+COMMENT= Python utility for doing easy, distributed load testing
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Flask>=0.10.1:www/py-flask@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}gevent>=1.2.2:devel/py-gevent@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}msgpack>=0.4.2:devel/py-msgpack@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyzmq>=16.0.2:net/py-pyzmq@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.9.1:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.10.0:devel/py-six@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+OPTIONS_DEFINE= EXAMPLES
+
+post-install-EXAMPLES-on:
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${FILESDIR}/extra-EXAMPLES* ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>