aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/sipp
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2005-10-01 03:51:42 +0800
committersobomax <sobomax@FreeBSD.org>2005-10-01 03:51:42 +0800
commit766b7f9ea79ae908f1e13cec9525598696804210 (patch)
treed6e48f2b6d4c170d3c0f0e244c628b4687237994 /benchmarks/sipp
parentd0bf7d7da68ba3f5191828e25bf65b96d14e4c9a (diff)
downloadfreebsd-ports-gnome-766b7f9ea79ae908f1e13cec9525598696804210.tar.gz
freebsd-ports-gnome-766b7f9ea79ae908f1e13cec9525598696804210.tar.zst
freebsd-ports-gnome-766b7f9ea79ae908f1e13cec9525598696804210.zip
Respect CC, CXX, CFLAGS and CXXFLAGS.
Diffstat (limited to 'benchmarks/sipp')
-rw-r--r--benchmarks/sipp/Makefile2
-rw-r--r--benchmarks/sipp/files/patch-Makefile50
2 files changed, 52 insertions, 0 deletions
diff --git a/benchmarks/sipp/Makefile b/benchmarks/sipp/Makefile
index 24e49856feac..f5dfd9aaf93f 100644
--- a/benchmarks/sipp/Makefile
+++ b/benchmarks/sipp/Makefile
@@ -19,6 +19,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES= bin/sipp
MAN1= sipp.1
+MAKE_ENV= CPP="${CXX}" CPPFLAGS="${CXXFLAGS}" CCLINK="${CXX}"
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64"
diff --git a/benchmarks/sipp/files/patch-Makefile b/benchmarks/sipp/files/patch-Makefile
new file mode 100644
index 000000000000..3ff53349ff04
--- /dev/null
+++ b/benchmarks/sipp/files/patch-Makefile
@@ -0,0 +1,50 @@
+
+$FreeBSD$
+
+--- Makefile.orig
++++ Makefile
+@@ -64,7 +64,7 @@
+ CC_tru64=cc
+ CC_SunOS=gcc
+ CC_Cygwin=cc
+-CC=$(CC_$(SYSTEM))
++CC?=$(CC_$(SYSTEM))
+
+ # C++ compiler mapping
+ CPP_hpux=aCC
+@@ -73,7 +73,7 @@
+ CPP_tru64=cxx
+ CPP_SunOS=g++
+ CPP_Cygwin=g++
+-CPP=$(CPP_$(SYSTEM))
++CPP?=$(CPP_$(SYSTEM))
+
+ #Model specific flags
+ MFLAGS_ia64=+DD64
+@@ -94,7 +94,7 @@
+ CFLAGS_tru64=-D__OSF1 -pthread
+ CFLAGS_SunOS=-g
+ CFLAGS_Cygwin=-D__CYGWIN -Dsocklen_t=int
+-CFLAGS=$(CFLAGS_$(SYSTEM)) -D__3PCC__ $(TLS)
++CFLAGS+=$(CFLAGS_$(SYSTEM)) -D__3PCC__ $(TLS)
+
+ #C++ Compiler Flags
+ CPPFLAGS_hpux=-AA -mt -D__HPUX +W829
+@@ -103,7 +103,7 @@
+ CPPFLAGS_tru64=-D__OSF1 -pthread
+ CPPFLAGS_SunOS=-g
+ CPPFLAGS_Cygwin=-D__CYGWIN -Dsocklen_t=int
+-CPPFLAGS=$(CPPFLAGS_$(SYSTEM)) -D__3PCC__ $(TLS)
++CPPFLAGS+=$(CPPFLAGS_$(SYSTEM)) -D__3PCC__ $(TLS)
+
+ #Linker mapping
+ CCLINK_hpux=aCC
+@@ -112,7 +112,7 @@
+ CCLINK_tru64=cxx
+ CCLINK_SunOS=gcc
+ CCLINK_Cygwin=g++
+-CCLINK=$(CCLINK_$(SYSTEM))
++CCLINK?=$(CCLINK_$(SYSTEM))
+
+ #Linker Flags
+ LFLAGS_hpux=-AA -mt