aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/unixbench/Makefile
diff options
context:
space:
mode:
authorse <se@FreeBSD.org>1996-01-03 08:06:21 +0800
committerse <se@FreeBSD.org>1996-01-03 08:06:21 +0800
commitbe42cf355258f6f7cec97043c39406e37e1c0a22 (patch)
tree5988d8bf2357a241e5beb3bdb73d6f7b7089afdb /benchmarks/unixbench/Makefile
parent78d738d90c898448746ffc25638f9e24cdc96c9e (diff)
downloadfreebsd-ports-gnome-be42cf355258f6f7cec97043c39406e37e1c0a22.tar.gz
freebsd-ports-gnome-be42cf355258f6f7cec97043c39406e37e1c0a22.tar.zst
freebsd-ports-gnome-be42cf355258f6f7cec97043c39406e37e1c0a22.zip
Specify TMPDIR and RESULTDIR outside the /usr tree, or a R/O /usr will
prevent the tests from running.
Diffstat (limited to 'benchmarks/unixbench/Makefile')
-rw-r--r--benchmarks/unixbench/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/benchmarks/unixbench/Makefile b/benchmarks/unixbench/Makefile
index 8f198db74601..98a5fc4ba822 100644
--- a/benchmarks/unixbench/Makefile
+++ b/benchmarks/unixbench/Makefile
@@ -17,8 +17,20 @@ do-install:
-mkdir -p $(PREFIX)/lib/bytebench
for f in Makefile README Run doc pgms results testdir; \
do cp -R $(WRKSRC)/$$f $(PREFIX)/lib/bytebench; done
- echo "!#/bin/sh" > $(PREFIX)/bin/bytebench
- echo "$(PREFIX)/lib/bytebench/Run" >> $(PREFIX)/bin/bytebench
+ echo "#!/bin/sh" > $(PREFIX)/bin/bytebench
+ echo "TMPDIR=/var/tmp" >> $(PREFIX)/bin/bytebench
+ echo "RESULTDIR=/tmp" >> $(PREFIX)/bin/bytebench
+ echo "export TMPDIR RESULTDIR" >> $(PREFIX)/bin/bytebench
+ echo "cd $(PREFIX)/lib/bytebench" >> $(PREFIX)/bin/bytebench
+ echo "exec ./Run" >> $(PREFIX)/bin/bytebench
chmod 755 $(PREFIX)/bin/bytebench
+ chmod 644 $(PREFIX)/lib/bytebench/Makefile
+ chmod 644 $(PREFIX)/lib/bytebench/README
+ chmod 755 $(PREFIX)/lib/bytebench/Run
+ chmod 755 $(PREFIX)/lib/bytebench/doc
+ chmod 755 $(PREFIX)/lib/bytebench/pgms
+ chmod 755 $(PREFIX)/lib/bytebench/pgms/*
+ chmod 755 $(PREFIX)/lib/bytebench/results
+ chmod 755 $(PREFIX)/lib/bytebench/testdir
.include <bsd.port.mk>