aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
authorLuca Pizzamiglio <pizzamig@FreeBSD.org>2017-09-05 15:53:13 +0800
committerLuca Pizzamiglio <pizzamig@FreeBSD.org>2017-09-05 15:53:13 +0800
commit1c9863b704528439a4827b751d10f2e411f5f71e (patch)
treede7d6ce9cec438142aa36f201a805ebb89ae1585 /benchmarks
parentbb3d132f7e35cf4af34de11ef8a1bf05d7e257b4 (diff)
downloadfreebsd-ports-gnome-1c9863b704528439a4827b751d10f2e411f5f71e.tar.gz
freebsd-ports-gnome-1c9863b704528439a4827b751d10f2e411f5f71e.tar.zst
freebsd-ports-gnome-1c9863b704528439a4827b751d10f2e411f5f71e.zip
benchmarks/unixbench: updating to version 5.1.3
While I'm here: * updating MAINTAINER entry * adding the proper dependencies Reviewed by: mat Approved by: olivier (mentor) Differential Revision: https://reviews.freebsd.org/D12224
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/unixbench/Makefile63
-rw-r--r--benchmarks/unixbench/distinfo5
-rw-r--r--benchmarks/unixbench/files/patch-Makefile42
-rw-r--r--benchmarks/unixbench/files/patch-Run130
-rw-r--r--benchmarks/unixbench/files/patch-pgms_cleanup.sh13
-rw-r--r--benchmarks/unixbench/files/patch-pgms_multi.sh4
-rw-r--r--benchmarks/unixbench/files/patch-pgms_tst.sh6
-rw-r--r--benchmarks/unixbench/files/patch-src_big.c11
-rw-r--r--benchmarks/unixbench/files/patch-src_dhry__1.c2
-rw-r--r--benchmarks/unixbench/files/patch-src_execl.c11
-rw-r--r--benchmarks/unixbench/files/patch-src_syscall.c11
-rw-r--r--benchmarks/unixbench/pkg-descr4
-rw-r--r--benchmarks/unixbench/pkg-message2
-rw-r--r--benchmarks/unixbench/pkg-plist71
14 files changed, 190 insertions, 185 deletions
diff --git a/benchmarks/unixbench/Makefile b/benchmarks/unixbench/Makefile
index 57c9802450dd..a7ea8a680271 100644
--- a/benchmarks/unixbench/Makefile
+++ b/benchmarks/unixbench/Makefile
@@ -2,48 +2,49 @@
# $FreeBSD$
PORTNAME= unixbench
-PORTVERSION= 4.1.0
-PORTREVISION= 2
+DISTVERSIONPREFIX= v
+DISTVERSION= 5.1.3
CATEGORIES= benchmarks
-MASTER_SITES= http://ftp.osuosl.org/pub/nslu2/sources/ \
- http://www.tux.org/pub/tux/niemi/unixbench/
-MAINTAINER= luca.pizzamiglio@gmail.com
+MAINTAINER= pizzamig@FreeBSD.org
COMMENT= BYTE magazine's Public Domain benchmark for UNIX
-USES= shebangfix tar:tgz
-SHEBANG_FILES= pgms/perlbench
-SUB_FILES= unixbench
-MAKE_JOBS_UNSAFE= yes
+LICENSE= GPLv2
+
+RUN_DEPENDS= x11perf:x11/x11perf
-post-extract:
- ${RM} ${WRKSRC}/pgms/select
+USES= gmake perl5 shebangfix
+USE_GITHUB= yes
+GH_ACCOUNT= kdlucas
+GH_PROJECT= byte-unixbench
+WRKSRC_SUBDIR= UnixBench
+
+SUB_FILES= unixbench
+SHEBANG_FILES= Run pgms/gfx-x11
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/unixbench ${STAGEDIR}${PREFIX}/bin/
- ${MKDIR} ${STAGEDIR}${PREFIX}/lib/unixbench
- for f in Run ; do \
- ${INSTALL_SCRIPT} ${WRKSRC}/$${f} ${STAGEDIR}${PREFIX}/lib/unixbench/ ; \
- done
- for f in Makefile README ; do \
- ${INSTALL_DATA} ${WRKSRC}/$${f} ${STAGEDIR}${PREFIX}/lib/unixbench/ ; \
- done
- ${MKDIR} ${STAGEDIR}${PREFIX}/lib/unixbench/pgms
+ ${MKDIR} ${STAGEDIR}${PREFIX}/libexec/unixbench
+ ${INSTALL_SCRIPT} ${WRKSRC}/Run ${STAGEDIR}${PREFIX}/libexec/unixbench
+ ${MKDIR} ${STAGEDIR}${PREFIX}/libexec/unixbench/pgms
for f in ${WRKSRC}/pgms/* ; do \
case $$f in \
- *.awk|*.sh|*perlbench) \
- ${INSTALL_SCRIPT} $${f} ${STAGEDIR}${PREFIX}/lib/unixbench/pgms/ ;; \
- *.logo|*.base) \
- ${INSTALL_SCRIPT} $${f} ${STAGEDIR}${PREFIX}/lib/unixbench/pgms/ ;; \
- *.orig|*.rej|*~) \
- ;;\
- *) \
- ${INSTALL_PROGRAM} $${f} ${STAGEDIR}${PREFIX}/lib/unixbench/pgms/ ;; \
+ *.sh|*gfx-x11) \
+ ${INSTALL_SCRIPT} $${f} \
+ ${STAGEDIR}${PREFIX}/libexec/unixbench/pgms/ ;; \
+ *.logo|*.base) \
+ ${INSTALL_DATA} $${f} \
+ ${STAGEDIR}${PREFIX}/libexec/unixbench/pgms/ ;; \
+ *.orig|*.rej|*~) \
+ ;;\
+ *) \
+ ${INSTALL_PROGRAM} $${f} \
+ ${STAGEDIR}${PREFIX}/libexec/unixbench/pgms/ ;; \
esac ; \
done
- -${MKDIR} ${STAGEDIR}${PREFIX}/lib/unixbench/testdir
- for f in ${WRKSRC}/testdir/* ; do \
- ${INSTALL_DATA} $${f} ${STAGEDIR}${PREFIX}/lib/unixbench/testdir/ ; \
- done
+ ${MKDIR} ${STAGEDIR}${PREFIX}/libexec/unixbench/testdir
+ ${INSTALL_DATA} ${WRKSRC}/testdir/* ${STAGEDIR}${PREFIX}/libexec/unixbench/testdir/
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${PREFIX}/libexec/unixbench/
+ ${INSTALL_DATA} ${WRKSRC}/Makefile ${STAGEDIR}${PREFIX}/libexec/unixbench/
.include <bsd.port.mk>
diff --git a/benchmarks/unixbench/distinfo b/benchmarks/unixbench/distinfo
index 048c98f2d29f..0916f4bbfc18 100644
--- a/benchmarks/unixbench/distinfo
+++ b/benchmarks/unixbench/distinfo
@@ -1,2 +1,3 @@
-SHA256 (unixbench-4.1.0.tgz) = 4605f3f0001afd3af91ffb554dfd65c5cd313b6b9ada52ae8b2efdccf894cfa2
-SIZE (unixbench-4.1.0.tgz) = 63075
+TIMESTAMP = 1503481858
+SHA256 (kdlucas-byte-unixbench-v5.1.3_GH0.tar.gz) = 3a6bb00f270a5329682dff20fd2c1ab5332ef046eb54a96a0d7bd371005d31a3
+SIZE (kdlucas-byte-unixbench-v5.1.3_GH0.tar.gz) = 145908
diff --git a/benchmarks/unixbench/files/patch-Makefile b/benchmarks/unixbench/files/patch-Makefile
index bb9d8cbe648d..f0ddc57d3c29 100644
--- a/benchmarks/unixbench/files/patch-Makefile
+++ b/benchmarks/unixbench/files/patch-Makefile
@@ -1,40 +1,46 @@
---- Makefile.orig 1999-07-28 22:05:02 UTC
+--- Makefile.orig 2015-06-04 17:20:18 UTC
+++ Makefile
-@@ -30,9 +30,7 @@
+@@ -38,7 +38,7 @@
##############################################################################
- ID="@(#)Makefile:3.9 -- 5/15/91 19:30:15";
+
SHELL = /bin/sh
--#HZ = ???? #(read from environment)
--CFLAGS = -DTIME
--CC=gcc
+-
+HZ = 128
+ # GRAPHICS TESTS: Uncomment the definition of "GRAPHIC_TESTS" to enable
+ # the building of the graphics benchmarks. This will require the
+ # X11 libraries on your system.
+@@ -53,7 +53,7 @@ GL_LIBS = -lGL -lXext -lX11
+ # COMPILER CONFIGURATION: Set "CC" to the name of the compiler to use
+ # to build the binary benchmarks. You should also set "$cCompiler" in the
+ # Run script to the name of the compiler you want to test.
+-CC=gcc
++#CC=gcc
- ## For Linux 486/Pentium, GCC 2.7.x and 2.8.x
- #OPTON = -O2 -fomit-frame-pointer -fforce-addr -fforce-mem -ffast-math \
-@@ -44,7 +42,7 @@ CC=gcc
+ # OPTIMISATION SETTINGS:
+
+@@ -71,14 +71,14 @@ CC=gcc
# -m386 -malign-loops=1 -malign-jumps=1 -malign-functions=1
## For Solaris 2, or general-purpose GCC 2.7.x
--OPTON = -O2 -fomit-frame-pointer -fforce-addr -fforce-mem -ffast-math -Wall
-+#OPTON = -O2 -fomit-frame-pointer -fforce-addr -fforce-mem -ffast-math -Wall
+-OPTON = -O2 -fomit-frame-pointer -fforce-addr -ffast-math -Wall
++OPTON = -O2 -fomit-frame-pointer -ffast-math -Wall
- ## Very generic
- #OPTON = -O
-@@ -54,14 +52,14 @@ OPTON = -O2 -fomit-frame-pointer -fforce
+ ## For Digital Unix v4.x, with DEC cc v5.x
+ #OPTON = -O4
#CFLAGS = -DTIME -std1 -verbose -w0
- ## generic gcc CFLAGS. -DTIME must be included
+ ## generic gcc CFLAGS. -DTIME must be included.
-CFLAGS = -DTIME -Wall -pedantic -ansi
+CFLAGS += -DTIME -Wall -pedantic -ansi
- # local directories
+
+ ##############################################################################
+@@ -90,8 +90,6 @@ CFLAGS = -DTIME -Wall -pedantic -ansi
PROGDIR = ./pgms
SRCDIR = ./src
TESTDIR = ./testdir
-RESULTDIR = ./results
-TMPDIR = ./tmp
-+#RESULTDIR = ./results
-+#TMPDIR = /var/tmp
# other directories
INCLDIR = /usr/include
LIBDIR = /lib
diff --git a/benchmarks/unixbench/files/patch-Run b/benchmarks/unixbench/files/patch-Run
index 77dcee755c77..0661db387c74 100644
--- a/benchmarks/unixbench/files/patch-Run
+++ b/benchmarks/unixbench/files/patch-Run
@@ -1,61 +1,71 @@
---- Run.orig 1999-07-28 22:04:47 UTC
+--- Run.orig 2017-09-04 20:35:19 UTC
+++ Run
-@@ -88,11 +88,11 @@ else
- fi
-
- # check that the required files are in the proper places
--if make check; then
-- :
--else
-- make all
--fi
-+#if make check; then
-+# :
-+#else
-+# make all
-+#fi
-
-
- # establish full paths to directories
-@@ -114,7 +114,7 @@ cd $SCRPDIR
- SCRPDIR=`pwd`
- cd $_WD
-
--TMPDIR=${HOMEDIR}/tmp
-+TMPDIR=${TMPDIR-${HOMEDIR}/tmp}
- cd $TMPDIR
- TMPDIR=`pwd`
- cd $_WD
-@@ -367,10 +367,11 @@ do # line argument processing
- C)
- logmsg="C Compiler Throughput"
- prog="looper ${looper-60} ${CC} cctest.c"
-+ prog="looper ${looper-60} ${CC} cctest.c -o ${TMPDIR}/a.out"
- stdout=/dev/null
- repeat="$shortloop"
- cleanopt="-m $TMPTIMES"
-- rm -f ${TESTDIR}/cctest.o ${TESTDIR}/a.out
-+ rm -f ${TESTDIR}/cctest.o ${TMPDIR}/a.out
- ;;
-
- arithoh)
-@@ -385,8 +386,8 @@ do # line argument processing
-
- dc)
- logmsg="Dc: sqrt(2) to 99 decimal places"
-- prog="looper ${looper-30} dc"
-- stdin=dc.dat
-+ prog="looper ${looper-30} \"dc < ${TESTDIR}/dc.dat\""
-+ stdin=
- stdout=/dev/null
- cleanopt="-m $TMPTIMES"
- ;;
-@@ -508,7 +509,7 @@ do # line argument processing
- ########### some specific cleanup routines ##############
- case $bench in
- C)
-- rm -f ${TESTDIR}/cctest.o ${TESTDIR}/a.out
-+ rm -f ${TESTDIR}/cctest.o ${TMPDIR}/a.out
- ;;
-
- fstime | fsbuffer | fsdisk)
+@@ -91,10 +91,10 @@ chomp($BASEDIR);
+ my $BINDIR = getDir('UB_BINDIR', $BASEDIR . "/pgms");
+
+ # Temp directory, for temp files.
+-my $TMPDIR = getDir('UB_TMPDIR', $BASEDIR . "/tmp");
++my $TMPDIR = "/tmp";
+
+ # Directory to put results in.
+-my $RESULTDIR = getDir('UB_RESULTDIR', $BASEDIR . "/results");
++my $RESULTDIR = "/tmp";
+
+ # Directory where the tests are executed.
+ my $TESTDIR = getDir('UB_TESTDIR', $BASEDIR . "/testdir");
+@@ -735,12 +735,10 @@ sub getSystemInfo {
+
+ # Get the language info.
+ my $lang = getCmdOutput("printenv LANG");
+- my $map = getCmdOutput("locale -k LC_CTYPE | grep charmap");
++ my $map = getCmdOutput("locale -k | grep charmap");
+ $map =~ s/.*=//;
+- my $coll = getCmdOutput("locale -k LC_COLLATE | grep collate-codeset");
+- $coll =~ s/.*=//;
+- $info->{'language'} = sprintf "%s (charmap=%s, collate=%s)",
+- $lang, $map, $coll;
++ $info->{'language'} = sprintf "%s (charmap=%s)",
++ $lang, $map;
+
+ # Get details on the CPUs, if possible.
+ my $cpus = getCpuInfo();
+@@ -750,10 +748,9 @@ sub getSystemInfo {
+ }
+
+ # Get graphics hardware info.
+- $info->{'graphics'} = getCmdOutput("3dinfo | cut -f1 -d\'(\'");
++ # $info->{'graphics'} = getCmdOutput("3dinfo | cut -f1 -d\'(\'");
+
+ # Get system run state, load and usage info.
+- $info->{'runlevel'} = getCmdOutput("runlevel | cut -f2 -d\" \"");
+ $info->{'load'} = getCmdOutput("uptime");
+ $info->{'numUsers'} = getCmdOutput("who | wc -l");
+
+@@ -781,6 +778,7 @@ sub abortRun {
+
+ # Do checks that everything's ready for testing.
+ sub preChecks {
++ return;
+ # Set the language.
+ $ENV{'LANG'} = $language;
+
+@@ -1386,7 +1384,7 @@ sub displaySystem {
+ }
+
+ # Display system load and usage info.
+- printf $fd " %s; runlevel %s\n\n", $info->{'load'}, $info->{'runlevel'};
++ printf $fd " %s; \n\n", $info->{'load'};
+ }
+
+
+@@ -1603,8 +1601,8 @@ sub displaySystemHtml {
+ # Display system runlevel, load and usage info.
+ printf $fd "<tr>\n";
+ printf $fd " <td><b>Uptime:</b></td>\n";
+- printf $fd " <td colspan=2>%s; runlevel %s</td>\n",
+- $info->{'load'}, $info->{'runlevel'};
++ printf $fd " <td colspan=2>%s</td>\n",
++ $info->{'load'};
+ printf $fd "</tr>\n";
+
+ printf $fd "</table></p>\n\n";
diff --git a/benchmarks/unixbench/files/patch-pgms_cleanup.sh b/benchmarks/unixbench/files/patch-pgms_cleanup.sh
deleted file mode 100644
index 36eeaa7a9784..000000000000
--- a/benchmarks/unixbench/files/patch-pgms_cleanup.sh
+++ /dev/null
@@ -1,13 +0,0 @@
---- pgms/cleanup.sh.orig 1997-09-13 02:01:19 UTC
-+++ pgms/cleanup.sh
-@@ -107,8 +107,8 @@ do
- ;;
-
- -r) # reason for failure
-- echo $1
-- echo $1 >>$LOGFILE
-+ echo -e $1
-+ echo -e $1 >>$LOGFILE
- shift
- ;;
-
diff --git a/benchmarks/unixbench/files/patch-pgms_multi.sh b/benchmarks/unixbench/files/patch-pgms_multi.sh
index 0b344228ae96..0a4dca1c2169 100644
--- a/benchmarks/unixbench/files/patch-pgms_multi.sh
+++ b/benchmarks/unixbench/files/patch-pgms_multi.sh
@@ -1,4 +1,4 @@
---- pgms/multi.sh.orig 1995-11-28 00:19:10 UTC
+--- pgms/multi.sh.orig 2015-06-04 17:20:18 UTC
+++ pgms/multi.sh
@@ -14,6 +14,7 @@
#
@@ -7,4 +7,4 @@
+cd ${TMPDIR}
instance=1
while [ $instance -le $1 ]; do
- /bin/sh $BINDIR/tst.sh &
+ /bin/sh "$UB_BINDIR/tst.sh" &
diff --git a/benchmarks/unixbench/files/patch-pgms_tst.sh b/benchmarks/unixbench/files/patch-pgms_tst.sh
index 4cd6b0073cce..910f7e614f4e 100644
--- a/benchmarks/unixbench/files/patch-pgms_tst.sh
+++ b/benchmarks/unixbench/files/patch-pgms_tst.sh
@@ -1,11 +1,11 @@
---- pgms/tst.sh.orig 1995-11-27 17:07:03 UTC
+--- pgms/tst.sh.orig 2015-06-04 17:20:18 UTC
+++ pgms/tst.sh
@@ -14,7 +14,7 @@
#
###############################################################################
ID="@(#)tst.sh:3.4 -- 5/15/91 19:30:24";
-sort >sort.$$ <sort.src
-+sort >sort.$$ < ${TESTDIR}/sort.src
- od sort.$$ | sort -n +1 > od.$$
++sort >sort.$$ < ${UB_TESTDIR}/sort.src
+ od sort.$$ | sort -n -k 1 > od.$$
grep the sort.$$ | tee grep.$$ | wc > wc.$$
rm sort.$$ grep.$$ od.$$ wc.$$
diff --git a/benchmarks/unixbench/files/patch-src_big.c b/benchmarks/unixbench/files/patch-src_big.c
new file mode 100644
index 000000000000..7790317c2b9e
--- /dev/null
+++ b/benchmarks/unixbench/files/patch-src_big.c
@@ -0,0 +1,11 @@
+--- src/big.c.orig 2015-06-04 17:20:18 UTC
++++ src/big.c
+@@ -583,7 +583,7 @@ void dumpwork(void)
+ void fatal(char *s)
+ {
+ int i;
+- fprintf(stderr, s);
++ fprintf(stderr, "%s", s);
+ fflush(stderr);
+ perror("Reason?");
+ fflush(stderr);
diff --git a/benchmarks/unixbench/files/patch-src_dhry__1.c b/benchmarks/unixbench/files/patch-src_dhry__1.c
index 01821756b3b5..26b7ced39c54 100644
--- a/benchmarks/unixbench/files/patch-src_dhry__1.c
+++ b/benchmarks/unixbench/files/patch-src_dhry__1.c
@@ -1,4 +1,4 @@
---- src/dhry_1.c.orig 1999-07-28 21:43:08 UTC
+--- src/dhry_1.c.orig 2015-06-04 17:20:18 UTC
+++ src/dhry_1.c
@@ -34,6 +34,7 @@
***************************************************************************/
diff --git a/benchmarks/unixbench/files/patch-src_execl.c b/benchmarks/unixbench/files/patch-src_execl.c
deleted file mode 100644
index 434380383c9e..000000000000
--- a/benchmarks/unixbench/files/patch-src_execl.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/execl.c.orig 1999-07-28 21:46:58 UTC
-+++ src/execl.c
-@@ -88,7 +88,7 @@ char *argv[];
- fprintf(stderr, "%lu loops\n", iter);
- exit(0);
- }
-- execl(fullpath, fullpath, "0", dur_str, count_str, start_str, 0);
-+ execl(fullpath, fullpath, "0", dur_str, count_str, start_str, NULL);
- printf("Exec failed at iteration %lu\n", iter);
- perror("Reason");
- exit(1);
diff --git a/benchmarks/unixbench/files/patch-src_syscall.c b/benchmarks/unixbench/files/patch-src_syscall.c
new file mode 100644
index 000000000000..9e920f1e1390
--- /dev/null
+++ b/benchmarks/unixbench/files/patch-src_syscall.c
@@ -0,0 +1,11 @@
+--- src/syscall.c.orig 2015-06-04 17:20:18 UTC
++++ src/syscall.c
+@@ -90,7 +90,7 @@ char *argv[];
+ fprintf(stderr,"%s: fork failed\n", argv[0]);
+ exit(1);
+ } else if (pid == 0) {
+- execl("/bin/true", (char *) 0);
++ execl("/bin/true", (char *) 0, (char *) 0);
+ fprintf(stderr,"%s: exec /bin/true failed\n", argv[0]);
+ exit(1);
+ } else {
diff --git a/benchmarks/unixbench/pkg-descr b/benchmarks/unixbench/pkg-descr
index d2654a977cba..d0313591efc3 100644
--- a/benchmarks/unixbench/pkg-descr
+++ b/benchmarks/unixbench/pkg-descr
@@ -1,3 +1,3 @@
-UnixBench v4.1 based on the BYTE UNIX Benchmarks v3.
+UnixBench based on the BYTE UNIX Benchmarks v3.
-WWW: http://www.tux.org/pub/tux/benchmarks/System/unixbench/
+WWW: https://github.com/kdlucas/byte-unixbench
diff --git a/benchmarks/unixbench/pkg-message b/benchmarks/unixbench/pkg-message
index db5791dda9b4..bb6ccab2492c 100644
--- a/benchmarks/unixbench/pkg-message
+++ b/benchmarks/unixbench/pkg-message
@@ -1,5 +1,5 @@
------------------------------------------------------------------------
-If you want to run unixbench, please type the following command:
+If you want to run unixbench, please type the following commands:
% unixbench
------------------------------------------------------------------------
diff --git a/benchmarks/unixbench/pkg-plist b/benchmarks/unixbench/pkg-plist
index c665a62a0861..6b7d6d2b3a39 100644
--- a/benchmarks/unixbench/pkg-plist
+++ b/benchmarks/unixbench/pkg-plist
@@ -1,42 +1,31 @@
bin/unixbench
-lib/unixbench/Makefile
-lib/unixbench/README
-lib/unixbench/Run
-lib/unixbench/pgms/arithoh
-lib/unixbench/pgms/cleanup.sh
-lib/unixbench/pgms/context1
-lib/unixbench/pgms/dhry2
-lib/unixbench/pgms/dhry2reg
-lib/unixbench/pgms/double
-lib/unixbench/pgms/execl
-lib/unixbench/pgms/float
-lib/unixbench/pgms/fs.awk
-lib/unixbench/pgms/fsbuffer
-lib/unixbench/pgms/fsdisk
-lib/unixbench/pgms/fstime
-lib/unixbench/pgms/hanoi
-lib/unixbench/pgms/index.awk
-lib/unixbench/pgms/index.base
-lib/unixbench/pgms/index.sh
-lib/unixbench/pgms/int
-lib/unixbench/pgms/long
-lib/unixbench/pgms/looper
-lib/unixbench/pgms/loopm.awk
-lib/unixbench/pgms/loops.awk
-lib/unixbench/pgms/lps.awk
-lib/unixbench/pgms/multi.sh
-lib/unixbench/pgms/mwips.awk
-lib/unixbench/pgms/perlbench
-lib/unixbench/pgms/pipe
-lib/unixbench/pgms/register
-lib/unixbench/pgms/report.awk
-lib/unixbench/pgms/report.sh
-lib/unixbench/pgms/short
-lib/unixbench/pgms/spawn
-lib/unixbench/pgms/syscall
-lib/unixbench/pgms/tst.sh
-lib/unixbench/pgms/unixbench.logo
-lib/unixbench/pgms/whetstone-double
-lib/unixbench/testdir/cctest.c
-lib/unixbench/testdir/dc.dat
-lib/unixbench/testdir/sort.src
+libexec/unixbench/Makefile
+libexec/unixbench/README
+libexec/unixbench/Run
+libexec/unixbench/pgms/arithoh
+libexec/unixbench/pgms/context1
+libexec/unixbench/pgms/dhry2
+libexec/unixbench/pgms/dhry2reg
+libexec/unixbench/pgms/double
+libexec/unixbench/pgms/execl
+libexec/unixbench/pgms/float
+libexec/unixbench/pgms/fstime
+libexec/unixbench/pgms/gfx-x11
+libexec/unixbench/pgms/hanoi
+libexec/unixbench/pgms/index.base
+libexec/unixbench/pgms/int
+libexec/unixbench/pgms/long
+libexec/unixbench/pgms/looper
+libexec/unixbench/pgms/multi.sh
+libexec/unixbench/pgms/pipe
+libexec/unixbench/pgms/register
+libexec/unixbench/pgms/short
+libexec/unixbench/pgms/spawn
+libexec/unixbench/pgms/syscall
+libexec/unixbench/pgms/tst.sh
+libexec/unixbench/pgms/unixbench.logo
+libexec/unixbench/pgms/whetstone-double
+libexec/unixbench/testdir/cctest.c
+libexec/unixbench/testdir/dc.dat
+libexec/unixbench/testdir/large.txt
+libexec/unixbench/testdir/sort.src
de MAINTAINER and CATEGORIES (in slave ports).demon2001-04-101-2/+2 * Add the ability to select which languages to install via dialog(1)-baseddemon2001-04-102-0/+87 * Update to 2.1.1demon2001-04-063-13/+2 * Change dot file to .vnelvisrc from .exrc.obrien2001-04-051-8/+26 * Default to Vietnamese processing.obrien2001-04-051-0/+5 * Overhaul QT/KDE support:will2001-04-031-2/+2 * Install new manpage.obrien2001-03-261-0/+2 * Add FreeBSD ID.obrien2001-03-261-0/+1 * Grr. a local cc(1) option got added by mistake.obrien2001-03-261-3/+3 * Sigh. This code is based on vnlibs. Thus I need to fix the Pascal'ismobrien2001-03-261-0/+8 * Respect CFLAGS.obrien2001-03-261-0/+11 * Add a man page.obrien2001-03-261-0/+65 * Minor tweak.obrien2001-03-261-2/+2 * Add reference to vnconvert(1).obrien2001-03-263-0/+3 * unbreak post-install script.sf2001-03-191-1/+1 * Use full path to `mkfontdir'.obrien2001-03-131-1/+1 * Make sure teTeX is installed before installing this port.obrien2001-03-131-0/+3 * Update to the 20010210 version. This fixes occasional core dumps in apps.obrien2001-03-092-2/+2 * New port: localized messages and documentation for KDE2.demon2001-03-025-0/+38 * Add aliases.obrien2001-02-163-0/+15 * Make this build when it is in the full /usr/ports tree and "vi-" is prependedobrien2001-02-121-1/+1 * Use the new libviet port in building.obrien2001-02-123-16/+15 * Use the new libviet port in building.obrien2001-02-113-14/+17 * Update vnterm so it is based on the X11R6.5.1 Xterm rather than the X11R5 one.obrien2001-02-1123-191/+1411 * Fix prefix bogon.obrien2001-02-111-0/+1 * These X fonts allow you to display Vietnamese characters in an Xterm andobrien2001-02-118-0/+134 * VIQR<->VISCII conversion and VISCII ctype-like routinesobrien2001-02-106-0/+49 * teTeX Vietnamese language + font supportobrien2001-02-078-0/+475 * Style fixes in ports/vietnamese.olgeni2001-02-061-1/+1 * Converts Vietnamese text files between popular formats.obrien2001-01-066-0/+40 * Add $FreeBSD$, which help me in problem reports.obrien2000-11-221-0/+1 * Fix curses clear() usage.obrien2000-11-033-0/+54 * Change PKGDIR from pkg/ to . Also fix places where ${PKGDIR} isasami2000-10-081-1/+1 * Add dependency to mkfontdir:XFree86-4-clients when XFREE86_VERSION=4.asami2000-09-121-1/+8 * Back out the previous commit. That one has a problem which occurs onknu2000-08-281-5/+1 * PKGNAMEPREFIX cleanup. This should allow chained PKGNAMEPREFIX'es.knu2000-08-271-1/+5 * Add one manpage, one doc file and delete two directories.asami2000-07-052-0/+4 * List two files in share/doc/vnlpr and delete the directory upon deinstall.asami2000-07-051-2/+3 * Update the manpage to note this now adhears to Vietnamese Standard Code forobrien2000-05-214-7/+58 * Correct whitespace introduced during PORTNAME conversion and portlintmharo2000-04-216-6/+6 * Remove "vi-" prefix from PORTNAMEs, they are set by PKGNAMEPREFIX inasami2000-04-157-12/+12 * Set PKGNAMEPREFIX with ?= so it can be overridden.asami2000-04-111-1/+1 * Add PKGNAMEPREFIX definitions for language-specific dirs.asami2000-04-111-0/+4 * Update with the new PORTNAME/PORTVERSION variablescpiazza2000-04-107-21/+20 * Restore useless version required comments.obrien2000-03-227-0/+7 * Remove the "version required" line.obrien2000-03-207-7/+0 * Style nits in the ports I maintain.obrien2000-02-137-13/+13 * adjust for my editorobrien1999-09-065-0/+5 * $Id$ -> $FreeBSD$peter1999-08-3117-17/+17 * ln -> ${LN}mharo1999-08-281-3/+3 * chmod -> ${CHMOD}mharo1999-08-232-6/+6 * Make this port reinstall friendly.steve1999-07-051-8/+3 * #4/4 enforcing Caps, no periodhoek1999-06-275-5/+5 * mark unbroken - can't repeat the problemobrien1998-11-071-3/+1 * mark unbroken -- I can't duplicate the problem on 3 different machinesobrien1998-11-071-3/+1 * make buildable on ELFobrien1998-11-071-3/+5 * mark unbroken -- I can't repeat the problem on 3 different machinesobrien1998-11-071-3/+1 * Mark BROKEN for ELF:jseger1998-10-161-1/+3 * Mark BROKEN for ELF:jseger1998-10-161-1/+3 * Mark BROKEN for ELF:jseger1998-10-161-1/+3 * Mark BROKEN for ELF:jseger1998-10-161-1/+3 * Remove manpages from pkg/PLISTobrien1998-08-14