aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2005-02-18 20:26:26 +0800
committerkrion <krion@FreeBSD.org>2005-02-18 20:26:26 +0800
commit4d778f33fa9c58c97dad98a03034e11a96464cde (patch)
tree93d81548a77161cb5787088f11844fe0f04fec5f /benchmarks
parent7f5600dcb2f6e9031e147c970a5f73ffeb439629 (diff)
downloadfreebsd-ports-gnome-4d778f33fa9c58c97dad98a03034e11a96464cde.tar.gz
freebsd-ports-gnome-4d778f33fa9c58c97dad98a03034e11a96464cde.tar.zst
freebsd-ports-gnome-4d778f33fa9c58c97dad98a03034e11a96464cde.zip
Unbreak on alpha.
PR: ports/76963 Submitted by: Florent Thoumie <flz at xbsd.org>
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/sipp/Makefile2
-rw-r--r--benchmarks/sipp/files/patch-sipp.hpp11
2 files changed, 12 insertions, 1 deletions
diff --git a/benchmarks/sipp/Makefile b/benchmarks/sipp/Makefile
index c79e5fbf15b0..0aadbb5aaa58 100644
--- a/benchmarks/sipp/Makefile
+++ b/benchmarks/sipp/Makefile
@@ -21,7 +21,7 @@ MAN1= sipp.1
.include <bsd.port.pre.mk>
-.if ((${ARCH} == "alpha") || (${ARCH} == "ia64"))
+.if ${ARCH} == "ia64"
BROKEN= "Does not compile - patch needed by someone who can test it"
.endif
diff --git a/benchmarks/sipp/files/patch-sipp.hpp b/benchmarks/sipp/files/patch-sipp.hpp
new file mode 100644
index 000000000000..4c39f89eb72e
--- /dev/null
+++ b/benchmarks/sipp/files/patch-sipp.hpp
@@ -0,0 +1,11 @@
+--- sipp.hpp.orig Tue Feb 1 15:12:35 2005
++++ sipp.hpp Tue Feb 1 15:12:49 2005
+@@ -268,7 +268,7 @@
+ void pollset_remove(int idx);
+ int pollset_add(call * p_call, int socket);
+
+-#if defined (__hpux) || defined (__alpha)
++#if defined (__hpux)
+ #define sipp_socklen_t int
+ #else
+ #define sipp_socklen_t socklen_t