aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-11-18 21:45:44 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-11-18 21:45:44 +0800
commit51c60ddf7f7c0942f2a332498ef7e104a0c11dc0 (patch)
tree003722865c3ffbd06a385211135ea1ca17afd24a /benchmarks
parentfcbc3463cba2860570ef5b205a8994fa3c5e084f (diff)
downloadfreebsd-ports-gnome-51c60ddf7f7c0942f2a332498ef7e104a0c11dc0.tar.gz
freebsd-ports-gnome-51c60ddf7f7c0942f2a332498ef7e104a0c11dc0.tar.zst
freebsd-ports-gnome-51c60ddf7f7c0942f2a332498ef7e104a0c11dc0.zip
Convert to USES=dos2unix
While here stagify some of the ports Modernize LIB_DEPENDS Extract zip with bsdtar when possible
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/imb/Makefile3
-rw-r--r--benchmarks/xdd/Makefile13
2 files changed, 6 insertions, 10 deletions
diff --git a/benchmarks/imb/Makefile b/benchmarks/imb/Makefile
index bbc6c7c7b0e6..29bf301ac79c 100644
--- a/benchmarks/imb/Makefile
+++ b/benchmarks/imb/Makefile
@@ -15,8 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Intel MPI Benchmark
WRKSRC= ${WRKDIR}/IMB_3.0/src/
-USES= gmake
-USE_DOS2UNIX= yes
+USES= dos2unix gmake
MAKEFILE= make_mpich
ALL_TARGET= all
# Intel hardcodes -O3 in make_mpich. Replacing it with system defaults
diff --git a/benchmarks/xdd/Makefile b/benchmarks/xdd/Makefile
index fac95e0f73c0..5f90c35e4c39 100644
--- a/benchmarks/xdd/Makefile
+++ b/benchmarks/xdd/Makefile
@@ -14,19 +14,16 @@ COMMENT= Tool for measuring and characterizing disk subsystem I/O
WRKSRC= ${WRKDIR}/${DISTNAME}
PLIST_FILES= bin/xdd bin/timeserver bin/gettime
-USE_DOS2UNIX= yes
+USES= dos2unix
DOS2UNIX_REGEX= .*\.(c|cpp|h)
+MAKEFILE= freebsd.makefile
-NO_STAGE= yes
post-extract:
${CP} ${FILESDIR}/freebsd.makefile ${WRKSRC}
-do-build:
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} -f freebsd.makefile
-
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/xdd.freebsd ${PREFIX}/bin/xdd
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/timeserver.freebsd ${PREFIX}/bin/timeserver
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/gettime.freebsd ${PREFIX}/bin/gettime
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/xdd.freebsd ${STAGEDIR}${PREFIX}/bin/xdd
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/timeserver.freebsd ${STAGEDIR}${PREFIX}/bin/timeserver
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/gettime.freebsd ${STAGEDIR}${PREFIX}/bin/gettime
.include <bsd.port.mk>