aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2003-11-22 08:46:43 +0800
committerpav <pav@FreeBSD.org>2003-11-22 08:46:43 +0800
commit7e50dd97364d6a49273c0e573de8e69e5776773b (patch)
tree38db9776bf7fae9fd783890bf6c0ac80dd0ae2cf /benchmarks
parent00244f4eaa41746b0537fb5d953d033d446b5dd7 (diff)
downloadfreebsd-ports-gnome-7e50dd97364d6a49273c0e573de8e69e5776773b.tar.gz
freebsd-ports-gnome-7e50dd97364d6a49273c0e573de8e69e5776773b.tar.zst
freebsd-ports-gnome-7e50dd97364d6a49273c0e573de8e69e5776773b.zip
- Our other two 64-bit platforms needs min(int, int) workaround too
- Unmark broken as it builds on Bento at least for i386. I got some feedback that it builds with gcc 3.3.3, but not with 3.3.1 Tested by: Koop Mast (on sparc64) Approved by: adamw (mentor)
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/bonnie++/Makefile8
-rw-r--r--benchmarks/bonnie++/files/patch-getc_putc.cpp2
2 files changed, 2 insertions, 8 deletions
diff --git a/benchmarks/bonnie++/Makefile b/benchmarks/bonnie++/Makefile
index a5d777e8ad65..d8115e211166 100644
--- a/benchmarks/bonnie++/Makefile
+++ b/benchmarks/bonnie++/Makefile
@@ -19,12 +19,6 @@ COMMENT= Performance Test of Filesystem I/O
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501103
-BROKEN= "Does not build with gcc 3.3; author is aware of the problem"
-.endif
-
MAN1= bon_csv2html.1 bon_csv2txt.1 generate_randfile.1
MAN8= bonnie++.8 getc_putc.8 zcav.8
@@ -35,4 +29,4 @@ post-install:
@${MKDIR} ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/readme.html ${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/benchmarks/bonnie++/files/patch-getc_putc.cpp b/benchmarks/bonnie++/files/patch-getc_putc.cpp
index fbabf3e53905..bad9550b0938 100644
--- a/benchmarks/bonnie++/files/patch-getc_putc.cpp
+++ b/benchmarks/bonnie++/files/patch-getc_putc.cpp
@@ -4,7 +4,7 @@
#include "duration.h"
#include "getc_putc.h"
-+#if defined(__alpha__) || defined(__sparc64__)
++#if defined(__alpha__) || defined(__sparc64__) || defined(__amd64__) || defined(__ia64__)
+/* Work around for: line 168, no matching function for call to `min(long unsigned int, unsigned int)' */
+#include <sys/param.h>
+#define min MIN