aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
authorKoop Mast <kwm@rainbow-runner.nl>2019-09-07 04:56:57 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2019-09-07 04:56:57 +0800
commitf44e2881c913e6863249652cf73fca4a93296a47 (patch)
treed3daee8b4a2fbf1025d4c02c3aebedd4d67df52e /benchmarks
parent9fcef473288365748d276dbf967c46d8c3698aaf (diff)
parent8a91d63da840b97569719c1cff6c0a39401c9c04 (diff)
downloadfreebsd-ports-gnome-f44e2881c913e6863249652cf73fca4a93296a47.tar.gz
freebsd-ports-gnome-f44e2881c913e6863249652cf73fca4a93296a47.tar.zst
freebsd-ports-gnome-f44e2881c913e6863249652cf73fca4a93296a47.zip
Merge remote-tracking branch 'upstream/master'
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/bonnie++/Makefile6
-rw-r--r--benchmarks/bonnie++/distinfo6
-rw-r--r--benchmarks/bonnie++/files/patch-bon_time.cpp11
-rw-r--r--benchmarks/bonnie++/files/patch-bonnie++.cpp14
-rw-r--r--benchmarks/bonnie++/files/patch-getc_putc.cpp20
-rw-r--r--benchmarks/bonnie++/files/patch-getc_putc_helper.cpp11
-rw-r--r--benchmarks/hipercontracer/Makefile2
-rw-r--r--benchmarks/netperfmeter/Makefile19
-rw-r--r--benchmarks/netperfmeter/distinfo6
-rw-r--r--benchmarks/netperfmeter/pkg-plist4
-rw-r--r--benchmarks/rubygem-benchmark-ips/Makefile5
11 files changed, 71 insertions, 33 deletions
diff --git a/benchmarks/bonnie++/Makefile b/benchmarks/bonnie++/Makefile
index 92a5aa8c4c42..264b8c4a9a07 100644
--- a/benchmarks/bonnie++/Makefile
+++ b/benchmarks/bonnie++/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= bonnie++
-PORTVERSION= 1.97.3
+PORTVERSION= 1.98
CATEGORIES= benchmarks
MASTER_SITES= https://www.coker.com.au/bonnie++/
@@ -11,9 +11,9 @@ COMMENT= Performance Test of Filesystem I/O
LICENSE= GPLv2
-GNU_CONFIGURE= yes
-
USES= shebangfix tar:tgz
+
+GNU_CONFIGURE= yes
SHEBANG_FILES= bon_csv2txt.in
PORTDOCS= readme.html
diff --git a/benchmarks/bonnie++/distinfo b/benchmarks/bonnie++/distinfo
index c1df97421b62..28addae36e5a 100644
--- a/benchmarks/bonnie++/distinfo
+++ b/benchmarks/bonnie++/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1482419750
-SHA256 (bonnie++-1.97.3.tgz) = e27b386ae0dc054fa7b530aab6bdead7aea6337a864d1f982bc9ebacb320746e
-SIZE (bonnie++-1.97.3.tgz) = 100166
+TIMESTAMP = 1567440456
+SHA256 (bonnie++-1.98.tgz) = 6e0bcbc08b78856fd998dd7bcb352d4615a99c26c2dc83d5b8345b102bad0b04
+SIZE (bonnie++-1.98.tgz) = 100339
diff --git a/benchmarks/bonnie++/files/patch-bon_time.cpp b/benchmarks/bonnie++/files/patch-bon_time.cpp
new file mode 100644
index 000000000000..bdd4ca288bb3
--- /dev/null
+++ b/benchmarks/bonnie++/files/patch-bon_time.cpp
@@ -0,0 +1,11 @@
+--- bon_time.cpp.orig 2019-09-02 11:43:11 UTC
++++ bon_time.cpp
+@@ -146,7 +146,7 @@ int BonTimer::print_stat(tests_t test, i
+ }
+ else
+ {
+- fprintf(m_fp, " %5d", stat);
++ fprintf(m_fp, " %5f", stat);
+ }
+ }
+ else
diff --git a/benchmarks/bonnie++/files/patch-bonnie++.cpp b/benchmarks/bonnie++/files/patch-bonnie++.cpp
index 550f66b03411..12e01be32bfb 100644
--- a/benchmarks/bonnie++/files/patch-bonnie++.cpp
+++ b/benchmarks/bonnie++/files/patch-bonnie++.cpp
@@ -1,6 +1,6 @@
---- bonnie++.cpp.orig 2016-06-30 09:41:41.000000000 +0000
-+++ bonnie++.cpp 2016-10-18 19:52:40.381679719 +0000
-@@ -294,11 +294,7 @@
+--- bonnie++.cpp.orig 2019-09-02 18:10:39.852145000 +0200
++++ bonnie++.cpp 2019-09-02 18:12:18.027222000 +0200
+@@ -298,11 +298,7 @@
{
char *sbuf = _strdup(optarg);
char *size = strtok(sbuf, ":");
@@ -9,10 +9,10 @@
-#else
- file_size = size_from_str(size, "g");
-#endif
- size = strtok(NULL, "");
- if(size)
+ char * chunk_size = strtok(NULL, ":");
+ if(chunk_size)
{
-@@ -384,15 +380,6 @@
+@@ -398,15 +394,6 @@
if(file_size % 1024 > 512)
file_size = file_size + 1024 - (file_size % 1024);
}
@@ -28,7 +28,7 @@
globals.byte_io_size = min(file_size, globals.byte_io_size);
globals.byte_io_size = max(0, globals.byte_io_size);
-@@ -465,14 +452,6 @@
+@@ -479,14 +466,6 @@
&& (directory_max_size < directory_min_size || directory_max_size < 0
|| directory_min_size < 0) )
usage();
diff --git a/benchmarks/bonnie++/files/patch-getc_putc.cpp b/benchmarks/bonnie++/files/patch-getc_putc.cpp
new file mode 100644
index 000000000000..3ff9c2956453
--- /dev/null
+++ b/benchmarks/bonnie++/files/patch-getc_putc.cpp
@@ -0,0 +1,20 @@
+--- getc_putc.cpp.orig 2018-09-15 09:00:31.000000000 +0200
++++ getc_putc.cpp 2019-09-05 12:09:25.705704000 +0200
+@@ -206,7 +206,7 @@
+ return 1;
+ }
+ fflush(NULL);
+- TEST_FUNC_READ("getc()", if( (c = getc(fp)) == EOF), res[Getc]);
++ TEST_FUNC_READ("getc()", int tmp = getc(fp); c = (char)tmp; if (tmp == EOF), res[Getc]);
+ if(fseek(fp, 0, SEEK_SET) != 0)
+ {
+ fprintf(stderr, "Can't seek.\n");
+@@ -221,7 +221,7 @@
+ return 1;
+ }
+ fflush(NULL);
+- TEST_FUNC_READ("getc_unlocked()", if( (c = getc_unlocked(fp)) == EOF), res[GetcUnlocked]);
++ TEST_FUNC_READ("getc_unlocked()", int tmp = getc_unlocked(fp); c = (char)tmp; if (tmp == EOF), res[GetcUnlocked]);
+
+ if(!quiet)
+ printf("done\n");
diff --git a/benchmarks/bonnie++/files/patch-getc_putc_helper.cpp b/benchmarks/bonnie++/files/patch-getc_putc_helper.cpp
new file mode 100644
index 000000000000..a7edca3b1b6c
--- /dev/null
+++ b/benchmarks/bonnie++/files/patch-getc_putc_helper.cpp
@@ -0,0 +1,11 @@
+--- getc_putc_helper.cpp.orig 2009-07-03 04:26:05.000000000 +0200
++++ getc_putc_helper.cpp 2019-09-05 12:09:25.707876000 +0200
+@@ -45,7 +45,7 @@
+ return 1;
+ }
+ fflush(NULL);
+- TEST_FUNC_READ("getc() no thread", if( (c = getc(fp)) == EOF), res[1]);
++ TEST_FUNC_READ("getc() no thread", int tmp = getc(fp); c = (char)tmp; if (tmp == EOF), res[1]);
+ if(fseek(fp, 0, SEEK_SET) != 0)
+ {
+ fprintf(stderr, "Can't seek.\n");
diff --git a/benchmarks/hipercontracer/Makefile b/benchmarks/hipercontracer/Makefile
index 202bd50a2e4a..9493d463ae2c 100644
--- a/benchmarks/hipercontracer/Makefile
+++ b/benchmarks/hipercontracer/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libboost_date_time.so:devel/boost-libs \
libboost_system.so:devel/boost-libs \
libboost_thread.so:devel/boost-libs
-USES= tar:xz cmake shebangfix python
+USES= cmake compiler:c++14-lang python shebangfix tar:xz
USE_LDCONFIG= yes
CMAKE_ARGS+= -DCMAKE_INSTALL_MANDIR=${PREFIX}/man
diff --git a/benchmarks/netperfmeter/Makefile b/benchmarks/netperfmeter/Makefile
index c5436ea314f1..62f7d3564ec0 100644
--- a/benchmarks/netperfmeter/Makefile
+++ b/benchmarks/netperfmeter/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= netperfmeter
-PORTVERSION= 1.7.6
+PORTVERSION= 1.8.4
CATEGORIES= benchmarks
MASTER_SITES= https://www.uni-due.de/~be0001/netperfmeter/download/
@@ -12,17 +12,12 @@ COMMENT= Network Performance Meter
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake compiler shebangfix
-CMAKE_ON= BUILD_PLOT_PROGRAMS
-CMAKE_OFF= BUILD_TEST_PROGRAMS WITH_NEAT
-SHEBANG_FILES= src/pdfembedfonts src/pdfmetadata src/plot-netperfmeter-results
+USES= cmake shebangfix tar:xz
-.include <bsd.port.pre.mk>
+SHEBANG_FILES= src/pdfembedfonts src/setpdfmetadata src/plot-netperfmeter-results
-post-patch:
-.if ${CHOSEN_COMPILER_TYPE} == gcc
- @${REINPLACE_CMD} 's, -Wno-array-bounds,,g' ${WRKSRC}/CMakeLists.txt
-.endif
- @${REINPLACE_CMD} 's,share/man,man,' ${WRKSRC}/CMakeLists.txt
+CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR=${PREFIX}/man
+CMAKE_OFF= WITH_NEAT BUILD_TEST_PROGRAMS
+CMAKE_ON= BUILD_PLOT_PROGRAMS
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/benchmarks/netperfmeter/distinfo b/benchmarks/netperfmeter/distinfo
index 2eef58ba82ed..6f82c35bcd3b 100644
--- a/benchmarks/netperfmeter/distinfo
+++ b/benchmarks/netperfmeter/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1520777384
-SHA256 (netperfmeter-1.7.6.tar.gz) = 09c8709b59bc330a8cc1d58e2e909a13e98feac5ff472856625a7a22712c3aeb
-SIZE (netperfmeter-1.7.6.tar.gz) = 278596
+TIMESTAMP = 1565194937
+SHA256 (netperfmeter-1.8.4.tar.xz) = 83034f2f2761c97a17178a9c0c275c9835167b08af8f65dabd40f9da5680c5aa
+SIZE (netperfmeter-1.8.4.tar.xz) = 196032
diff --git a/benchmarks/netperfmeter/pkg-plist b/benchmarks/netperfmeter/pkg-plist
index ea8892980eaf..4f1c67a8005d 100644
--- a/benchmarks/netperfmeter/pkg-plist
+++ b/benchmarks/netperfmeter/pkg-plist
@@ -4,7 +4,7 @@ bin/extractvectors
bin/getabstime
bin/netperfmeter
bin/pdfembedfonts
-bin/pdfmetadata
+bin/setpdfmetadata
bin/plot-netperfmeter-results
bin/runtimeestimator
man/man1/combinesummaries.1.gz
@@ -13,7 +13,7 @@ man/man1/extractvectors.1.gz
man/man1/getabstime.1.gz
man/man1/netperfmeter.1.gz
man/man1/pdfembedfonts.1.gz
-man/man1/pdfmetadata.1.gz
+man/man1/setpdfmetadata.1.gz
man/man1/plot-netperfmeter-results.1.gz
man/man1/runtimeestimator.1.gz
%%DATADIR%%/plot-netperfmeter-results.R
diff --git a/benchmarks/rubygem-benchmark-ips/Makefile b/benchmarks/rubygem-benchmark-ips/Makefile
index 8a64a3671cef..0c15daab72ce 100644
--- a/benchmarks/rubygem-benchmark-ips/Makefile
+++ b/benchmarks/rubygem-benchmark-ips/Makefile
@@ -11,8 +11,9 @@ COMMENT= Iterations per second enhancement to Benchmark
LICENSE= MIT
-NO_ARCH= yes
-USE_RUBY= yes
USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
.include <bsd.port.mk>