aboutsummaryrefslogtreecommitdiffstats
path: root/biology/fasttree
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2015-09-26 02:34:29 +0800
committerrm <rm@FreeBSD.org>2015-09-26 02:34:29 +0800
commit2987b59daaef2f4c0f6cbef1751bb08d03565e63 (patch)
tree270ceac59b6706ee2b139099ecaa979682c8283f /biology/fasttree
parent8bfafc3030596829380986a07d5193bcdb7133cf (diff)
downloadfreebsd-ports-gnome-2987b59daaef2f4c0f6cbef1751bb08d03565e63.tar.gz
freebsd-ports-gnome-2987b59daaef2f4c0f6cbef1751bb08d03565e63.tar.zst
freebsd-ports-gnome-2987b59daaef2f4c0f6cbef1751bb08d03565e63.zip
FastTree infers approximately-maximum-likelihood phylogenetic trees from
alignments of nucleotide or protein sequences. FastTree can handle alignments with up to a million of sequences in a reasonable amount of time and memory. WWW: http://www.microbesonline.org/fasttree/ PR: 203295 Submitted by: Jason Bacon <jwbacon@tds.net>
Diffstat (limited to 'biology/fasttree')
-rw-r--r--biology/fasttree/Makefile33
-rw-r--r--biology/fasttree/distinfo2
-rw-r--r--biology/fasttree/pkg-descr5
3 files changed, 40 insertions, 0 deletions
diff --git a/biology/fasttree/Makefile b/biology/fasttree/Makefile
new file mode 100644
index 000000000000..0fbca3f6dba6
--- /dev/null
+++ b/biology/fasttree/Makefile
@@ -0,0 +1,33 @@
+# Created by: Jason Bacon <jwbacon@tds.net>
+# $FreeBSD$
+
+PORTNAME= FastTree
+PORTVERSION= 2.1.8
+CATEGORIES= biology
+MASTER_SITES= http://www.microbesonline.org/fasttree/
+EXTRACT_SUFX= .c
+
+MAINTAINER= jwbacon@tds.net
+COMMENT= Approximately-maximum-likelihood phylogenetic trees from alignments
+
+# LICENSE= unspecified open source
+
+USES= compiler:openmp
+
+CFLAGS+= -DOPENMP -fopenmp -O3 -finline-functions -funroll-loops
+LDFLAGS+= -lm
+
+PLIST_FILES= bin/FastTree
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ ${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}
+
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} -o FastTree ${DISTFILES} ${LDFLAGS}
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/FastTree ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/biology/fasttree/distinfo b/biology/fasttree/distinfo
new file mode 100644
index 000000000000..abd99c4d0c3c
--- /dev/null
+++ b/biology/fasttree/distinfo
@@ -0,0 +1,2 @@
+SHA256 (FastTree-2.1.8.c) = b172d160f1b12b764d21a6937c3ce01ba42fa8743d95e083e031c6947762f837
+SIZE (FastTree-2.1.8.c) = 385231
diff --git a/biology/fasttree/pkg-descr b/biology/fasttree/pkg-descr
new file mode 100644
index 000000000000..c8b02a9d8466
--- /dev/null
+++ b/biology/fasttree/pkg-descr
@@ -0,0 +1,5 @@
+FastTree infers approximately-maximum-likelihood phylogenetic trees from
+alignments of nucleotide or protein sequences. FastTree can handle alignments
+with up to a million of sequences in a reasonable amount of time and memory.
+
+WWW: http://www.microbesonline.org/fasttree/