aboutsummaryrefslogtreecommitdiffstats
path: root/biology/gmap
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-12-21 18:23:19 +0800
committerlinimon <linimon@FreeBSD.org>2017-12-21 18:23:19 +0800
commit6a2c8adf9eab2d622b7805a3cb7990c8c9454251 (patch)
treee2529c5247b78282bbb3a3cc3aaaad34e48baf86 /biology/gmap
parentc9983b6ed69b31349559fe4008e6b2e88fe191c7 (diff)
downloadfreebsd-ports-gnome-6a2c8adf9eab2d622b7805a3cb7990c8c9454251.tar.gz
freebsd-ports-gnome-6a2c8adf9eab2d622b7805a3cb7990c8c9454251.tar.zst
freebsd-ports-gnome-6a2c8adf9eab2d622b7805a3cb7990c8c9454251.zip
Try to bring some consistency to ports that have x86-specific pieces.
- in general, if we think that the code is not architecture-specific, and instead just enables x86 assembler by default, those should use BROKEN rather than IGNORE. This will allow them to be attempted with TRYBROKEN. - spell i386 as x86. - spell asm as assembler. - pet portlint. These changes should have no effect on tier-1 builds. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'biology/gmap')
-rw-r--r--biology/gmap/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/biology/gmap/Makefile b/biology/gmap/Makefile
index 162604683557..7bf74d92c51e 100644
--- a/biology/gmap/Makefile
+++ b/biology/gmap/Makefile
@@ -15,6 +15,13 @@ LICENSE_NAME= GMAP License
LICENSE_FILE= ${WRKSRC}/COPYING
LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
+BROKEN_aarch64= invokes x86 assembler
+BROKEN_armv6= invokes x86 assembler
+BROKEN_armv7= invokes x86 assembler
+BROKEN_mips64= invokes x86 assembler
+BROKEN_powerpc64= invokes x86 assembler
+BROKEN_sparc64= invokes x86 assembler
+
USES= gmake perl5
GNU_CONFIGURE= yes
@@ -24,13 +31,6 @@ OPTIONS_DEFINE= SIMD
SIMD_CONFIGURE_OFF= --disable-builtin-popcount --disable-simd
-BROKEN_aarch64= Does not build: invokes x86 asm
-BROKEN_armv6= Does not build: invokes x86 asm
-BROKEN_armv7= Does not build: invokes x86 asm
-BROKEN_mips64= Does not build: invokes x86 asm
-BROKEN_powerpc64= Does not build: invokes x86 asm
-BROKEN_sparc64= Does not build: invokes x86 asm
-
# shebang_fix operates during patch.
# These scripts are created during configure.
post-configure: