aboutsummaryrefslogtreecommitdiffstats
path: root/biology/phylip
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-03-24 05:52:54 +0800
committerpawel <pawel@FreeBSD.org>2014-03-24 05:52:54 +0800
commit794e4d0683906c0d03b1eb3648bd4cc6e6383783 (patch)
tree5a9b67acc9d568fa0ea95016ab0c9673732b3208 /biology/phylip
parent74e0a97b8bbd497887c6a14947f283f177a0a958 (diff)
downloadfreebsd-ports-gnome-794e4d0683906c0d03b1eb3648bd4cc6e6383783.tar.gz
freebsd-ports-gnome-794e4d0683906c0d03b1eb3648bd4cc6e6383783.tar.zst
freebsd-ports-gnome-794e4d0683906c0d03b1eb3648bd4cc6e6383783.zip
- Add staging support
- Strip libraries
Diffstat (limited to 'biology/phylip')
-rw-r--r--biology/phylip/Makefile30
1 files changed, 13 insertions, 17 deletions
diff --git a/biology/phylip/Makefile b/biology/phylip/Makefile
index dcae4f991c4e..73dbe64e8373 100644
--- a/biology/phylip/Makefile
+++ b/biology/phylip/Makefile
@@ -3,7 +3,7 @@
PORTNAME= phylip
PORTVERSION= 3.695
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= biology
MASTER_SITES= http://evolution.gs.washington.edu/phylip/download/
@@ -13,8 +13,6 @@ COMMENT= Phylogeny Inference Package
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
-OPTIONS_DEFINE= DOCS EXAMPLES
-
BUILD_WRKSRC= ${WRKSRC}/src
INSTALL_WRKSRC= ${WRKSRC}/src
@@ -29,28 +27,26 @@ USE_LDCONFIG= yes
PORTDOCS= *
PORTEXAMPLES= *
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+pre-install:
+ @(cd ${WRKSRC}/src && ${STRIP_CMD} libdrawtree.so libdrawgram.so)
post-install:
@cd ${WRKSRC}/exe && \
${FIND} . -maxdepth 1 -not -type d -not -name '*.jar' \
-not -name '*.unx' -not -name 'font*' -not -name '*.so' \
- -exec ${INSTALL_PROGRAM} "{}" "${PREFIX}/bin/{}" \;
+ -exec ${INSTALL_PROGRAM} "{}" "${STAGEDIR}${PREFIX}/bin/{}" \;
@cd ${WRKSRC}/exe && \
${FIND} . -maxdepth 1 -not -type d -name "*.so" \
- -exec ${INSTALL_DATA} "{}" "${PREFIX}/lib/{}" \;
- @${MKDIR} ${DATADIR}
+ -exec ${INSTALL_DATA} "{}" "${STAGEDIR}${PREFIX}/lib/{}" \;
+ @${MKDIR} ${STAGEDIR}${DATADIR}
@cd ${WRKSRC}/exe && \
${FIND} . -maxdepth 1 -not -type d -name 'font*' \
- -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${DOCSDIR})
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- @(cd ${WRKSRC}/exe && ${COPYTREE_SHARE} testdata ${EXAMPLESDIR})
-.endif
+ -exec ${INSTALL_DATA} "{}" "${STAGEDIR}${DATADIR}/{}" \;
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @(cd ${WRKSRC}/exe && ${COPYTREE_SHARE} testdata ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>