aboutsummaryrefslogtreecommitdiffstats
path: root/biology/seaview/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1999-02-03 19:12:01 +0800
committerasami <asami@FreeBSD.org>1999-02-03 19:12:01 +0800
commitaa52cd921c82a10ec33065084fe0edb5cf8bebbc (patch)
treeb70284a297d2e3c06462e3a3a86166c4371477f9 /biology/seaview/Makefile
parentdd1603cad7e60d10dd91a2f1f918e24ed859ed24 (diff)
downloadfreebsd-ports-gnome-aa52cd921c82a10ec33065084fe0edb5cf8bebbc.tar.gz
freebsd-ports-gnome-aa52cd921c82a10ec33065084fe0edb5cf8bebbc.tar.zst
freebsd-ports-gnome-aa52cd921c82a10ec33065084fe0edb5cf8bebbc.zip
Adjust port Makefiles to new EXTRACT_* variable defaults. See log of
bsd.port.mk rev. 1.304 for details on the change. The fix here is one of the following. (1) Define USE_BZIP2 instead of BUILD_DEPENDS on bzip2 and redefining EXTRACT_* commands. (2) Change ${EXTRACT_CMD} to ${TAR} when the command is obviously calling the "tar" command (i.e., arguments like "-xzf" are spelled out). (3) If ${EXTRACT_CMD} is called directly with ${EXTRACT_BEFORE_ARGS}, add ${EXTRACT_AFTER_ARGS} to the command line as well. (4) If any of EXTRACT_CMD, EXTRACT_BEFORE_ARGS or EXTRACT_AFTER_ARGS is set, define the other two too.
Diffstat (limited to 'biology/seaview/Makefile')
-rw-r--r--biology/seaview/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/biology/seaview/Makefile b/biology/seaview/Makefile
index d506d3589603..b982bf2f0150 100644
--- a/biology/seaview/Makefile
+++ b/biology/seaview/Makefile
@@ -3,7 +3,7 @@
# Date created: Dec 5 1997
# Whom: frankch@waru.life.nthu.edu.tw
#
-# $Id: Makefile,v 1.11 1998/11/03 00:51:24 jseger Exp $
+# $Id: Makefile,v 1.12 1999/01/07 08:19:24 simokawa Exp $
#
DISTNAME= seaview
@@ -21,7 +21,9 @@ ONLY_FOR_ARCHS= i386
USE_X_PREFIX= YES
NO_WRKSUBDIR= YES
+EXTRACT_CMD= ${TAR}
EXTRACT_BEFORE_ARGS= -xf
+EXTRACT_AFTER_ARGS= # empty
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/${DISTNAME} ${PREFIX}/bin