aboutsummaryrefslogtreecommitdiffstats
path: root/biology/tRNAscan-SE/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-05-22 08:49:42 +0800
committermiwi <miwi@FreeBSD.org>2008-05-22 08:49:42 +0800
commit2a0e3b92514252f266d7c0109a3529b1db4226a0 (patch)
tree34d10087fe51b77c9efaea24b1cd0ddd6e2d9e2a /biology/tRNAscan-SE/Makefile
parent6440de8ec53e0e293b93602e467272ae99476618 (diff)
downloadfreebsd-ports-gnome-2a0e3b92514252f266d7c0109a3529b1db4226a0.tar.gz
freebsd-ports-gnome-2a0e3b92514252f266d7c0109a3529b1db4226a0.tar.zst
freebsd-ports-gnome-2a0e3b92514252f266d7c0109a3529b1db4226a0.zip
- Update MASTER_SITES and WWW: line
- Support CC/CFLAGS properly - Strip binary PR: 123866 Submitted by: Ports Fury
Diffstat (limited to 'biology/tRNAscan-SE/Makefile')
-rw-r--r--biology/tRNAscan-SE/Makefile26
1 files changed, 23 insertions, 3 deletions
diff --git a/biology/tRNAscan-SE/Makefile b/biology/tRNAscan-SE/Makefile
index 1ffeebff9282..da7e62619150 100644
--- a/biology/tRNAscan-SE/Makefile
+++ b/biology/tRNAscan-SE/Makefile
@@ -7,22 +7,42 @@
PORTNAME= tRNAscan-SE
PORTVERSION= 1.23
+PORTREVISION= 1
CATEGORIES= biology
-MASTER_SITES= ftp://ftp.genetics.wustl.edu/pub/eddy/software/
+MASTER_SITES= ftp://selab.janelia.org/pub/software/tRNAscan-SE/
EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
COMMENT= An improved tool for transfer RNA detection
+USE_PERL5= yes
+MAKE_ARGS= BINDIR="${PREFIX}/bin" \
+ LIBDIR="${DATADIR}" \
+ CC="${CC}" \
+ CFLAGS="${CFLAGS}"
+
MAN1= tRNAscan-SE.1
-USE_PERL5= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's|tRNAscanSE setpaths|tRNAscanSE|g ; \
+ s|if tRNAscan-SE|if ./tRNAscan-SE|g' ${WRKSRC}/Makefile
+
+do-install:
+.for f in covels-SE coves-SE eufindtRNA trnascan-1.4
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
+.endfor
+ ${INSTALL_SCRIPT} ${WRKSRC}/tRNAscan-SE ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/tRNAscan-SE.man ${MANPREFIX}/man/man1/tRNAscan-SE.1
+ @${MKDIR} ${DATADIR}
+.for f in TPCsignal Dsignal *.cm gcode.*
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DATADIR}
+.endfor
#
# have to install before testing as path to data files is hardcoded
#
post-install:
- @ cd ${WRKSRC} && $(MAKE) testrun
+ @ cd ${WRKSRC} && $(MAKE) testrun
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/Manual.ps ${DOCSDIR}