aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2019-05-19 14:52:38 +0800
committeryuri <yuri@FreeBSD.org>2019-05-19 14:52:38 +0800
commit3c83f77eabe1ad275eb28707a8b962546634f20b (patch)
tree84e7d4cdca9ed7ff4340aa70384db65f8e2f5c7b /biology
parent244951e9e07912ff5edf2ea267b3e8fe1982d5a9 (diff)
downloadfreebsd-ports-gnome-3c83f77eabe1ad275eb28707a8b962546634f20b.tar.gz
freebsd-ports-gnome-3c83f77eabe1ad275eb28707a8b962546634f20b.tar.zst
freebsd-ports-gnome-3c83f77eabe1ad275eb28707a8b962546634f20b.zip
New port: biology/hhsuite: Remote protein homology detection suite
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/hhsuite/Makefile26
-rw-r--r--biology/hhsuite/distinfo3
-rw-r--r--biology/hhsuite/files/patch-data_CMakeLists.txt11
-rw-r--r--biology/hhsuite/files/patch-scripts_CMakeLists.txt9
-rw-r--r--biology/hhsuite/files/patch-src_cs_getopt__pp.cc11
-rw-r--r--biology/hhsuite/pkg-descr8
-rw-r--r--biology/hhsuite/pkg-plist59
8 files changed, 128 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index 3c920fefacc8..c4248a6aff6a 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -49,6 +49,7 @@
SUBDIR += graphlan
SUBDIR += grappa
SUBDIR += groopm
+ SUBDIR += hhsuite
SUBDIR += hisat2
SUBDIR += hmmer
SUBDIR += htslib
diff --git a/biology/hhsuite/Makefile b/biology/hhsuite/Makefile
new file mode 100644
index 000000000000..e7288f102ee9
--- /dev/null
+++ b/biology/hhsuite/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= hhsuite
+DISTVERSIONPREFIX= v
+DISTVERSION= 3.2.0
+CATEGORIES= biology science
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Remote protein homology detection suite
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= openmpi>0:net/openmpi
+LIB_DEPENDS= libomp.so:devel/openmp
+RUN_DEPENDS= openmpi>0:net/openmpi
+
+USES= cmake perl5 python shebangfix
+SHEBANG_GLOB= *.pl *.py
+USE_GITHUB= yes
+GH_ACCOUNT= soedinglab
+GH_PROJECT= hh-suite
+
+LDFLAGS+= -Wl,-rpath,${LOCALBASE}/mpi/openmpi/lib -L${LOCALBASE}/mpi/openmpi/lib -lmpi # force linking to openmpi, and not to mpich
+
+.include <bsd.port.mk>
diff --git a/biology/hhsuite/distinfo b/biology/hhsuite/distinfo
new file mode 100644
index 000000000000..49ae95d9d8f4
--- /dev/null
+++ b/biology/hhsuite/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1558244086
+SHA256 (soedinglab-hh-suite-v3.2.0_GH0.tar.gz) = 6b870dcfbc1ffb9dd664a45415fcd13cf5970f49d1c7b824160c260fa138e6d6
+SIZE (soedinglab-hh-suite-v3.2.0_GH0.tar.gz) = 6273589
diff --git a/biology/hhsuite/files/patch-data_CMakeLists.txt b/biology/hhsuite/files/patch-data_CMakeLists.txt
new file mode 100644
index 000000000000..4c47731d84e8
--- /dev/null
+++ b/biology/hhsuite/files/patch-data_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- data/CMakeLists.txt.orig 2019-05-19 05:46:02 UTC
++++ data/CMakeLists.txt
+@@ -7,7 +7,7 @@ INSTALL(FILES
+ do_not_delete.pin
+ do_not_delete.psq
+ PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ
+- DESTINATION data
++ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/hhsuite/data
+ )
+
+ include(ResourceCompiler)
diff --git a/biology/hhsuite/files/patch-scripts_CMakeLists.txt b/biology/hhsuite/files/patch-scripts_CMakeLists.txt
new file mode 100644
index 000000000000..4efad430385d
--- /dev/null
+++ b/biology/hhsuite/files/patch-scripts_CMakeLists.txt
@@ -0,0 +1,9 @@
+--- scripts/CMakeLists.txt.orig 2019-05-19 05:44:58 UTC
++++ scripts/CMakeLists.txt
+@@ -21,5 +21,5 @@ INSTALL(PROGRAMS
+ reformat.pl
+ renumberpdb.pl
+ splitfasta.pl
+- DESTINATION scripts
++ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/hhsuite/scripts
+ )
diff --git a/biology/hhsuite/files/patch-src_cs_getopt__pp.cc b/biology/hhsuite/files/patch-src_cs_getopt__pp.cc
new file mode 100644
index 000000000000..df995bccad92
--- /dev/null
+++ b/biology/hhsuite/files/patch-src_cs_getopt__pp.cc
@@ -0,0 +1,11 @@
+--- src/cs/getopt_pp.cc.orig 2019-05-19 05:36:03 UTC
++++ src/cs/getopt_pp.cc
+@@ -21,7 +21,7 @@
+ #include <unistd.h>
+ #include "getopt_pp.h"
+
+-#ifdef __APPLE__
++#if defined(__APPLE__) || defined(__FreeBSD__)
+ extern char** environ;
+ #endif
+
diff --git a/biology/hhsuite/pkg-descr b/biology/hhsuite/pkg-descr
new file mode 100644
index 000000000000..5d2df6f41513
--- /dev/null
+++ b/biology/hhsuite/pkg-descr
@@ -0,0 +1,8 @@
+SIMD-vectorized implementation of the Viterbi algorithm for profile HMM
+alignment and introduced various other speed-ups. This accelerated HHsearch by a
+factor 4 and HHblits by a factor 2 over the previous version 2.0.16. HHblits3 is
+~10x faster than PSI-BLAST and ~20x faster than HMMER3. Jobs to perform HHsearch
+and HHblits searches with many query profile HMMs can be parallelized over cores
+and over servers in a cluster using OpenMP and message passing interface (MPI).
+
+WWW: https://github.com/soedinglab/hh-suite
diff --git a/biology/hhsuite/pkg-plist b/biology/hhsuite/pkg-plist
new file mode 100644
index 000000000000..c0088e8470e1
--- /dev/null
+++ b/biology/hhsuite/pkg-plist
@@ -0,0 +1,59 @@
+bin/a3m_database_extract
+bin/a3m_database_filter
+bin/a3m_database_reduce
+bin/a3m_extract
+bin/a3m_reduce
+bin/cstranslate
+bin/cstranslate_mpi
+bin/ffindex_apply
+bin/ffindex_apply_mpi
+bin/ffindex_build
+bin/ffindex_from_fasta
+bin/ffindex_from_fasta_with_split
+bin/ffindex_get
+bin/ffindex_modify
+bin/ffindex_order
+bin/ffindex_reduce
+bin/ffindex_unpack
+bin/hhalign
+bin/hhalign_mpi
+bin/hhalign_omp
+bin/hhblits
+bin/hhblits_ca3m
+bin/hhblits_mpi
+bin/hhblits_omp
+bin/hhconsensus
+bin/hhfilter
+bin/hhmake
+bin/hhsearch
+bin/hhsearch_mpi
+bin/hhsearch_omp
+%%DATADIR%%/data/context_data.crf
+%%DATADIR%%/data/context_data.lib
+%%DATADIR%%/data/cs219.lib
+%%DATADIR%%/data/do_not_delete
+%%DATADIR%%/data/do_not_delete.phr
+%%DATADIR%%/data/do_not_delete.pin
+%%DATADIR%%/data/do_not_delete.psq
+%%DATADIR%%/scripts/Align.pm
+%%DATADIR%%/scripts/HHPaths.pm
+%%DATADIR%%/scripts/a3m.py
+%%DATADIR%%/scripts/addss.pl
+%%DATADIR%%/scripts/check_a3m.py
+%%DATADIR%%/scripts/cif2fasta.py
+%%DATADIR%%/scripts/create_profile_from_hhm.pl
+%%DATADIR%%/scripts/create_profile_from_hmmer.pl
+%%DATADIR%%/scripts/ffindex.py
+%%DATADIR%%/scripts/get_a3m_size.py
+%%DATADIR%%/scripts/hh_reader.py
+%%DATADIR%%/scripts/hhmakemodel.pl
+%%DATADIR%%/scripts/hhmakemodel.py
+%%DATADIR%%/scripts/hhsuitedb.py
+%%DATADIR%%/scripts/mergeali.pl
+%%DATADIR%%/scripts/multithread.pl
+%%DATADIR%%/scripts/pdb2fasta.pl
+%%DATADIR%%/scripts/pdbfilter.pl
+%%DATADIR%%/scripts/pdbfilter.py
+%%DATADIR%%/scripts/reformat.pl
+%%DATADIR%%/scripts/renumberpdb.pl
+%%DATADIR%%/scripts/splitfasta.pl