aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authorjwb <jwb@FreeBSD.org>2019-02-20 06:20:11 +0800
committerjwb <jwb@FreeBSD.org>2019-02-20 06:20:11 +0800
commit43eb57aad67ac2bbacf9713ec4b3b89dbd20a7ba (patch)
tree883b9324d29b9771fe69fd291f72c299c4db779d /biology
parent47030c212f5c2f358b5c9cab0d9d78dc5a290bc8 (diff)
downloadfreebsd-ports-gnome-43eb57aad67ac2bbacf9713ec4b3b89dbd20a7ba.tar.gz
freebsd-ports-gnome-43eb57aad67ac2bbacf9713ec4b3b89dbd20a7ba.tar.zst
freebsd-ports-gnome-43eb57aad67ac2bbacf9713ec4b3b89dbd20a7ba.zip
biology/pbcopper: Upgrade to 0.4.1 release
In preparation for biology/unanimity upgrade
Diffstat (limited to 'biology')
-rw-r--r--biology/pbcopper/Makefile21
-rw-r--r--biology/pbcopper/distinfo6
-rw-r--r--biology/pbcopper/files/patch-cmake_pbcopper-gitsha1.cmake21
-rw-r--r--biology/pbcopper/files/patch-meson__options.txt7
-rw-r--r--biology/pbcopper/pkg-plist9
5 files changed, 26 insertions, 38 deletions
diff --git a/biology/pbcopper/Makefile b/biology/pbcopper/Makefile
index f02f7ade599c..19f84985b50c 100644
--- a/biology/pbcopper/Makefile
+++ b/biology/pbcopper/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= pbcopper
-DISTVERSION= g20180413
-PORTREVISION= 3
+DISTVERSION= 0.4.1 # Test with biology/unanimity before upgrading!
CATEGORIES= biology
MAINTAINER= jwb@FreeBSD.org
@@ -13,17 +12,17 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LIB_DEPENDS= libboost_regex.so:devel/boost-libs
-USES= cmake compiler:c++14-lang
-# Although there are a couple releases, git describe --tags does not work
-# so we cannot use the usual USE_GITHUB tools here.
+# Meson needs BOOST_ROOT=${LOCALBASE}
+# https://github.com/mesonbuild/meson/issues/2239
+USES= compiler:c++14-lang localbase meson
+USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= PacificBiosciences
-GH_TAGNAME= 17ef457a0dbe1894a8d17af7ddba01a6261bf117
-do-install:
- ${INSTALL_DATA} ${BUILD_WRKSRC}/lib/*.a ${STAGEDIR}${PREFIX}/lib
- cd ${WRKSRC}/include && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/include
- ${MV} ${STAGEDIR}${PREFIX}/include/meson.build \
- ${STAGEDIR}${PREFIX}/include/pbcopper
+post-install:
+ ${RLN} ${STAGEDIR}${PREFIX}/lib/libpbcopper.so.${PORTVERSION} \
+ ${STAGEDIR}${PREFIX}/lib/libpbcopper.so.0.4
+ ${RLN} ${STAGEDIR}${PREFIX}/lib/libpbcopper.so.${PORTVERSION} \
+ ${STAGEDIR}${PREFIX}/lib/libpbcopper.so.0
.include <bsd.port.mk>
diff --git a/biology/pbcopper/distinfo b/biology/pbcopper/distinfo
index 4ee86047d81b..fafecefe146c 100644
--- a/biology/pbcopper/distinfo
+++ b/biology/pbcopper/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1524500014
-SHA256 (PacificBiosciences-pbcopper-g20180413-17ef457a0dbe1894a8d17af7ddba01a6261bf117_GH0.tar.gz) = 13f006d53334a0538657e0ba5c6e02f811f1901cd25fce220fc9011726ffe23f
-SIZE (PacificBiosciences-pbcopper-g20180413-17ef457a0dbe1894a8d17af7ddba01a6261bf117_GH0.tar.gz) = 3033636
+TIMESTAMP = 1550453144
+SHA256 (PacificBiosciences-pbcopper-0.4.1_GH0.tar.gz) = 4c8daf6c1a6efe3860a16fb5b6111ebe65221423254819f3a68a400d0a984fcd
+SIZE (PacificBiosciences-pbcopper-0.4.1_GH0.tar.gz) = 3095846
diff --git a/biology/pbcopper/files/patch-cmake_pbcopper-gitsha1.cmake b/biology/pbcopper/files/patch-cmake_pbcopper-gitsha1.cmake
deleted file mode 100644
index 56eb84971d36..000000000000
--- a/biology/pbcopper/files/patch-cmake_pbcopper-gitsha1.cmake
+++ /dev/null
@@ -1,21 +0,0 @@
---- cmake/pbcopper-gitsha1.cmake.orig 2018-03-16 16:16:38 UTC
-+++ cmake/pbcopper-gitsha1.cmake
-@@ -5,16 +5,15 @@ endif()
- set(__find_git_sha1 YES)
-
- function(find_git_sha1 _GIT_SHA1)
-- find_package(Git QUIET REQUIRED)
- execute_process(COMMAND
-- "${GIT_EXECUTABLE}" "describe" "--always" "--dirty=*"
-+ echo ce9a4b6
- WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}"
- RESULT_VARIABLE res
- OUTPUT_VARIABLE out
- ERROR_QUIET
- OUTPUT_STRIP_TRAILING_WHITESPACE)
- if (NOT res EQUAL 0)
-- message(FATAL_ERROR "Could not determine git sha1 via `git describe --always --dirty=*`")
-+ message(FATAL_ERROR "Could not determine git sha1")
- endif()
- set(${_GIT_SHA1} "${out}" PARENT_SCOPE)
- endfunction()
diff --git a/biology/pbcopper/files/patch-meson__options.txt b/biology/pbcopper/files/patch-meson__options.txt
new file mode 100644
index 000000000000..6d50fa2bf1da
--- /dev/null
+++ b/biology/pbcopper/files/patch-meson__options.txt
@@ -0,0 +1,7 @@
+--- meson_options.txt.orig 2019-02-17 22:34:29 UTC
++++ meson_options.txt
+@@ -1,3 +1,3 @@
+ option('build-examples', type : 'boolean', value : true, description : 'Build pbcopper examples')
+ option('build-docs', type : 'boolean', value : false, description : 'Build pbcopper docs')
+-option('tests', type : 'boolean', value : true, description : 'Enable dependencies required for testing')
++option('tests', type : 'boolean', value : false, description : 'Enable dependencies required for testing')
diff --git a/biology/pbcopper/pkg-plist b/biology/pbcopper/pkg-plist
index 0c9352560b76..92caf488a25f 100644
--- a/biology/pbcopper/pkg-plist
+++ b/biology/pbcopper/pkg-plist
@@ -1,4 +1,5 @@
include/pbcopper/PbcopperConfig.h
+include/pbcopper/PbcopperMakeUnique.h
include/pbcopper/align/Seed.h
include/pbcopper/align/Seeds.h
include/pbcopper/align/internal/Seed-inl.h
@@ -23,7 +24,6 @@ include/pbcopper/cli/toolcontract/ResolvedToolContract.h
include/pbcopper/cli/toolcontract/ResourceType.h
include/pbcopper/cli/toolcontract/Task.h
include/pbcopper/cli/toolcontract/TaskType.h
-include/pbcopper/cli/toolcontract/internal/Config-inl.h
include/pbcopper/cli/toolcontract/internal/Driver-inl.h
include/pbcopper/cli/toolcontract/internal/InputFileType-inl.h
include/pbcopper/cli/toolcontract/internal/OutputFileType-inl.h
@@ -48,7 +48,6 @@ include/pbcopper/json/JSON.h
include/pbcopper/json/internal/json.hpp
include/pbcopper/logging/Logging.h
include/pbcopper/logging/internal/Logging-inl.h
-include/pbcopper/meson.build
include/pbcopper/parallel/FireAndForget.h
include/pbcopper/parallel/WorkQueue.h
include/pbcopper/qgram/Index.h
@@ -72,4 +71,8 @@ include/pbcopper/utility/internal/FileUtils-inl.h
include/pbcopper/utility/internal/Stopwatch-inl.h
include/pbcopper/utility/internal/StringUtils-inl.h
include/pbcopper/utility/internal/SystemInfo-inl.h
-lib/libpbcopper.a
+lib/libpbcopper.so
+lib/libpbcopper.so.0
+lib/libpbcopper.so.0.4
+lib/libpbcopper.so.0.4.1
+libdata/pkgconfig/pbcopper.pc