aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authorjrm <jrm@FreeBSD.org>2016-09-28 10:30:29 +0800
committerjrm <jrm@FreeBSD.org>2016-09-28 10:30:29 +0800
commitb0d0f5163e77afc24d8eba4ac2bcaff317849a62 (patch)
treefa6b81e0f9966e4269483763095c15fea9c47d76 /biology
parent83ceb4707f4267842a0385cfa6f91098a381b0f8 (diff)
downloadfreebsd-ports-gnome-b0d0f5163e77afc24d8eba4ac2bcaff317849a62.tar.gz
freebsd-ports-gnome-b0d0f5163e77afc24d8eba4ac2bcaff317849a62.tar.zst
freebsd-ports-gnome-b0d0f5163e77afc24d8eba4ac2bcaff317849a62.zip
biology/paml: update to version 4.9c and various improvements
- Update to version 4.9c - Set LICENSE=GPLv3 - Use the variable PORTDOCS to automate the generation of the DOCS plist (as suggested by mat@). - Install dat/ examples/ and Technical/ directories as well as files in the root directory of the distribution tarball. - Fix broken permissions. - Delete Windows executables. - Build and install useful binaries not built by upstream's Makefile. - Update pkg-descr. Reviewed by: swills (mentor) Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D8040
Diffstat (limited to 'biology')
-rw-r--r--biology/paml/Makefile46
-rw-r--r--biology/paml/distinfo6
-rw-r--r--biology/paml/pkg-descr23
-rw-r--r--biology/paml/pkg-plist6
4 files changed, 48 insertions, 33 deletions
diff --git a/biology/paml/Makefile b/biology/paml/Makefile
index 9a74d5ac1235..265e61490a39 100644
--- a/biology/paml/Makefile
+++ b/biology/paml/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= paml
-PORTVERSION= 4.9a
+PORTVERSION= 4.9c
CATEGORIES= biology
MASTER_SITES= http://abacus.gene.ucl.ac.uk/software/
DISTNAME= ${PORTNAME}${PORTVERSION}
@@ -10,24 +10,52 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= jrm@FreeBSD.org
COMMENT= Phylogenetic Analysis by Maximum Likelihood (PAML)
+LICENSE= GPLv3
+
USES= gmake tar:tgz
-WRKSRC= ${WRKDIR}/${DISTNAME}/src
-MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
-BINARIES= baseml basemlg chi2 codeml evolver pamp yn00
-DOC_FILES= pamlDOC.pdf pamlFAQs.pdf pamlHistory.txt
+BINARIES= baseml basemlg chi2 codeml evolver evolverNSbranches \
+ evolverNSbranchsites evolverNSsites pamp yn00
+
+PORTDOCS= MCMCtree.Tutorials.pdf MCMCtreeDOC.pdf pamlDOC.pdf pamlFAQs.pdf \
+ pamlHistory.txt README.txt
+
+DATA= 3s.trees 4s.trees 5s.trees 6s.trees GeneticCode.txt MCaa.dat \
+ MCbase.dat MCbaseRandomTree.dat MCcodon.dat aaml.ctl baseml.ctl \
+ brown.nuc brown.rooted.trees brown.trees codeml.ctl codonml.ctl \
+ mcmctree.ctl pamp.ctl paupblock paupend paupstart stewart.aa \
+ stewart.trees yn00.ctl
+PORTDATA= ${DATA} dat examples Technical
OPTIONS_DEFINE= DOCS
+# Fix broken permissions and remove Windows executables
+post-extract:
+ @${CHMOD} -R a+rX ${WRKDIR}
+ @${FIND} ${WRKSRC}/Technical -name "*.exe" -delete
+
+do-build:
+ @cd ${WRKSRC}/src && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD}
+.for f in NSbranches NSsites NSbranchsites
+ @cd ${WRKSRC}/src && \
+ ${CC} ${CFLAGS} -DCodon${f} -o evolver${f} evolver.c tools.c -lm
+.endfor
+
do-install:
.for f in ${BINARIES}
- ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${f} ${STAGEDIR}${PREFIX}/bin
+.endfor
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+.for f in ${DATA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}/${DATADIR}
.endfor
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "dat examples Technical" \
+ ${STAGEDIR}/${DATADIR})
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for f in ${DOC_FILES}
- ${INSTALL_DATA} ${WRKSRC}/../doc/${f} ${STAGEDIR}${DOCSDIR}
-.endfor
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/biology/paml/distinfo b/biology/paml/distinfo
index 00a59125bc88..7165f2139526 100644
--- a/biology/paml/distinfo
+++ b/biology/paml/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1463365805
-SHA256 (paml4.9a.tgz) = 1400b6a48aa7ba2dee637352430a1f64594674168cf7a749ac79093da9a39ef4
-SIZE (paml4.9a.tgz) = 5853303
+TIMESTAMP = 1474920596
+SHA256 (paml4.9c.tgz) = c0c5fb1e1af5a27b2bd80c9daaa91c259157f34a44d297e058f1b9d8689dce02
+SIZE (paml4.9c.tgz) = 5405921
diff --git a/biology/paml/pkg-descr b/biology/paml/pkg-descr
index 142aea337cd7..68733fd977c8 100644
--- a/biology/paml/pkg-descr
+++ b/biology/paml/pkg-descr
@@ -1,22 +1,9 @@
Phylogenetic Analysis by Maximum Likelihood (PAML)
-PAML is a program package for phylogenetic analyses of DNA or protein
-sequences using maximum likelihood, and is maintained and distributed
-by Ziheng Yang.
-
-Possible uses of the programs are:
-- Estimation of branch lengths in a phylogenetic tree and parameters
- in the evolutionary model such as the transition/transversion rate
- ratio, the shape parameter of the gamma distribution for variable
- evolutionary rates among sites, and rate parameters for different
- genes;
-- Test of hypotheses concerning sequence evolution, such as rate
- constancy and independence among nucleotide or amino acid sites, rate
- constancy among lineages (the molecular clock), and homogeneity of
- evolutionary process in multiple genes;
-- Calculation of substitution rates at sites;
-- Reconstruction of ancestral nucleotide or amino acid sequences;
-- Simulation of nucleotide, codon, and amino acid sequence data sets;
-- Phylogenetic tree reconstruction by maximum likelihood and Bayesian methods.
+PAML is a package of programs for phylogenetic analyses of DNA or protein
+sequences using maximum likelihood. It is not good for tree making. It may be
+used to estimate parameters and test hypotheses for the study the evolutionary
+process using trees reconstructed with programs such as PAUP*, PHYLIP, MOLPHY,
+PhyML, or RaxML.
WWW: http://abacus.gene.ucl.ac.uk/software/paml.html
diff --git a/biology/paml/pkg-plist b/biology/paml/pkg-plist
index a7eb37b020f2..3755a5660cbb 100644
--- a/biology/paml/pkg-plist
+++ b/biology/paml/pkg-plist
@@ -3,8 +3,8 @@ bin/basemlg
bin/chi2
bin/codeml
bin/evolver
+bin/evolverNSbranches
+bin/evolverNSbranchsites
+bin/evolverNSsites
bin/pamp
bin/yn00
-%%PORTDOCS%%%%DOCSDIR%%/pamlDOC.pdf
-%%PORTDOCS%%%%DOCSDIR%%/pamlFAQs.pdf
-%%PORTDOCS%%%%DOCSDIR%%/pamlHistory.txt