aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-09-16 03:17:17 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-09-16 03:17:17 +0800
commitef8d7d7d98ebd30a3f9c0bf418e8568e3dffbc09 (patch)
tree4910a7d2513571d09d49adb50be62e3b76e93951 /biology
parentf87c01ea8828a4a148e47b1f394d91a81599c328 (diff)
downloadfreebsd-ports-gnome-ef8d7d7d98ebd30a3f9c0bf418e8568e3dffbc09.tar.gz
freebsd-ports-gnome-ef8d7d7d98ebd30a3f9c0bf418e8568e3dffbc09.tar.zst
freebsd-ports-gnome-ef8d7d7d98ebd30a3f9c0bf418e8568e3dffbc09.zip
Add p5-Bio-FeatureIO 1.6.905
Bio::FeatureIO is an iterator subsystem for genomic sequence features. Bio::FeatureIO is a handler module for the formats in the FeatureIO set (eg, Bio::FeatureIO::GFF). It is the officially sanctioned way of getting at the format objects, which most people should use. The Bio::FeatureIO system can be thought of like biological file handles. They are attached to filehandles with smart formatting rules (eg, GFF format, or BED format) and can either read or write feature objects (Bio::SeqFeature objects, or more correctly, Bio::FeatureHolderI implementing objects, of which Bio::SeqFeature is one such object). If you want to know what to do with a Bio::SeqFeatureI object, read Bio::SeqFeatureI. The idea is that you request a stream object for a particular format. All the stream objects have a notion of an internal file that is read from or written to. A particular FeatureIO object instance is configured for either input or output. A specific example of a stream object is the Bio::FeatureIO::gff object. WWW: http://search.cpan.org/dist/Bio-FeatureIO/
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/p5-Bio-FeatureIO/Makefile28
-rw-r--r--biology/p5-Bio-FeatureIO/distinfo3
-rw-r--r--biology/p5-Bio-FeatureIO/pkg-descr19
-rw-r--r--biology/p5-Bio-FeatureIO/pkg-plist16
5 files changed, 67 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index e9f524296acc..98c0bb8296fd 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -60,6 +60,7 @@
SUBDIR += p5-Bio-Coordinate
SUBDIR += p5-Bio-Das
SUBDIR += p5-Bio-Das-Lite
+ SUBDIR += p5-Bio-FeatureIO
SUBDIR += p5-Bio-GFF3
SUBDIR += p5-Bio-Glite
SUBDIR += p5-Bio-Graphics
diff --git a/biology/p5-Bio-FeatureIO/Makefile b/biology/p5-Bio-FeatureIO/Makefile
new file mode 100644
index 000000000000..2f85c893b768
--- /dev/null
+++ b/biology/p5-Bio-FeatureIO/Makefile
@@ -0,0 +1,28 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Bio-FeatureIO
+PORTVERSION= 1.6.905
+CATEGORIES= biology perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Handler for FeatureIO
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= p5-BioPerl>=0:biology/p5-BioPerl \
+ p5-Tree-DAG_Node>=0:devel/p5-Tree-DAG_Node \
+ p5-URI>=0:net/p5-URI \
+ p5-XML-DOM>=0:textproc/p5-XML-DOM \
+ p5-XML-DOM-XPath>=0:textproc/p5-XML-DOM-XPath
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+NO_ARCH= yes
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/biology/p5-Bio-FeatureIO/distinfo b/biology/p5-Bio-FeatureIO/distinfo
new file mode 100644
index 000000000000..35d83d252f57
--- /dev/null
+++ b/biology/p5-Bio-FeatureIO/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1505488503
+SHA256 (Bio-FeatureIO-1.6.905.tar.gz) = 322e5757b374f2fb90b8f20bdbdc75631f5cb4d122f81a4d35c3a177cf950c7a
+SIZE (Bio-FeatureIO-1.6.905.tar.gz) = 54906
diff --git a/biology/p5-Bio-FeatureIO/pkg-descr b/biology/p5-Bio-FeatureIO/pkg-descr
new file mode 100644
index 000000000000..dbeef47cb191
--- /dev/null
+++ b/biology/p5-Bio-FeatureIO/pkg-descr
@@ -0,0 +1,19 @@
+Bio::FeatureIO is an iterator subsystem for genomic sequence features.
+
+Bio::FeatureIO is a handler module for the formats in the FeatureIO set (eg,
+Bio::FeatureIO::GFF). It is the officially sanctioned way of getting at the
+format objects, which most people should use.
+
+The Bio::FeatureIO system can be thought of like biological file handles. They
+are attached to filehandles with smart formatting rules (eg, GFF format, or BED
+format) and can either read or write feature objects (Bio::SeqFeature objects,
+or more correctly, Bio::FeatureHolderI implementing objects, of which
+Bio::SeqFeature is one such object). If you want to know what to do with a
+Bio::SeqFeatureI object, read Bio::SeqFeatureI.
+
+The idea is that you request a stream object for a particular format. All the
+stream objects have a notion of an internal file that is read from or written
+to. A particular FeatureIO object instance is configured for either input or
+output. A specific example of a stream object is the Bio::FeatureIO::gff object.
+
+WWW: http://search.cpan.org/dist/Bio-FeatureIO/
diff --git a/biology/p5-Bio-FeatureIO/pkg-plist b/biology/p5-Bio-FeatureIO/pkg-plist
new file mode 100644
index 000000000000..00952b34ad92
--- /dev/null
+++ b/biology/p5-Bio-FeatureIO/pkg-plist
@@ -0,0 +1,16 @@
+%%SITE_PERL%%/Bio/FeatureIO.pm
+%%SITE_PERL%%/Bio/FeatureIO/bed.pm
+%%SITE_PERL%%/Bio/FeatureIO/gff.pm
+%%SITE_PERL%%/Bio/FeatureIO/gtf.pm
+%%SITE_PERL%%/Bio/FeatureIO/interpro.pm
+%%SITE_PERL%%/Bio/FeatureIO/ptt.pm
+%%SITE_PERL%%/Bio/FeatureIO/vecscreen_simple.pm
+%%SITE_PERL%%/Bio/SeqFeature/Annotated.pm
+%%PERL5_MAN3%%/Bio::FeatureIO.3.gz
+%%PERL5_MAN3%%/Bio::FeatureIO::bed.3.gz
+%%PERL5_MAN3%%/Bio::FeatureIO::gff.3.gz
+%%PERL5_MAN3%%/Bio::FeatureIO::gtf.3.gz
+%%PERL5_MAN3%%/Bio::FeatureIO::interpro.3.gz
+%%PERL5_MAN3%%/Bio::FeatureIO::ptt.3.gz
+%%PERL5_MAN3%%/Bio::FeatureIO::vecscreen_simple.3.gz
+%%PERL5_MAN3%%/Bio::SeqFeature::Annotated.3.gz