aboutsummaryrefslogtreecommitdiffstats
path: root/cad/calculix/Makefile
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2015-03-14 14:41:37 +0800
committermaho <maho@FreeBSD.org>2015-03-14 14:41:37 +0800
commit9ebed7708b8f43f59e240eb1d6841b70f7acfcc8 (patch)
treea86d8e32b13f787dc431200c76e346e1e6f8b358 /cad/calculix/Makefile
parent8f24bdeca40373c211d40b8191f519bcdaded5a5 (diff)
downloadfreebsd-ports-gnome-9ebed7708b8f43f59e240eb1d6841b70f7acfcc8.tar.gz
freebsd-ports-gnome-9ebed7708b8f43f59e240eb1d6841b70f7acfcc8.tar.zst
freebsd-ports-gnome-9ebed7708b8f43f59e240eb1d6841b70f7acfcc8.zip
Now we can choose between OpenBLAS and reference BLAS.
Diffstat (limited to 'cad/calculix/Makefile')
-rw-r--r--cad/calculix/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/cad/calculix/Makefile b/cad/calculix/Makefile
index ba70fdfc40e9..254474dced4a 100644
--- a/cad/calculix/Makefile
+++ b/cad/calculix/Makefile
@@ -39,9 +39,19 @@ USE_GL= glut
BROWSER?= firefox
PSVIEWER?= gv
-OPTIONS_DEFINE= ATLAS METIS METIS_EDF DOCS EXAMPLES
+OPTIONS_DEFINE= METIS METIS_EDF DOCS EXAMPLES
OPTIONS_DEFAULT=METIS
+OPTIONS_RADIO= BLAS
+OPTIONS_RADIO_BLAS= REFERENCE OBLAS
+OPTIONS_DEFAULT= REFERENCE
+
+REFERENCE_DESC= Blas / Lapack
+REFERENCE_USES= blaslapack:netlib
+
+OBLAS_DESC= Openblas
+OBLAS_USES= blaslapack:openblas
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MEXAMPLES}
@@ -61,12 +71,6 @@ LIB_DEPENDS+= libmetis.so:${PORTSDIR}/math/metis4
LIB_DEPENDS+= libmetis.so:${PORTSDIR}/math/metis-edf
.endif
-.if ${PORT_OPTIONS:MATLAS}
-USES+= blaslapack:atlas
-.else
-USES+= blaslapack
-.endif
-
.if ${ARCH} == "sparc64"
CFLAGS+= -fPIC
FFLAGS+= -fPIC