aboutsummaryrefslogtreecommitdiffstats
path: root/cad/freecad
diff options
context:
space:
mode:
authorcmt <cmt@FreeBSD.org>2019-02-10 05:04:06 +0800
committercmt <cmt@FreeBSD.org>2019-02-10 05:04:06 +0800
commit3ae87dd7ac5d8ac42ab4a4a1260fc45fbc498705 (patch)
treefdfe64a3d134b11e876bf4a2a7c33b9729a7e672 /cad/freecad
parent978fb00c2925f70e14f8d429125ff70c1dc3b0b8 (diff)
downloadfreebsd-ports-gnome-3ae87dd7ac5d8ac42ab4a4a1260fc45fbc498705.tar.gz
freebsd-ports-gnome-3ae87dd7ac5d8ac42ab4a4a1260fc45fbc498705.tar.zst
freebsd-ports-gnome-3ae87dd7ac5d8ac42ab4a4a1260fc45fbc498705.zip
switch cad/freecad to Qt5 - this is the Makefile.
Diffstat (limited to 'cad/freecad')
-rw-r--r--cad/freecad/Makefile32
1 files changed, 14 insertions, 18 deletions
diff --git a/cad/freecad/Makefile b/cad/freecad/Makefile
index 23d078cfff83..5474b9d063eb 100644
--- a/cad/freecad/Makefile
+++ b/cad/freecad/Makefile
@@ -3,56 +3,52 @@
PORTNAME= FreeCAD
DISTVERSION= 0.17-13541 # git rev-list --count
DISTVERSIONSUFFIX= -g9948ee4f1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= cad
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= cmt@FreeBSD.org
COMMENT= General purpose 3D CAD modeller
LICENSE= LGPL20+
LICENSE_FILE= ${WRKSRC}/COPYING
-DEPRECATED= Qt4 has been EOL since december 2015
-EXPIRATION_DATE= 2019-03-15
-
-BUILD_DEPENDS= pyside-rcc:devel/pyside-tools \
+BUILD_DEPENDS= pyside2-rcc:devel/pyside2-tools \
swig3.0:devel/swig30
LIB_DEPENDS= libexpat.so:textproc/expat2 \
libfreetype.so:print/freetype2 \
${PY_BOOST} \
- libpyside-python2.7.so:devel/pyside@${PY_FLAVOR} \
+ libpyside2-${PYTHON_VERSION}.so:devel/pyside2@${PY_FLAVOR} \
libCoin.so:graphics/Coin \
libpng.so:graphics/png \
libtiff.so:graphics/tiff \
libvtkFiltersTexture-6.2.so:math/vtk6 \
libTKernel.so:cad/opencascade \
- libSoQt.so:x11-toolkits/soqt \
libxerces-c.so:textproc/xerces-c3 \
libboost_thread.so:devel/boost-libs \
libarea.so:devel/libarea \
libmed.so:french/med \
- libshiboken-${PYTHON_VERSION}.so:devel/shiboken \
+ libshiboken2-${PYTHON_VERSION}.so:devel/shiboken2@${PY_FLAVOR} \
libhdf5.so:science/hdf5
-RUN_DEPENDS= pivy>0:graphics/py-pivy@${PY_FLAVOR}
+RUN_DEPENDS= pivy-devel>0:graphics/py-pivy-devel@${PY_FLAVOR}
-USES= dos2unix compiler:c++11-lib cmake eigen:3 fortran jpeg \
- python:2.7 localbase qt:4
+USES= dos2unix compiler:c++11-lib cmake gl eigen:3 fortran jpeg \
+ python:2.7 localbase qt:5
USE_GITHUB= yes
USE_XORG= ice sm x11 xext xt
USE_GL= gl glu
-USE_QT= qmake_build corelib gui moc_build network opengl rcc_build \
- uic_build svg xml webkit
+USE_QT= buildtools qmake_build core gui network opengl svg xml webkit widgets printsupport concurrent
USE_LDCONFIG= yes
+
DOS2UNIX_GLOB= *.txt *.h *.cpp *.py *.qss *.csv *.pov *.stp *.ui *.wrl *.WRL
-CMAKE_ARGS= -DOCC_INCLUDE_DIR="${LOCALBASE}/include/OpenCASCADE"
# To be removed when french/med will be built against science/hdf5
LIB_DEPENDS+= libhdf5-18.so:science/hdf5-18
-CMAKE_ARGS+= -DHDF5_FOUND="TRUE" -DHDF5_VERSION="1.8.17" \
+CMAKE_ARGS+= -DOCC_INCLUDE_DIR="${LOCALBASE}/include/OpenCASCADE" \
+ -DHDF5_FOUND="TRUE" -DHDF5_VERSION="1.8.17" \
-DHDF5_INCLUDE_DIRS="${LOCALBASE}/include/hdf5-18" \
-DCMAKE_CXX_FLAGS="-I${LOCALBASE}/include/hdf5-18" \
-DCMAKE_C_FLAGS="-I${LOCALBASE}/include/hdf5-18" \
- -DHDF5_LIBRARIES="-lhdf5-18"
+ -DHDF5_LIBRARIES="-lhdf5-18" -DBUILD_QT5="ON"
CFLAGS+= -I${LOCALBASE}/include/hdf5-18
CMAKE_INSTALL_PREFIX= ${PREFIX}/${PORTNAME}
@@ -63,7 +59,7 @@ COLLADA_DESC= Install pycollada for Collada files import
COLLADA_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycollada>0:graphics/py-pycollada@${PY_FLAVOR}
DESKTOP_ENTRIES=${PORTNAME} "" "${PREFIX}/FreeCAD/data/freecad.svg" \
- ${PORTNAME} "Engineering;" false
+ ${PORTNAME} "Graphics;Engineering;" false
post-patch:
@${REINPLACE_CMD} -e '/sed/s,-i,& \\"\\",' \