aboutsummaryrefslogtreecommitdiffstats
path: root/cad/freecad
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-12-26 04:25:39 +0800
committertcberner <tcberner@FreeBSD.org>2018-12-26 04:25:39 +0800
commit49081780dbf920e309ccc96ab737f85e04f46c66 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /cad/freecad
parent08b2e1c36dfd47eb173836d5b9826e537512dc18 (diff)
downloadfreebsd-ports-gnome-49081780dbf920e309ccc96ab737f85e04f46c66.tar.gz
freebsd-ports-gnome-49081780dbf920e309ccc96ab737f85e04f46c66.tar.zst
freebsd-ports-gnome-49081780dbf920e309ccc96ab737f85e04f46c66.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Diffstat (limited to 'cad/freecad')
-rw-r--r--cad/freecad/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/cad/freecad/Makefile b/cad/freecad/Makefile
index a988d295ec06..132a19b4061a 100644
--- a/cad/freecad/Makefile
+++ b/cad/freecad/Makefile
@@ -35,7 +35,7 @@ LIB_DEPENDS= libexpat.so:textproc/expat2 \
libhdf5.so:science/hdf5
RUN_DEPENDS= pivy>0:graphics/py-pivy@${PY_FLAVOR}
-USES= dos2unix compiler:c++11-lib cmake:outsource eigen:3 fortran jpeg \
+USES= dos2unix compiler:c++11-lib cmake eigen:3 fortran jpeg \
python:2.7 localbase qt:4
USE_GITHUB= yes
USE_XORG= ice sm x11 xext xt