aboutsummaryrefslogtreecommitdiffstats
path: root/cad/gmsh
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-02-17 01:15:31 +0800
committertijl <tijl@FreeBSD.org>2014-02-17 01:15:31 +0800
commitf86cbfadd2dbfab1dc1ea72e5084a23c10b1dc6c (patch)
tree49e521faa408bc4bd163bfb0febf91e262772c1c /cad/gmsh
parente04e533cf1bc01e44ad69d14d5c6c205e25bfe3a (diff)
downloadfreebsd-ports-gnome-f86cbfadd2dbfab1dc1ea72e5084a23c10b1dc6c.tar.gz
freebsd-ports-gnome-f86cbfadd2dbfab1dc1ea72e5084a23c10b1dc6c.tar.zst
freebsd-ports-gnome-f86cbfadd2dbfab1dc1ea72e5084a23c10b1dc6c.zip
Convert all USE_FORTRAN=yes to "USES=fortran, USE_GCC=yes". In most cases
USE_GCC=yes has been omitted though. Remove USE_FORTRAN handling from bsd.port.mk and bsd.gcc.mk. Minor cleanups in some ports like USE_GMAKE, NOPORTDOCS,... Exp-run: bdrewery Approved by: portmgr (bdrewery)
Diffstat (limited to 'cad/gmsh')
-rw-r--r--cad/gmsh/Makefile5
-rw-r--r--cad/gmsh/files/patch-Fltk-Main.cpp11
-rw-r--r--cad/gmsh/files/patch-Mesh-meshGFaceBDS.cpp13
-rw-r--r--cad/gmsh/pkg-plist2
4 files changed, 28 insertions, 3 deletions
diff --git a/cad/gmsh/Makefile b/cad/gmsh/Makefile
index d12903e7d412..363a2fbcc471 100644
--- a/cad/gmsh/Makefile
+++ b/cad/gmsh/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gmsh
PORTVERSION= 2.8.4
+PORTREVISION= 1
CATEGORIES= cad
MASTER_SITES= http://www.geuz.org/gmsh/src/ \
http://glaros.dtc.umn.edu/gkhome/fetch/sw/metis/
@@ -26,9 +27,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-source
SLAVEDIRS= cad/gmsh-occ
-USE_FORTRAN= yes
-USES= cmake
-USE_GMAKE= yes
+USES= cmake fortran gmake
USE_GL= yes
ALL_TARGET= all
diff --git a/cad/gmsh/files/patch-Fltk-Main.cpp b/cad/gmsh/files/patch-Fltk-Main.cpp
new file mode 100644
index 000000000000..d5ec754d8136
--- /dev/null
+++ b/cad/gmsh/files/patch-Fltk-Main.cpp
@@ -0,0 +1,11 @@
+--- Fltk/Main.cpp.orig
++++ Fltk/Main.cpp
+@@ -3,7 +3,7 @@
+ // See the LICENSE.txt file for license information. Please report all
+ // bugs and problems to the public mailing list <gmsh@geuz.org>.
+
+-#include <stdlib.h>
++#include <cstdlib>
+ #include <string>
+ #include "Gmsh.h"
+ #include "GmshMessage.h"
diff --git a/cad/gmsh/files/patch-Mesh-meshGFaceBDS.cpp b/cad/gmsh/files/patch-Mesh-meshGFaceBDS.cpp
new file mode 100644
index 000000000000..855c1939a918
--- /dev/null
+++ b/cad/gmsh/files/patch-Mesh-meshGFaceBDS.cpp
@@ -0,0 +1,13 @@
+--- Mesh/meshGFaceBDS.cpp.orig
++++ Mesh/meshGFaceBDS.cpp
+@@ -771,8 +771,8 @@
+ while (it != m.edges.end()){
+ BDS_Edge *e = *it;
+ if (!e->deleted && e->numfaces() == 2){
+- std::map<BDS_Point*, MVertex*>::iterator itp1 = recoverMap->find(e->p1);
+- std::map<BDS_Point*, MVertex*>::iterator itp2 = recoverMap->find(e->p2);
++ std::map<BDS_Point*, MVertex*, PointLessThan>::iterator itp1 = recoverMap->find(e->p1);
++ std::map<BDS_Point*, MVertex*, PointLessThan>::iterator itp2 = recoverMap->find(e->p2);
+ if (itp1 != recoverMap->end() &&
+ itp2 != recoverMap->end() &&
+ itp1->second == itp2->second) toSplit.insert(e);
diff --git a/cad/gmsh/pkg-plist b/cad/gmsh/pkg-plist
index 9ed8acaff405..77aabf76f383 100644
--- a/cad/gmsh/pkg-plist
+++ b/cad/gmsh/pkg-plist
@@ -63,6 +63,7 @@ include/gmsh/OptHomRun.h
include/gmsh/PView.h
include/gmsh/PViewData.h
include/gmsh/PViewDataGModel.h
+include/gmsh/PViewDataList.h
include/gmsh/PViewOptions.h
include/gmsh/Pair.h
include/gmsh/ParamCoord.h
@@ -103,6 +104,7 @@ include/gmsh/linearSystem.h
include/gmsh/linearSystemCSR.h
include/gmsh/linearSystemFull.h
include/gmsh/linearSystemGMM.h
+include/gmsh/linearSystemMUMPS.h
include/gmsh/linearSystemPETSc.h
include/gmsh/mathEvaluator.h
include/gmsh/mathex.h