aboutsummaryrefslogtreecommitdiffstats
path: root/cad/gnucap
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2012-10-10 06:12:13 +0800
committerMark Linimon <linimon@FreeBSD.org>2012-10-10 06:12:13 +0800
commita8693b8dee82d3226a0bc0b337d3eb2085add552 (patch)
tree7d9d8595a250c7e5a9a646200945ef2094927620 /cad/gnucap
parent39890db4500948ba8648094ec8b290262a74d880 (diff)
downloadfreebsd-ports-gnome-a8693b8dee82d3226a0bc0b337d3eb2085add552.tar.gz
freebsd-ports-gnome-a8693b8dee82d3226a0bc0b337d3eb2085add552.tar.zst
freebsd-ports-gnome-a8693b8dee82d3226a0bc0b337d3eb2085add552.zip
Force numerous ports that fail to build with clang over to instead always
rely on gcc. The patch uses the new USE_GCC=any code in Mk/bsd.gcc.mk to accomplish this. The ports chosen were ports that blocked 2 or more ports from building with clang. (There are several hundred other ports that still fail to build with clang, even with this patch. This is merely one step along the way.) Those interested in fixing these ports with clang, and have clang as their default compiler, can simply set FORCE_BASE_CC_FOR_TESTING=yes. For those who have gcc as their default compiler, this change is believed to cause no change. Hat: portmgr Tested with: multiple runs on amd64-8-exp-bcm and 9-exp-clang, with various combinations of patch/no-patch and flag settings.
Diffstat (limited to 'cad/gnucap')
-rw-r--r--cad/gnucap/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/cad/gnucap/Makefile b/cad/gnucap/Makefile
index 4f1f133abed6..13d5274d019e 100644
--- a/cad/gnucap/Makefile
+++ b/cad/gnucap/Makefile
@@ -19,6 +19,7 @@ COMMENT= The GNU Circuit Analysis Package
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
+USE_GCC= any
USE_GMAKE= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes