aboutsummaryrefslogtreecommitdiffstats
path: root/cad/gspiceui/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-11-27 17:42:58 +0800
committermiwi <miwi@FreeBSD.org>2011-11-27 17:42:58 +0800
commitaf2a4dc5cd02776e5a77d5c49db881c659a83923 (patch)
treee83a61e22f625d65d6b96f380012de70f8e0d552 /cad/gspiceui/Makefile
parentab7081a2bd3106c65546237f51bf032d077e9a96 (diff)
downloadfreebsd-ports-gnome-af2a4dc5cd02776e5a77d5c49db881c659a83923.tar.gz
freebsd-ports-gnome-af2a4dc5cd02776e5a77d5c49db881c659a83923.tar.zst
freebsd-ports-gnome-af2a4dc5cd02776e5a77d5c49db881c659a83923.zip
- Update to version 1.0.00
PR: 162828 Submitted by: Ports Fury Feature safe: yes
Diffstat (limited to 'cad/gspiceui/Makefile')
-rw-r--r--cad/gspiceui/Makefile54
1 files changed, 32 insertions, 22 deletions
diff --git a/cad/gspiceui/Makefile b/cad/gspiceui/Makefile
index 566134584519..6ccdbc15969c 100644
--- a/cad/gspiceui/Makefile
+++ b/cad/gspiceui/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gspiceui
-PORTVERSION= 0.9.65
-PORTREVISION= 5
+PORTVERSION= 1.0.00
CATEGORIES= cad
MASTER_SITES= SF/${PORTNAME}/gSpiceUI/${PORTNAME}-v${PORTVERSION}
DISTNAME= ${PORTNAME}-v${PORTVERSION}
@@ -15,24 +14,27 @@ DISTNAME= ${PORTNAME}-v${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= GUI frontend for gnucap/ng-spice circuit simulators
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/License
+
RUN_DEPENDS= gwave:${PORTSDIR}/cad/gwave
+OPTIONS= NGSPICE "Use ng-spice as backend" on \
+ GNUCAP "Use gnucap as backend" off
+
USE_WX= 2.6+
WX_UNICODE= yes
+USE_GCC= 4.6+
USE_GMAKE= yes
+MAKE_JOBS_SAFE= yes
-OPTIONS= NGSPICE "Use ng-spice as backend" on \
- GNUCAP "Use gnucap as backend" off \
- MODELS "Install example models" on
-
+MAN1= gspiceui.1
PORTDOCS= *
+PORTEXAMPLES= *
+PLIST_FILES= bin/gspiceui
.include <bsd.port.pre.mk>
-post-patch:
- @${REINPLACE_CMD} -E -e "s,%%WX_CONFIG%%,${WX_CONFIG},g" \
- ${WRKSRC}/src/Makefile
-
.if !defined(WITHOUT_NGSPICE)
RUN_DEPENDS+= ngspice:${PORTSDIR}/cad/ngspice_rework
.endif
@@ -41,23 +43,31 @@ RUN_DEPENDS+= ngspice:${PORTSDIR}/cad/ngspice_rework
RUN_DEPENDS+= gnucap:${PORTSDIR}/cad/gnucap
.endif
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|:= -Ofast -pipe|+= -I.|g ; \
+ s|^INCLUDES |#INCLUDES |g ; \
+ s|$$(WXCFG)|$$(WX_CONFIG)|g ; \
+ s|$$(CC)|$$(CXX)|g' ${WRKSRC}/src/Makefile
+ @${REINPLACE_CMD} -e \
+ 's|share/gspiceui|share/doc/gspiceui|g' ${WRKSRC}/src/main/HelpTasks.cpp
-post-install:
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/gspiceui ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/gspiceui.1 ${MANPREFIX}/man/man1
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- @(cd ${WRKSRC}/html && ${COPYTREE_SHARE} \* ${DOCSDIR} \
+.for dir in html
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${dir} ${DOCSDIR} \
"! -name Makefile")
+.endfor
.endif
-.if !defined(WITHOUT_MODELS)
- @${MKDIR} ${DATADIR}
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} sch ${DATADIR} \
- "! -name Makefile" && \
- ${COPYTREE_SHARE} lib ${DATADIR} "! -name Makefile")
-PLIST_SUB+= MODELS=""
-.else
-PLIST_SUB+= MODELS="@comment "
+.if !defined(WITHOUT_EXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+.for dir in lib sch
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${dir} ${EXAMPLESDIR} \
+ "! -name Makefile")
+.endfor
.endif
.include <bsd.port.post.mk>