aboutsummaryrefslogtreecommitdiffstats
path: root/cad/libgeda/Makefile
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2001-04-07 08:09:57 +0800
committervanilla <vanilla@FreeBSD.org>2001-04-07 08:09:57 +0800
commita905f73e68c1dc6cf339a13704a0a0b08a98180e (patch)
treeb1a3b649a5d9568816105e2b2653721e17e3d0ff /cad/libgeda/Makefile
parent1d4b346646ffd709de5a68dc7b38ddbb54543817 (diff)
downloadfreebsd-ports-gnome-a905f73e68c1dc6cf339a13704a0a0b08a98180e.tar.gz
freebsd-ports-gnome-a905f73e68c1dc6cf339a13704a0a0b08a98180e.tar.zst
freebsd-ports-gnome-a905f73e68c1dc6cf339a13704a0a0b08a98180e.zip
libgeda is a a base library common to all the gEDA tools
Submitted by: bruno.schwander@technologist.com
Diffstat (limited to 'cad/libgeda/Makefile')
-rw-r--r--cad/libgeda/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/cad/libgeda/Makefile b/cad/libgeda/Makefile
new file mode 100644
index 000000000000..4a3f5b1936fa
--- /dev/null
+++ b/cad/libgeda/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: geda
+# Date created: 4 April 2001
+# Whom: bruno schwander <bruno@tinkerbox.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgeda
+PORTVERSION= 20010304
+CATEGORIES= cad
+MASTER_SITES= ftp://ftp.geda.seul.org/pub/geda/devel/20010304/ \
+ http://geda.seul.org/devel/20010304/ \
+ http://www.tinkerbox.org/projects/files/gEDA/
+
+MAINTAINER= bruno@tinkerbox.org
+
+LIB_DEPENDS= gdgeda.4:${PORTSDIR}/graphics/libgdgeda
+
+USE_LIBTOOL= yes
+USE_AUTOCONF= yes
+USE_GTK= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --enable-gdgeda
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+WRKSRC= ${WRKDIR}/libgeda
+
+.include <bsd.port.mk>