aboutsummaryrefslogtreecommitdiffstats
path: root/cad/opencascade
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-06-26 05:07:58 +0800
committerTobias C. Berner <tcberner@FreeBSD.org>2017-06-26 05:07:58 +0800
commit5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf (patch)
tree3291541f3b73432c893dec35f4f23770dd07732a /cad/opencascade
parent9c92503171817f96d944009b9ea88d3c083c9a45 (diff)
downloadfreebsd-ports-gnome-5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf.tar.gz
freebsd-ports-gnome-5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf.tar.zst
freebsd-ports-gnome-5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf.zip
Make ninja opt-out in cmake.mk
Using ninja instead of make (1) can lead to significant speed ups while building. Therefore switch from having the ninja generator opt-in to having it opt-out. Previously cmake-ports that wanted to use ninja could set CMAKE_NINJA=yes now, ports that do not work with ninja can set cmake:<existing args>,noninja Note, that needing this should be an exception and most often points to a broken cmake of the port. The ports using cmake were modified * removed USES=gmake, if ninja is used * removed MAKE_ARGS, if ninja is used * added the cmake-argument noninja if necessary PR: 219629 PR: 213331 Exp-run by: antoine Reviewed by: rakuco Differential Revision: https://reviews.freebsd.org/D10748
Diffstat (limited to 'cad/opencascade')
-rw-r--r--cad/opencascade/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/cad/opencascade/Makefile b/cad/opencascade/Makefile
index b715090cc6e0..20d3d23bf7b0 100644
--- a/cad/opencascade/Makefile
+++ b/cad/opencascade/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= bash:shells/bash
# Check ${WRKSRC}/dox/overview/Overview.md
# and ${WRKSRC}/dox/dev_guides/building
-USES= alias:10 bison cmake compiler:c++11-lib dos2unix gmake \
+USES= alias:10 bison cmake compiler:c++11-lib dos2unix \
shebangfix tk tar:tgz
USE_XORG= xmu
DOS2UNIX_FILES= adm/templates/*