aboutsummaryrefslogtreecommitdiffstats
path: root/cad/salome-jobmanager
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2011-01-05 05:15:54 +0800
committerthierry <thierry@FreeBSD.org>2011-01-05 05:15:54 +0800
commitdabf56d5c9e5f47098fd6a167a0fa163d4f9358f (patch)
treeb7bbb9a7a43db044a10e67e8265e00ba817d9112 /cad/salome-jobmanager
parent2cce29c43f549d29941faa0344c623d9bf5b0a48 (diff)
downloadfreebsd-ports-gnome-dabf56d5c9e5f47098fd6a167a0fa163d4f9358f.tar.gz
freebsd-ports-gnome-dabf56d5c9e5f47098fd6a167a0fa163d4f9358f.tar.zst
freebsd-ports-gnome-dabf56d5c9e5f47098fd6a167a0fa163d4f9358f.zip
SALOME is a free software that provides a generic platform for Pre
and Post-Processing for numerical simulation. +Supports interoperability between CAD modeling and computation software (CAD-CAE link) +Makes easier the integration of new components on heterogeneous systems for numerical computation +Sets the priority to multi-physics coupling between computation software +Provides a generic user interface, user-friendly and efficient, which helps to reduce the costs and delays of carrying out the studies +Reduces training time to the specific time for learning the software solution which has been based on this platform +All functionalities are accessible through the programmatic integrated Python console This package contains Job manager module. WWW: http://www.salome-platform.org - Stas Timokhin devel@stasyan.com PR: ports/152396 Submitted by: Stas Timokhin <devel at stasyan.com>
Diffstat (limited to 'cad/salome-jobmanager')
-rw-r--r--cad/salome-jobmanager/Makefile15
-rw-r--r--cad/salome-jobmanager/files/patch-configure.ac11
-rw-r--r--cad/salome-jobmanager/pkg-descr19
-rw-r--r--cad/salome-jobmanager/pkg-plist32
4 files changed, 77 insertions, 0 deletions
diff --git a/cad/salome-jobmanager/Makefile b/cad/salome-jobmanager/Makefile
new file mode 100644
index 000000000000..4ad1b6dcfaf6
--- /dev/null
+++ b/cad/salome-jobmanager/Makefile
@@ -0,0 +1,15 @@
+# New ports collection makefile for: cad/salome-jobmanager
+# Date created: 10 Nov 2010
+# Whom: Stas Timokhin <devel@stasyan.com>
+#
+# $FreeBSD$
+
+CATEGORIES= cad science
+
+MASTERDIR= ${.CURDIR}/../salome
+
+PORTNAME= salome
+PKGNAMESUFFIX= -jobmanager
+SAL_MODULE_UPPER= JOBMANAGER
+
+.include "${MASTERDIR}/Makefile"
diff --git a/cad/salome-jobmanager/files/patch-configure.ac b/cad/salome-jobmanager/files/patch-configure.ac
new file mode 100644
index 000000000000..9f345504afe6
--- /dev/null
+++ b/cad/salome-jobmanager/files/patch-configure.ac
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2010-11-10 13:50:32.000000000 +0600
++++ configure.ac 2010-11-10 13:50:39.000000000 +0600
+@@ -39,7 +39,7 @@
+ # argument. Exemple:
+ # $ filename="../KERNEL_SRC/configure
+ # $ absfilename=`absolute_path $filename`
+-function absolute_path {
++absolute_path () {
+ filename=$1
+ here=`pwd`
+ apath=`dirname $filename`
diff --git a/cad/salome-jobmanager/pkg-descr b/cad/salome-jobmanager/pkg-descr
new file mode 100644
index 000000000000..227a988415d9
--- /dev/null
+++ b/cad/salome-jobmanager/pkg-descr
@@ -0,0 +1,19 @@
+SALOME is a free software that provides a generic platform for Pre
+and Post-Processing for numerical simulation.
++Supports interoperability between CAD modeling and
+ computation software (CAD-CAE link)
++Makes easier the integration of new components on heterogeneous systems
+ for numerical computation
++Sets the priority to multi-physics coupling between computation software
++Provides a generic user interface, user-friendly and efficient,
+ which helps to reduce the costs and delays of carrying out the studies
++Reduces training time to the specific time for learning the software solution
+ which has been based on this platform
++All functionalities are accessible through the programmatic
+ integrated Python console
+
+This package contains Job manager module.
+
+WWW: http://www.salome-platform.org
+- Stas Timokhin
+devel@stasyan.com
diff --git a/cad/salome-jobmanager/pkg-plist b/cad/salome-jobmanager/pkg-plist
new file mode 100644
index 000000000000..673ebb8ea20e
--- /dev/null
+++ b/cad/salome-jobmanager/pkg-plist
@@ -0,0 +1,32 @@
+bin/jobmanager_gui
+bin/start_jobmanager.sh
+include/salome/BL_Exception.hxx
+include/salome/BL_SalomeGui.hxx
+include/salome/BL_Traces.hxx
+lib/salome/libBL_Bases.a
+lib/salome/libBL_Bases.la
+lib/salome/libBL_Bases.so
+lib/salome/libBL_Bases.so.0
+lib/salome/libBL_Engine.a
+lib/salome/libBL_Engine.la
+lib/salome/libBL_Engine.so
+lib/salome/libBL_Engine.so.0
+lib/salome/libBL_GenericGui.a
+lib/salome/libBL_GenericGui.la
+lib/salome/libBL_GenericGui.so
+lib/salome/libBL_GenericGui.so.0
+lib/salome/libBL_Wrappers_Qt.a
+lib/salome/libBL_Wrappers_Qt.la
+lib/salome/libBL_Wrappers_Qt.so
+lib/salome/libBL_Wrappers_Qt.so.0
+lib/salome/libBL_Wrappers_SALOME.a
+lib/salome/libBL_Wrappers_SALOME.la
+lib/salome/libBL_Wrappers_SALOME.so
+lib/salome/libBL_Wrappers_SALOME.so.0
+lib/salome/libJOBMANAGER.a
+lib/salome/libJOBMANAGER.la
+lib/salome/libJOBMANAGER.so
+lib/salome/libJOBMANAGER.so.0
+%%DATADIR%%/resources/jobmanager/SalomeApp.xml
+%%DATADIR%%/resources/jobmanager/jobmanager.png
+@dirrm %%DATADIR%%/resources/jobmanager