aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-02-01 14:23:42 +0800
committerpi <pi@FreeBSD.org>2016-02-01 14:23:42 +0800
commit144c73d4899d74dce469bcb7b0191f264a1a5088 (patch)
tree39697cf24995b7c5e0f2ff38d3f2660bc52f195b /cad
parent0bfd07e5dc7cc27f3453a90d337d125bbd82be6d (diff)
downloadfreebsd-ports-gnome-144c73d4899d74dce469bcb7b0191f264a1a5088.tar.gz
freebsd-ports-gnome-144c73d4899d74dce469bcb7b0191f264a1a5088.tar.zst
freebsd-ports-gnome-144c73d4899d74dce469bcb7b0191f264a1a5088.zip
New port: cad/fritzing
Fritzing is an Electronic Design Automation software with a low entry barrier, suited for the needs of designers and artists. It uses the metaphor of the breadboard, so that it is easy to transfer your hardware sketch to the software. From there it is possible to create PCB layouts for turning it into a robust PCB yourself or by help of a manufacturer. WWW: http://fritzing.org/ PR: 206697 Submitted by: lenzi.sergio@gmail.com
Diffstat (limited to 'cad')
-rw-r--r--cad/Makefile1
-rw-r--r--cad/fritzing/Makefile45
-rw-r--r--cad/fritzing/distinfo4
-rw-r--r--cad/fritzing/files/patch-fritzing.desktop11
-rw-r--r--cad/fritzing/files/patch-phoenix.pro44
-rw-r--r--cad/fritzing/files/pkg-install.in15
-rw-r--r--cad/fritzing/pkg-descr8
-rw-r--r--cad/fritzing/pkg-plist5
8 files changed, 133 insertions, 0 deletions
diff --git a/cad/Makefile b/cad/Makefile
index 084e20cda4a8..65131219bc5b 100644
--- a/cad/Makefile
+++ b/cad/Makefile
@@ -25,6 +25,7 @@
SUBDIR += feappv
SUBDIR += fidocadj
SUBDIR += freehdl
+ SUBDIR += fritzing
SUBDIR += gdsreader
SUBDIR += gdt
SUBDIR += geda
diff --git a/cad/fritzing/Makefile b/cad/fritzing/Makefile
new file mode 100644
index 000000000000..5b07d6f5dbdc
--- /dev/null
+++ b/cad/fritzing/Makefile
@@ -0,0 +1,45 @@
+# Created by: Sergio Lenzi <lenzi.sergio@gmail.com>
+# $FreeBSD$
+
+PORTNAME= fritzing
+PORTVERSION= 0.9.2
+PORTREVISION= 3
+CATEGORIES= cad
+MASTER_SITES= https://github.com/fritzing/fritzing-app/archive/:source \
+ https://github.com/fritzing/fritzing-parts/archive/:parts
+DISTFILES= 0.9.2b.tar.gz:source 0.9.2b.zip:parts
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= lenzi.sergio@gmail.com
+COMMENT= CAD for printed circuit boards
+
+LICENSE= GPLv2+
+
+SUB_FILES+= pkg-install
+
+WRKSRC= ${WRKDIR}/fritzing-app-${PORTVERSION}b
+
+USES= dos2unix gmake python qmake tar:bzip2
+USE_QT5= buildtools concurrent core dbus gui imageformats network printsupport qmake serialport sql-sqlite3 svg xml
+DOS2UNIX_REGEX= .*pro
+INSTALLS_ICONS= yes
+
+PORTDATA= *
+MAKE_ENV= INSTALL_ROOT="${STAGEDIR}"
+
+BUILD_DEPENDS+= boost-libs>1.52:${PORTSDIR}/devel/boost-libs
+
+RUN_DEPENDS+= py${PYTHON_SUFFIX}-sqlite3>0:${PORTSDIR}/databases/py-sqlite3
+
+.include <bsd.port.pre.mk>
+
+post-extract:
+ cd ${WRKDIR}/fritzing-parts-0.9.2b;\
+ ${MKDIR} parts;${MV} -f * parts 2> /dev/null || true;\
+ ${MKDIR} pdb;${MV} parts/core pdb;${MKDIR} parts/core;\
+ ${MV} ${WRKDIR}/fritzing-app-0.9.2b/bins .
+
+post-install:
+ ${CP} -rpf ${WRKDIR}/fritzing-parts-0.9.2b/* ${STAGEDIR}${LOCALBASE}/share/fritzing
+
+.include <bsd.port.post.mk>
diff --git a/cad/fritzing/distinfo b/cad/fritzing/distinfo
new file mode 100644
index 000000000000..309595203b6b
--- /dev/null
+++ b/cad/fritzing/distinfo
@@ -0,0 +1,4 @@
+SHA256 (fritzing/0.9.2b.tar.gz) = 6e9dbb94a4ca5e23effc2056f471c78913b9efa4c154ced94de8f72bfe29735f
+SIZE (fritzing/0.9.2b.tar.gz) = 10913985
+SHA256 (fritzing/0.9.2b.zip) = 88f666926cd68fe74810f31dbb0c95b97a77f869246d0f5516f8f26162154c67
+SIZE (fritzing/0.9.2b.zip) = 22306870
diff --git a/cad/fritzing/files/patch-fritzing.desktop b/cad/fritzing/files/patch-fritzing.desktop
new file mode 100644
index 000000000000..3fe96b005217
--- /dev/null
+++ b/cad/fritzing/files/patch-fritzing.desktop
@@ -0,0 +1,11 @@
+--- fritzing.desktop.orig 2015-03-17 13:36:55 UTC
++++ fritzing.desktop
+@@ -2,7 +2,7 @@
+ Name=Fritzing
+ GenericName=Fritzing
+ Comment=Electronic Design Automation software
+-Exec=Fritzing
++Exec=Fritzing -f /usr/local/share/fritzing
+ Icon=fritzing
+ Terminal=false
+ Type=Application
diff --git a/cad/fritzing/files/patch-phoenix.pro b/cad/fritzing/files/patch-phoenix.pro
new file mode 100644
index 000000000000..10e6c0b8d49f
--- /dev/null
+++ b/cad/fritzing/files/patch-phoenix.pro
@@ -0,0 +1,44 @@
+--- phoenix.pro.orig 2016-01-31 22:20:45 UTC
++++ phoenix.pro
+@@ -31,7 +31,7 @@
+ # QTPLUGIN += qjpeg qsqlite
+
+
+-CONFIG += debug_and_release
++CONFIG += release
+ win32 {
+ # release build using msvc 2010 needs to use Multi-threaded (/MT) for the code generation/runtime library option
+ # release build using msvc 2010 needs to add msvcrt.lib;%(IgnoreSpecificDefaultLibraries) to the linker/no default libraries option
+@@ -92,7 +92,7 @@ macx {
+ unix {
+ !macx { # unix is defined on mac
+ HARDWARE_PLATFORM = $$system(uname -m)
+- contains( HARDWARE_PLATFORM, x86_64 ) {
++ contains( HARDWARE_PLATFORM, amd64 ) {
+ DEFINES += LINUX_64
+ } else {
+ DEFINES += LINUX_32
+@@ -101,7 +101,7 @@ unix {
+ }
+
+ isEmpty(PREFIX) {
+- PREFIX = /usr
++ PREFIX = /usr/local
+ }
+ BINDIR = $$PREFIX/bin
+ DATADIR = $$PREFIX/share
+@@ -114,11 +114,11 @@ unix {
+ desktop.path = $$DATADIR/applications
+ desktop.files += fritzing.desktop
+
+- manpage.path = $$DATADIR/man/man1
++ manpage.path = /usr/local/man/man1
+ manpage.files += Fritzing.1
+
+- icon.path = $$DATADIR/icons
+- icon.extra = install -D -m 0644 $$PWD/resources/images/fritzing_icon.png $(INSTALL_ROOT)$$DATADIR/icons/fritzing.png
++ icon.path = $$DATADIR/icons/hicolor/64x64/apps
++ icon.extra = install -m 0644 $$PWD/resources/images/fritzing_icon.png $(INSTALL_ROOT)$$DATADIR/icons/hicolor/64x64/apps/fritzing.png
+
+ parts.path = $$PKGDATADIR
+ parts.files += parts
diff --git a/cad/fritzing/files/pkg-install.in b/cad/fritzing/files/pkg-install.in
new file mode 100644
index 000000000000..a84dd7733456
--- /dev/null
+++ b/cad/fritzing/files/pkg-install.in
@@ -0,0 +1,15 @@
+echo $2 for FRITZING
+
+case $2 in
+PRE-INSTALL)
+ if ! id fritzing > /dev/null 2>&1
+ then
+ pw adduser fritzing
+ fi
+;;
+POST-INSTALL)
+ echo fritzing shared files owned by fritzing user
+ chown -R fritzing:fritzing %%PREFIX%%/share/fritzing
+ chmod -R g+w %%PREFIX%%/share/fritzing
+;;
+esac
diff --git a/cad/fritzing/pkg-descr b/cad/fritzing/pkg-descr
new file mode 100644
index 000000000000..675814532e7e
--- /dev/null
+++ b/cad/fritzing/pkg-descr
@@ -0,0 +1,8 @@
+Fritzing is an Electronic Design Automation software with a low
+entry barrier, suited for the needs of designers and artists. It
+uses the metaphor of the breadboard, so that it is easy to transfer
+your hardware sketch to the software. From there it is possible to
+create PCB layouts for turning it into a robust PCB yourself or by
+help of a manufacturer.
+
+WWW: http://fritzing.org/
diff --git a/cad/fritzing/pkg-plist b/cad/fritzing/pkg-plist
new file mode 100644
index 000000000000..01eaa29322b6
--- /dev/null
+++ b/cad/fritzing/pkg-plist
@@ -0,0 +1,5 @@
+bin/Fritzing
+man/man1/Fritzing.1.gz
+share/applications/fritzing.desktop
+share/icons/hicolor/64x64/apps/fritzing.png
+@dir %%DATADIR%%/parts/core