aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-05-11 04:06:35 +0800
committerThierry Thomas <thierry@FreeBSD.org>2021-05-11 04:13:20 +0800
commit1d44af58980136b882d146f21d8776943a14c5eb (patch)
treef3a678f8aea7c2044c105d15a6ff7c7afec40762 /cad
parentaea041f3a2b531c0265897f6aec59936a96a9f35 (diff)
downloadfreebsd-ports-gnome-1d44af58980136b882d146f21d8776943a14c5eb.tar.gz
freebsd-ports-gnome-1d44af58980136b882d146f21d8776943a14c5eb.tar.zst
freebsd-ports-gnome-1d44af58980136b882d146f21d8776943a14c5eb.zip
math/py-matplotlib: chase minimum Python version in dependent ports
Since the previous update changed USES=python from 3.6+ to 3.7+, all dependent ports must have USES=python:3.7+ as well, otherwise it breaks the @py36 flavor. PR: 255347 Reported by: sunpoet
Diffstat (limited to 'cad')
-rw-r--r--cad/freecad/Makefile2
-rw-r--r--cad/py-lcapy/Makefile2
-rw-r--r--cad/py-pyfda/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/cad/freecad/Makefile b/cad/freecad/Makefile
index f4b4d8291217..ed8dec413c9d 100644
--- a/cad/freecad/Makefile
+++ b/cad/freecad/Makefile
@@ -34,7 +34,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pivy>0:graphics/py-pivy@${PY_FLAVOR} \
${PYTHON_SITELIBDIR}/matplotlib/__init__.py:math/py-matplotlib@${PY_FLAVOR}
USES= dos2unix compiler:c++11-lib cmake gl eigen:3 fortran jpeg \
- localbase:ldflags pkgconfig python:3.6+ localbase qt:5 xorg
+ localbase:ldflags pkgconfig python:3.7+ localbase qt:5 xorg
USE_GITHUB= yes
USE_XORG= ice sm x11 xext xt
USE_GL= gl glu
diff --git a/cad/py-lcapy/Makefile b/cad/py-lcapy/Makefile
index bf0e27086810..0c023293665b 100644
--- a/cad/py-lcapy/Makefile
+++ b/cad/py-lcapy/Makefile
@@ -15,7 +15,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sympy>0:math/py-sympy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR}
-USES= python:3.5+
+USES= python:3.7+
USE_PYTHON= distutils concurrent autoplist
USE_GITHUB= yes
GH_ACCOUNT= mph-
diff --git a/cad/py-pyfda/Makefile b/cad/py-pyfda/Makefile
index 7b3f5692c7bc..ac39a8a16727 100644
--- a/cad/py-pyfda/Makefile
+++ b/cad/py-pyfda/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}docutils>0:textproc/py-docutils@${PY_FLAVOR}
${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
-USES= python:3.4+ pyqt:5
+USES= python:3.7+ pyqt:5
USE_PYTHON= distutils autoplist
USE_PYQT= core_run gui_run widgets_run
NO_ARCH= yes