aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authortz <tz@FreeBSD.org>2016-12-16 17:24:32 +0800
committertz <tz@FreeBSD.org>2016-12-16 17:24:32 +0800
commit30c8d12e7a85d2aa85b1e1faeceb00ad43badf07 (patch)
tree0ae8c8ed3c642630ee85c91cd2b3efce1640d0d4 /cad
parent0aef650904d10357290435be1e41145c5e518633 (diff)
downloadfreebsd-ports-gnome-30c8d12e7a85d2aa85b1e1faeceb00ad43badf07.tar.gz
freebsd-ports-gnome-30c8d12e7a85d2aa85b1e1faeceb00ad43badf07.tar.zst
freebsd-ports-gnome-30c8d12e7a85d2aa85b1e1faeceb00ad43badf07.zip
cad/openvsp: fix compilation in 10.1
The port broke on 10.1 since the update to gcc 4.9. Now we enforce gcc 4.8 on FreeBSD 10.1. PR: 215307 Submitted by: fernando.apesteguia@gmail.com (maintainer) Approved by: mentors (implict) MFH: 2016Q4
Diffstat (limited to 'cad')
-rw-r--r--cad/openvsp/Makefile17
1 files changed, 15 insertions, 2 deletions
diff --git a/cad/openvsp/Makefile b/cad/openvsp/Makefile
index 8828e14d4352..e0ff52af5a0e 100644
--- a/cad/openvsp/Makefile
+++ b/cad/openvsp/Makefile
@@ -4,7 +4,7 @@
PORTNAME= openvsp
PORTVERSION= 3.9.1
DISTVERSIONPREFIX= ${GH_PROJECT}_
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= cad
MAINTAINER= fernando.apesteguia@gmail.com
@@ -39,7 +39,20 @@ WRKSRC= ${WRKDIR}/${GH_PROJECT}-${GH_PROJECT}_${PORTVERSION}
CMAKE_SOURCE_PATH= ${WRKSRC}/SuperProject
CMAKE_INSTALL_PREFIX= ${STAGEDIR}${PREFIX}
-USES= cmake:outsource compiler:gcc-c++11-lib jpeg
+USES= cmake:outsource jpeg
+
+.include <bsd.port.options.mk>
+
+.if ${OSVERSION} == 1001000
+# Fails to build with GCC 4.9 in 10.1
+USE_GCC= 4.8
+LDFLAGS+= -L${LOCALBASE}/lib/c++
+CXXFLAGS+= -nostdinc++ -isystem ${LOCALBASE}/include/c++/v1
+BUILD_DEPENDS+= ${LOCALBASE}/lib/c++/libstdc++.so:devel/libc++
+.else
+USES += compiler:gcc-c++11-lib
+.endif
+
CMAKE_ARGS= -DVSP_USE_SYSTEM_CMINPACK:BOOLEAN=yes \
-DVSP_USE_SYSTEM_CPPTEST:BOOLEAN=yes \
-DVSP_USE_SYSTEM_LIBXML2:BOOLEAN=yes \