aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authorultima <ultima@FreeBSD.org>2017-07-27 07:09:46 +0800
committerultima <ultima@FreeBSD.org>2017-07-27 07:09:46 +0800
commit3777f0cfa1bc4f904f6733d153552b78401159e3 (patch)
tree3a1651813b009893b6bb222a634ddbcc6674d96a /cad
parenteec22f5f8d71f30d871cbfcb1e61fee8a2acf652 (diff)
downloadfreebsd-ports-gnome-3777f0cfa1bc4f904f6733d153552b78401159e3.tar.gz
freebsd-ports-gnome-3777f0cfa1bc4f904f6733d153552b78401159e3.tar.zst
freebsd-ports-gnome-3777f0cfa1bc4f904f6733d153552b78401159e3.zip
* Enabled CIDER
* Added New option, SHLIB, only X11 or SHLIB can be selected, X11 is the default * Moved Uses to start Uses section block * Sorted option section to better comply with handbook (13.1.8)[1] [1] https://www.freebsd.org/doc/en/books/porters-handbook/porting-samplem.html#porting-samplem-order PR: 216800 Submitted by: Kevin Zheng <kevinz5000@gmail.com> (maintainer) Reviewed by: lifanov (mentor) Approved by: lifanov (mentor) Differential Revision: https://reviews.freebsd.org/D11729
Diffstat (limited to 'cad')
-rw-r--r--cad/ngspice_rework/Makefile25
-rw-r--r--cad/ngspice_rework/pkg-descr12
-rw-r--r--cad/ngspice_rework/pkg-plist22
3 files changed, 37 insertions, 22 deletions
diff --git a/cad/ngspice_rework/Makefile b/cad/ngspice_rework/Makefile
index 54ce3f68184d..c7ecb9151d64 100644
--- a/cad/ngspice_rework/Makefile
+++ b/cad/ngspice_rework/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ngspice_rework
PORTVERSION= 26
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= cad
MASTER_SITES= SF/ngspice/ng-spice-rework/${PORTVERSION}
DISTNAME= ngspice-${PORTVERSION}
@@ -11,22 +11,33 @@ DISTNAME= ngspice-${PORTVERSION}
MAINTAINER= kevinz5000@gmail.com
COMMENT= Mixed-signal circuit simulator derived from Spice and Cider
+LICENSE= BSD3CLAUSE BSD4CLAUSE LGPL21+
+LICENSE_COMB= multi
LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_aarch64= Fails to link: missing sbrk
-GNU_CONFIGURE= yes
USES= gmake libtool readline
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-readline=yes \
- --enable-xspice
+CONFIGURE_ARGS= --enable-cider --enable-xspice --with-readline=yes
-OPTIONS_DEFINE= DEBUG X11
-OPTIONS_DEFAULT= X11
+OPTIONS_DEFINE= DEBUG
+OPTIONS_DEFAULT= X11
+OPTIONS_SINGLE= INTERFACE
+OPTIONS_SINGLE_INTERFACE= SHLIB X11
+OPTIONS_SUB= yes
+
+SHLIB_DESC= Build as a shared library
+
+DEBUG_CONFIGURE_ENABLE= debug
+
+SHLIB_CONFIGURE_WITH= ngshared
X11_USE= XORG=ice,sm,x11,xaw,xext,xmu,xt
X11_CONFIGURE_WITH= x
-DEBUG_CONFIGURE_ENABLE= debug
+INSTALL_TARGET= install-strip
.include <bsd.port.mk>
diff --git a/cad/ngspice_rework/pkg-descr b/cad/ngspice_rework/pkg-descr
index 514d51691ff7..a04f765d9330 100644
--- a/cad/ngspice_rework/pkg-descr
+++ b/cad/ngspice_rework/pkg-descr
@@ -1,9 +1,7 @@
-Ngspice is the name of a project and of a program in the project. Spice is
-the famous circuit simulator developed by the CAD Group of the University of
-California at Berkeley (UCB). The NG prefix has a lot of meanings: Next
-Generation, New Good, etc. Choose or invent the one you prefer. The ngspice
-project aims to improve the capabilities of the Spice3 circuit simulator. The
-heart of the project is the ngspice program, a circuit simulator derived from
-spice3f5.
+Ngspice is a mixed-level/mixed-signal circuit simulator. Its code is based
+on three open source software packages: Spice3f5, Cider1b1 and Xspice. It is
+the open source successor of these venerable packages. Many, many
+modifications, bug fixes and improvements have been added to the code,
+yielding a stable and reliable simulator.
WWW: http://ngspice.sourceforge.net/
diff --git a/cad/ngspice_rework/pkg-plist b/cad/ngspice_rework/pkg-plist
index 130cb5369730..dc5524f5c76b 100644
--- a/cad/ngspice_rework/pkg-plist
+++ b/cad/ngspice_rework/pkg-plist
@@ -1,10 +1,13 @@
bin/cmpp
-bin/ngmakeidx
-bin/ngmultidec
-bin/ngnutmeg
-bin/ngproc2mod
-bin/ngsconvert
-bin/ngspice
+%%X11%%bin/ngmakeidx
+%%X11%%bin/ngmultidec
+%%X11%%bin/ngnutmeg
+%%X11%%bin/ngproc2mod
+%%X11%%bin/ngsconvert
+%%X11%%bin/ngspice
+%%SHLIB%%lib/libngspice.so
+%%SHLIB%%lib/libngspice.so.0
+%%SHLIB%%lib/libngspice.so.0.0.0
lib/ngspice/analog.cm
lib/ngspice/digital.cm
lib/ngspice/spice2poly.cm
@@ -15,8 +18,8 @@ man/man1/ngnutmeg.1.gz
man/man1/ngsconvert.1.gz
man/man1/ngspice.1.gz
share/ngspice/dlmain.c
-share/ngspice/helpdir/ngspice.idx
-share/ngspice/helpdir/ngspice.txt
+%%X11%%share/ngspice/helpdir/ngspice.idx
+%%X11%%share/ngspice/helpdir/ngspice.txt
share/ngspice/include/ngspice/1-f-code.h
share/ngspice/include/ngspice/FastNorm3.h
share/ngspice/include/ngspice/acdefs.h
@@ -136,6 +139,9 @@ share/ngspice/include/ngspice/typedefs.h
share/ngspice/include/ngspice/wallace.h
share/ngspice/include/ngspice/wordlist.h
share/ngspice/include/ngspice/wstdio.h
+share/ngspice/scripts/ciderinit
+share/ngspice/scripts/devaxis
+share/ngspice/scripts/devload
share/ngspice/scripts/setplot
share/ngspice/scripts/spectrum
share/ngspice/scripts/spinit