aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2017-05-08 02:45:52 +0800
committerdanilo <danilo@FreeBSD.org>2017-05-08 02:45:52 +0800
commit61ce13e7505593fdae9df29a468aa8cfbaa62104 (patch)
treebaba4f83aebaf31d49a9a905db4258473b7a92c5 /cad
parent727ef740aa1290d6a482416f2bcc31a2b41ab402 (diff)
downloadfreebsd-ports-gnome-61ce13e7505593fdae9df29a468aa8cfbaa62104.tar.gz
freebsd-ports-gnome-61ce13e7505593fdae9df29a468aa8cfbaa62104.tar.zst
freebsd-ports-gnome-61ce13e7505593fdae9df29a468aa8cfbaa62104.zip
- Update to 3.10.1
Diffstat (limited to 'cad')
-rw-r--r--cad/xcircuit/Makefile10
-rw-r--r--cad/xcircuit/distinfo6
-rw-r--r--cad/xcircuit/files/patch-tclxcircuit.c11
-rw-r--r--cad/xcircuit/pkg-plist7
4 files changed, 28 insertions, 6 deletions
diff --git a/cad/xcircuit/Makefile b/cad/xcircuit/Makefile
index dc34769c541b..cd99107ffdd9 100644
--- a/cad/xcircuit/Makefile
+++ b/cad/xcircuit/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= xcircuit
-PORTVERSION= 3.8.83
+PORTVERSION= 3.10.1
PORTEPOCH= 1
CATEGORIES= cad
MASTER_SITES= http://opencircuitdesign.com/xcircuit/archive/ \
@@ -13,11 +13,15 @@ COMMENT= X11 circuit schematics drawing program
LICENSE= GPLv2
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+
OPTIONS_DEFINE= EXAMPLES
USE_XORG= ice sm x11 xpm xscrnsaver xt
-USES= tk:tea ghostscript:x11,run gmake tar:tgz
-MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOHEADER="${TRUE}" \
+USE_GNOME= cairo
+USES= ghostscript:x11,run gmake pkgconfig tar:tgz tk:tea
+MAKE_ARGS+= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOHEADER="${TRUE}" \
AUTOMAKE="${TRUE}"
DESKTOP_ENTRIES="Xcircuit" "${COMMENT}" "${DATADIR}/pixmaps/${PORTNAME}.gif" \
diff --git a/cad/xcircuit/distinfo b/cad/xcircuit/distinfo
index 52d701ed7477..d2ea303dd843 100644
--- a/cad/xcircuit/distinfo
+++ b/cad/xcircuit/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1485548679
-SHA256 (xcircuit-3.8.83.tgz) = 263d54f455b0624b3497d375ebf1f557c9b99900a64cb21c013db8690d5248df
-SIZE (xcircuit-3.8.83.tgz) = 1533560
+TIMESTAMP = 1494177970
+SHA256 (xcircuit-3.10.1.tgz) = ee3d695e57bf68f1509a331c88fec7fe029190a8832d76db4cd9f2f2a5aa6e10
+SIZE (xcircuit-3.10.1.tgz) = 1615503
diff --git a/cad/xcircuit/files/patch-tclxcircuit.c b/cad/xcircuit/files/patch-tclxcircuit.c
new file mode 100644
index 000000000000..161c3d101dca
--- /dev/null
+++ b/cad/xcircuit/files/patch-tclxcircuit.c
@@ -0,0 +1,11 @@
+--- tclxcircuit.c.orig 2017-04-25 12:36:04 UTC
++++ tclxcircuit.c
+@@ -8947,7 +8947,7 @@ int defaultscript()
+ sprintf(_STR2, "%s/tcl/%s", SCRIPTS_DIR, STARTUP_FILE);
+ if ((fd = fopen(_STR2, "r")) == NULL) {
+ Wprintf("Failed to open startup script \"%s\"\n", STARTUP_FILE);
+- return;
++ return TCL_ERROR;
+ }
+ }
+ }
diff --git a/cad/xcircuit/pkg-plist b/cad/xcircuit/pkg-plist
index 6de27470f5b3..ed6adc21b3eb 100644
--- a/cad/xcircuit/pkg-plist
+++ b/cad/xcircuit/pkg-plist
@@ -29,6 +29,7 @@ man/man1/xcircuit.1.gz
%%DATADIR%%/boot_xcircuit.tcl
%%DATADIR%%/bparams.tcl
%%DATADIR%%/console.tcl
+%%DATADIR%%/cyrillic.enc
%%DATADIR%%/digital.lps
%%DATADIR%%/digitallib.lps
%%DATADIR%%/digitaltcl.lps
@@ -36,6 +37,7 @@ man/man1/xcircuit.1.gz
%%DATADIR%%/files.tcl
%%DATADIR%%/fonts/courier.lps
%%DATADIR%%/fonts/courier.xfe
+%%DATADIR%%/fonts/courier_cyrillic.xfe
%%DATADIR%%/fonts/courieriso.xfe
%%DATADIR%%/fonts/courieriso2.lps
%%DATADIR%%/fonts/courieriso2.xfe
@@ -43,6 +45,7 @@ man/man1/xcircuit.1.gz
%%DATADIR%%/fonts/courieriso5.xfe
%%DATADIR%%/fonts/helvetica.lps
%%DATADIR%%/fonts/helvetica.xfe
+%%DATADIR%%/fonts/helvetica_cyrillic.xfe
%%DATADIR%%/fonts/helveticaiso.xfe
%%DATADIR%%/fonts/helveticaiso2.lps
%%DATADIR%%/fonts/helveticaiso2.xfe
@@ -54,6 +57,7 @@ man/man1/xcircuit.1.gz
%%DATADIR%%/fonts/symbol.xfe
%%DATADIR%%/fonts/times_roman.lps
%%DATADIR%%/fonts/times_roman.xfe
+%%DATADIR%%/fonts/times_roman_cyrillic.xfe
%%DATADIR%%/fonts/times_romaniso.xfe
%%DATADIR%%/fonts/times_romaniso2.lps
%%DATADIR%%/fonts/times_romaniso2.xfe
@@ -61,6 +65,8 @@ man/man1/xcircuit.1.gz
%%DATADIR%%/fonts/times_romaniso5.xfe
%%DATADIR%%/generic.lps
%%DATADIR%%/ic_templates.lps
+%%DATADIR%%/isolatin2.enc
+%%DATADIR%%/isolatin5.enc
%%DATADIR%%/lgf.lps
%%DATADIR%%/library.tcl
%%DATADIR%%/matgen.tcl
@@ -136,3 +142,4 @@ man/man1/xcircuit.1.gz
%%DATADIR%%/xcircuit.so
%%DATADIR%%/xcircuit.tcl
%%DATADIR%%/xcstartup.tcl
+%%DATADIR%%/xspice.lps