aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2015-02-08 00:07:33 +0800
committerthierry <thierry@FreeBSD.org>2015-02-08 00:07:33 +0800
commit761eab4449ff3d7fcdc41cdc5bd8816c24c53185 (patch)
treefcc774630381a1630b5615dec0ef90b0911812e1 /cad
parentb5549d2e47a5b9efa2771aa134a49b929f182431 (diff)
downloadfreebsd-ports-gnome-761eab4449ff3d7fcdc41cdc5bd8816c24c53185.tar.gz
freebsd-ports-gnome-761eab4449ff3d7fcdc41cdc5bd8816c24c53185.tar.zst
freebsd-ports-gnome-761eab4449ff3d7fcdc41cdc5bd8816c24c53185.zip
Since Gcc is 4.8 by default, Kicad does not build anymore: e.g. see
http://beefy2.isc.freebsd.org/data/10amd64-default/2015-01-08_21h32m30s/logs/kicad-20140622.2.b4027_1,1.log Add an ugly hack to make it build with Gcc 4.7.
Diffstat (limited to 'cad')
-rw-r--r--cad/kicad/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/cad/kicad/Makefile b/cad/kicad/Makefile
index cbf425f92a10..799d4e7df7b5 100644
--- a/cad/kicad/Makefile
+++ b/cad/kicad/Makefile
@@ -21,8 +21,15 @@ RUN_DEPENDS= xpdf:${PORTSDIR}/graphics/xpdf
CONFLICTS= kicad-devel*
USES= cmake dos2unix desktop-file-utils shared-mime-info tar:xz
-# Boost templates and compiler and library support for the ISO C++ 2011 standard from include/wx-3.0
-USES+= compiler:gcc-c++11-lib
+
+# Does not compile with Gcc48
+GCC_DEFAULT= 4.7
+USE_GCC= ${GCC_DEFAULT}
+#USES+= compiler:gcc-c++11-lib
+LDFLAGS+= -L${LOCALBASE}/lib/c++
+CXXFLAGS+= -nostdinc++ -isystem ${LOCALBASE}/include/c++/v1
+BUILD_DEPENDS+= ${LOCALBASE}/lib/c++/libstdc++.so:${PORTSDIR}/devel/libc++
+
DOS2UNIX_GLOB= *.cmake sch_bus_entry.h sch_line.h sch_no_connect.h
USE_XORG= x11 ice xext
USE_GL= yes
@@ -48,7 +55,6 @@ BINS= cvpcb eeschema gerbview kicad pcbnew
EXTRAS2RM= linux-non_unicode linux wings3d LINUX.README \
contrib_makefiles.txt running_kicad_under_W98.txt
-
.include <bsd.port.options.mk>
.if {PORT_OPTIONS:MDOCS}