aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authorjoerg <joerg@FreeBSD.org>2005-09-14 20:15:59 +0800
committerjoerg <joerg@FreeBSD.org>2005-09-14 20:15:59 +0800
commit9742c9ddbbf2cbbd723b4f4e29e054ae62efae47 (patch)
tree1ec2ef147b9d63c0a43dd9091e3a93b808b33dbd /cad
parent27c1d434212223d86699ed1679d6544888953b82 (diff)
downloadfreebsd-ports-gnome-9742c9ddbbf2cbbd723b4f4e29e054ae62efae47.tar.gz
freebsd-ports-gnome-9742c9ddbbf2cbbd723b4f4e29e054ae62efae47.tar.zst
freebsd-ports-gnome-9742c9ddbbf2cbbd723b4f4e29e054ae62efae47.zip
Fix a coredump in the undo processing when doing a rotate editing
operation.
Diffstat (limited to 'cad')
-rw-r--r--cad/xcircuit/Makefile1
-rw-r--r--cad/xcircuit/files/patch-events.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/cad/xcircuit/Makefile b/cad/xcircuit/Makefile
index a618447d0be8..a57ad9be2486 100644
--- a/cad/xcircuit/Makefile
+++ b/cad/xcircuit/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xcircuit
PORTVERSION= 3.3.33
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= cad
MASTER_SITES= http://xcircuit.ece.jhu.edu/archive/
diff --git a/cad/xcircuit/files/patch-events.c b/cad/xcircuit/files/patch-events.c
new file mode 100644
index 000000000000..58f0897eb19a
--- /dev/null
+++ b/cad/xcircuit/files/patch-events.c
@@ -0,0 +1,11 @@
+--- events.c.orig Thu Sep 8 22:33:01 2005
++++ events.c Wed Sep 14 14:11:38 2005
+@@ -2436,7 +2436,7 @@
+ pathptr rotatepath = SELTOPATH(selectobj);
+
+ register_for_undo(XCF_Edit, UNDO_MORE, areastruct.topinstance,
+- *rotatepath);
++ rotatepath);
+ for (genpart = rotatepath->plist; genpart < rotatepath->plist
+ + rotatepath->parts; genpart++)
+ elemrotate(genpart, direction);