aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authorcmt <cmt@FreeBSD.org>2019-02-10 05:00:11 +0800
committercmt <cmt@FreeBSD.org>2019-02-10 05:00:11 +0800
commit978fb00c2925f70e14f8d429125ff70c1dc3b0b8 (patch)
tree2e6c2197b278591453bc211284f763952087b2ba /cad
parentf7be22d9542f36fec3d79807c37e20f9e2dfaee4 (diff)
downloadfreebsd-ports-gnome-978fb00c2925f70e14f8d429125ff70c1dc3b0b8.tar.gz
freebsd-ports-gnome-978fb00c2925f70e14f8d429125ff70c1dc3b0b8.tar.zst
freebsd-ports-gnome-978fb00c2925f70e14f8d429125ff70c1dc3b0b8.zip
switch cad/freecad to Qt5
Diffstat (limited to 'cad')
-rw-r--r--cad/freecad/files/patch-src_Gui_CMakeLists.txt6
-rw-r--r--cad/freecad/files/patch-src_Gui_Command.h12
-rw-r--r--cad/freecad/files/patch-src_Mod_Fem_Gui_TaskFemConstraintBearing.cpp10
-rw-r--r--cad/freecad/files/patch-src_Mod_Part_Gui_DlgSettingsGeneral.h10
-rw-r--r--cad/freecad/pkg-plist4
5 files changed, 39 insertions, 3 deletions
diff --git a/cad/freecad/files/patch-src_Gui_CMakeLists.txt b/cad/freecad/files/patch-src_Gui_CMakeLists.txt
index fc3b4bc6420b..23ec10fed6bf 100644
--- a/cad/freecad/files/patch-src_Gui_CMakeLists.txt
+++ b/cad/freecad/files/patch-src_Gui_CMakeLists.txt
@@ -1,11 +1,11 @@
---- src/Gui/CMakeLists.txt.orig 2017-06-16 13:00:26 UTC
+--- src/Gui/CMakeLists.txt.orig 2019-02-08 22:48:01 UTC
+++ src/Gui/CMakeLists.txt
-@@ -58,7 +58,7 @@ else(MSVC)
+@@ -57,7 +57,7 @@ else(MSVC)
FreeCADApp
${COIN3D_LIBRARIES}
${Boost_LIBRARIES}
- ${OPENGL_gl_LIBRARY}
-+ ${OPENGL_gl_LIBRARY} -L%%LOCALBASE%%/lib
++ ${OPENGL_gl_LIBRARY} -L${CMAKE_INSTALL_PREFIX}/lib
${3DCONNEXION_LINKFLAGS}
)
endif(MSVC)
diff --git a/cad/freecad/files/patch-src_Gui_Command.h b/cad/freecad/files/patch-src_Gui_Command.h
new file mode 100644
index 000000000000..b09dfbf1a7c5
--- /dev/null
+++ b/cad/freecad/files/patch-src_Gui_Command.h
@@ -0,0 +1,12 @@
+--- src/Gui/Command.h.orig 2019-02-08 22:48:01 UTC
++++ src/Gui/Command.h
+@@ -30,6 +30,9 @@
+ #include <string>
+ #include <vector>
+
++#include <QtCore/QtCore>
++#include <QtWidgets/QtWidgets>
++
+ #include <Base/Type.h>
+
+ class QWidget;
diff --git a/cad/freecad/files/patch-src_Mod_Fem_Gui_TaskFemConstraintBearing.cpp b/cad/freecad/files/patch-src_Mod_Fem_Gui_TaskFemConstraintBearing.cpp
new file mode 100644
index 000000000000..46efa7a0f57f
--- /dev/null
+++ b/cad/freecad/files/patch-src_Mod_Fem_Gui_TaskFemConstraintBearing.cpp
@@ -0,0 +1,10 @@
+--- src/Mod/Fem/Gui/TaskFemConstraintBearing.cpp.orig 2019-02-08 22:48:02 UTC
++++ src/Mod/Fem/Gui/TaskFemConstraintBearing.cpp
+@@ -44,6 +44,7 @@
+ #include <App/Application.h>
+ #include <App/Document.h>
+ #include <App/PropertyGeo.h>
++#include <Gui/Action.h>
+ #include <Gui/Application.h>
+ #include <Gui/Document.h>
+ #include <Gui/BitmapFactory.h>
diff --git a/cad/freecad/files/patch-src_Mod_Part_Gui_DlgSettingsGeneral.h b/cad/freecad/files/patch-src_Mod_Part_Gui_DlgSettingsGeneral.h
new file mode 100644
index 000000000000..eae45aaa92ec
--- /dev/null
+++ b/cad/freecad/files/patch-src_Mod_Part_Gui_DlgSettingsGeneral.h
@@ -0,0 +1,10 @@
+--- src/Mod/Part/Gui/DlgSettingsGeneral.h.orig 2019-02-08 22:48:01 UTC
++++ src/Mod/Part/Gui/DlgSettingsGeneral.h
+@@ -25,6 +25,7 @@
+ #define PARTGUI_DLGSETTINGSGENERAL_H
+
+ #include <Gui/PropertyPage.h>
++#include <QtWidgets/QtWidgets>
+
+ class QButtonGroup;
+
diff --git a/cad/freecad/pkg-plist b/cad/freecad/pkg-plist
index 5ac3db6c0c20..7384aa9990e6 100644
--- a/cad/freecad/pkg-plist
+++ b/cad/freecad/pkg-plist
@@ -1,4 +1,8 @@
FreeCAD/Ext/freecad/__init__.py
+FreeCAD/Ext/PySide/QtCore.py
+FreeCAD/Ext/PySide/QtGui.py
+FreeCAD/Ext/PySide/QtSvg.py
+FreeCAD/Ext/PySide/__init__.py
FreeCAD/Mod/AddonManager/AddonManager.py
FreeCAD/Mod/AddonManager/AddonManagerGui.py
FreeCAD/Mod/AddonManager/Init.py