aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-05-27 17:40:40 +0800
committerJohn Marino <marino@FreeBSD.org>2016-05-27 17:40:40 +0800
commita8eb9459757232f72b4ba3cb72135c282636e299 (patch)
tree59823112e2a4e5f5f335a754dd2d22247b3dd7a3 /cad
parentdecf876ef5564d29195b878dff1164cbfd4f82b8 (diff)
downloadfreebsd-ports-gnome-a8eb9459757232f72b4ba3cb72135c282636e299.tar.gz
freebsd-ports-gnome-a8eb9459757232f72b4ba3cb72135c282636e299.tar.zst
freebsd-ports-gnome-a8eb9459757232f72b4ba3cb72135c282636e299.zip
cad/ghdl: build it with gcc6-aux, not gcc5-aux
I confirmed that ghdl builds with the default-for-Ada gcc6-aux compiler on FreeBSD. It was building on DragonFly, but DragonFly uses the LLVM backend while on FreeBSD ghdl defaults to gcc back, so both options needed to be tested. It's debatable that a bump is needed because ghdl is self-contained, but let's do it anyway so they'll be immediate feedback on any runtime issues this may cause.
Diffstat (limited to 'cad')
-rw-r--r--cad/ghdl/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/cad/ghdl/Makefile b/cad/ghdl/Makefile
index 59a0dde18a0e..a0913bf17a61 100644
--- a/cad/ghdl/Makefile
+++ b/cad/ghdl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ghdl
PORTVERSION= 0.33
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= cad
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
@@ -17,7 +18,7 @@ LIB_DEPENDS= libgmp.so:math/gmp \
libmpfr.so:math/mpfr \
libmpc.so:math/mpc
-USES= ada:5 gmake
+USES= ada gmake
USE_GITHUB= yes
GH_ACCOUNT= tgingold