aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2015-01-26 05:37:31 +0800
committerthierry <thierry@FreeBSD.org>2015-01-26 05:37:31 +0800
commitaeada46f99c9cb24b585591e6e0ba4e8c2b18d45 (patch)
tree91e5e3c7cc6409f104805eabff2738b638a2b4b0 /cad
parent9d2a89a0455d1f1b01ae0540d1e43ca900395c3b (diff)
downloadfreebsd-ports-gnome-aeada46f99c9cb24b585591e6e0ba4e8c2b18d45.tar.gz
freebsd-ports-gnome-aeada46f99c9cb24b585591e6e0ba4e8c2b18d45.tar.zst
freebsd-ports-gnome-aeada46f99c9cb24b585591e6e0ba4e8c2b18d45.zip
Upgrade to 1.3.3 and define LICENSE.
Diffstat (limited to 'cad')
-rw-r--r--cad/meshlab/Makefile25
-rw-r--r--cad/meshlab/distinfo4
-rw-r--r--cad/meshlab/files/patch-external-structuresynth-1.5-ssynth-SyntopiaCore-GLEngine-Raytracer-VoxelStepper.cpp11
-rw-r--r--cad/meshlab/files/patch-meshlab_mainwindow_RunTime.cpp13
-rw-r--r--cad/meshlab/files/patch-meshlabplugins-decorate_base-colorhistogram.h6
-rw-r--r--cad/meshlab/files/patch-meshlabplugins-filter_csg-intercept.h58
-rw-r--r--cad/meshlab/files/patch-vcglib-vcg-complex-algorithms_subset.h17
-rw-r--r--cad/meshlab/files/patch-vcglib-vcg-math_base.h12
-rw-r--r--cad/meshlab/files/patch-vcglib-vcg-space_deprecated_point.h34
-rw-r--r--cad/meshlab/files/patch-vcglib-wrap-gl-trimesh.h18
-rw-r--r--cad/meshlab/pkg-plist7
11 files changed, 111 insertions, 94 deletions
diff --git a/cad/meshlab/Makefile b/cad/meshlab/Makefile
index e2dcfed5799c..34f9fb00396c 100644
--- a/cad/meshlab/Makefile
+++ b/cad/meshlab/Makefile
@@ -2,30 +2,35 @@
# $FreeBSD$
PORTNAME= meshlab
-DISTVERSION= 1.3.2
-PORTREVISION= 3
+PORTVERSION= 1.3.3
CATEGORIES= cad
-MASTER_SITES= ${MASTER_SITE_LOCAL}/gahr/ \
- http://people.freebsd.org/~gahr/distfiles/
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/MeshLab%20v${PORTVERSION}/
+DISTNAME= MeshLabSrc_AllInc_v${PORTVERSION:C|\.||g}
MAINTAINER= ports@FreeBSD.org
COMMENT= 3D triangular meshes processing and editing tool
-LIB_DEPENDS= libQtSolutions_SOAP-head.so:${PORTSDIR}/devel/qt4-qtsolutions-soap
-LIB_DEPENDS= libQtSolutions_SOAP-head.so:${PORTSDIR}/devel/qt4-qtsolutions-soap
+LICENSE= GPLv2
-USES= dos2unix qmake compiler:c++11-lib
+EXTRACT_DEPENDS=gtar:${PORTSDIR}/archivers/gtar
+LIB_DEPENDS= libQtSolutions_SOAP-head.so:${PORTSDIR}/devel/qt4-qtsolutions-soap \
+ libmpir.so:${PORTSDIR}/math/mpir
+
+USES= dos2unix qmake compiler:c++11-lib tar:tgz
USE_CXXSTD= c++11
USE_GL= glew glu
USE_QT4= moc_build rcc_build uic_build corelib gui xml \
xmlpatterns opengl network script
+USE_LDCONFIG= yes
DOS2UNIX_FILES= external/structuresynth/ssynth/SyntopiaCore/GLEngine/Object3D.h \
external/structuresynth/ssynth/SyntopiaCore/GLEngine/Raytracer/VoxelStepper.cpp \
- meshlabplugins/edit_arc3D/fillImage.cpp
+ meshlabplugins/edit_arc3D/fillImage.cpp \
+ meshlabplugins/filter_csg/intercept.h
-WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}/src
+EXTRACT_CMD= gtar
+WRKSRC= ${WRKDIR}/${PORTNAME}/src
-post-patch:
+pre-configure:
${MV} "${WRKSRC}/distrib/shaders/electronic microscope.gdp" \
${WRKSRC}/distrib/shaders/electronic_microscope.gdp
${MV} "${WRKSRC}/distrib/shaders/shadersrm/old/Depth of Field.rfx" \
diff --git a/cad/meshlab/distinfo b/cad/meshlab/distinfo
index f10bf0567106..27061f8f61e5 100644
--- a/cad/meshlab/distinfo
+++ b/cad/meshlab/distinfo
@@ -1,2 +1,2 @@
-SHA256 (meshlab-1.3.2.tar.gz) = 70b2bdcc8001346b5104e8614cefa9ed9cab055fb6adc04352a19b7f9b66bad6
-SIZE (meshlab-1.3.2.tar.gz) = 12774974
+SHA256 (MeshLabSrc_AllInc_v133.tgz) = c9829cd1f58713f1f82d546af1ee69291b52a0f94585f803174fb9e55654980f
+SIZE (MeshLabSrc_AllInc_v133.tgz) = 13390531
diff --git a/cad/meshlab/files/patch-external-structuresynth-1.5-ssynth-SyntopiaCore-GLEngine-Raytracer-VoxelStepper.cpp b/cad/meshlab/files/patch-external-structuresynth-1.5-ssynth-SyntopiaCore-GLEngine-Raytracer-VoxelStepper.cpp
new file mode 100644
index 000000000000..fdfe5a8120f9
--- /dev/null
+++ b/cad/meshlab/files/patch-external-structuresynth-1.5-ssynth-SyntopiaCore-GLEngine-Raytracer-VoxelStepper.cpp
@@ -0,0 +1,11 @@
+--- external/structuresynth-1.5/ssynth/SyntopiaCore/GLEngine/Raytracer/VoxelStepper.cpp.orig 2014-02-07 10:38:23.000000000 +0100
++++ external/structuresynth-1.5/ssynth/SyntopiaCore/GLEngine/Raytracer/VoxelStepper.cpp 2015-01-25 18:58:54.000000000 +0100
+@@ -122,7 +122,7 @@
+ currentT = p;
+
+ // We do not intersect grid.
+- if (!found) return false;
++ if (!found) return nullptr;
+ }
+
+ stepX = (dir.x() > 0) ? 1 : -1;
diff --git a/cad/meshlab/files/patch-meshlab_mainwindow_RunTime.cpp b/cad/meshlab/files/patch-meshlab_mainwindow_RunTime.cpp
deleted file mode 100644
index 7f8d43a65537..000000000000
--- a/cad/meshlab/files/patch-meshlab_mainwindow_RunTime.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- meshlab/mainwindow_RunTime.cpp.orig 2013-10-31 16:02:53.000000000 +0100
-+++ meshlab/mainwindow_RunTime.cpp 2013-10-31 16:04:13.000000000 +0100
-@@ -1575,7 +1575,9 @@
-
- /*********WARNING!!!!!! CHANGE IT!!! ALSO IN THE OPENPROJECT FUNCTION********/
- meshDoc()->setDocLabel(fileName);
-- mdiarea->activeSubWindow()->setWindowTitle(meshDoc()->docLabel());
-+ if (mdiarea->activeSubWindow()) {
-+ mdiarea->activeSubWindow()->setWindowTitle(meshDoc()->docLabel());
-+ }
- layerDialog->setWindowTitle(meshDoc()->docLabel());
- /****************************************************************************/
-
diff --git a/cad/meshlab/files/patch-meshlabplugins-decorate_base-colorhistogram.h b/cad/meshlab/files/patch-meshlabplugins-decorate_base-colorhistogram.h
index 633d5e67a962..8662f077f095 100644
--- a/cad/meshlab/files/patch-meshlabplugins-decorate_base-colorhistogram.h
+++ b/cad/meshlab/files/patch-meshlabplugins-decorate_base-colorhistogram.h
@@ -1,12 +1,12 @@
---- ../../meshlab/src/meshlabplugins/decorate_base/colorhistogram.h.orig 2013-11-16 22:04:41.000000000 +0100
-+++ ../../meshlab/src/meshlabplugins/decorate_base/colorhistogram.h 2013-11-16 22:04:56.000000000 +0100
+--- meshlabplugins/decorate_base/colorhistogram.h.orig 2013-07-17 17:20:11.000000000 +0200
++++ meshlabplugins/decorate_base/colorhistogram.h 2015-01-24 18:01:12.000000000 +0100
@@ -39,10 +39,11 @@
//ScalarType BinWidth(ScalarType v);
//! Reset histogram data.
+ /* dead code
void Clear() {
- this->::Clear();
+ Histogram<ScalarType>::Clear();
CV.clear();
- }
+ } */
diff --git a/cad/meshlab/files/patch-meshlabplugins-filter_csg-intercept.h b/cad/meshlab/files/patch-meshlabplugins-filter_csg-intercept.h
new file mode 100644
index 000000000000..e9ab3087f292
--- /dev/null
+++ b/cad/meshlab/files/patch-meshlabplugins-filter_csg-intercept.h
@@ -0,0 +1,58 @@
+--- meshlabplugins/filter_csg/intercept.h.orig 2015-01-25 21:48:25.000000000 +0100
++++ meshlabplugins/filter_csg/intercept.h 2015-01-25 21:49:09.000000000 +0100
+@@ -7,8 +7,13 @@
+ #include <unordered_map>
+ #include <unordered_set>
+ #else
++# if !defined(_LIBCPP_VERSION)
+ #include <tr1/unordered_map>
+ #include <tr1/unordered_set>
++# else
++ #include <unordered_map>
++ #include <unordered_set>
++# endif
+ #endif
+
+ #include <vcg/complex/complex.h>
+@@ -29,7 +34,7 @@
+ //MSVC++ 7.0 _MSC_VER = 1300
+ //MSVC++ 6.0 _MSC_VER = 1200
+ //MSVC++ 5.0 _MSC_VER = 1100
+-#if defined(_MSC_VER) && (_MSC_VER > 1500)
++#if (defined(_MSC_VER) && (_MSC_VER > 1500)) || defined(_LIBCPP_VERSION)
+ #else
+ namespace tr1 {
+ #endif
+@@ -38,11 +43,15 @@
+ {
+ std::size_t operator()(const vcg::Point3i &x) const
+ {
++#if !defined(_LIBCPP_VERSION)
+ std::tr1::hash<int> h;
++#else
++ std::hash<int> h;
++#endif
+ return ((x[0]) * 131 + h(x[1])) * 131 + h(x[2]);
+ }
+ };
+-#if defined(_MSC_VER) && (_MSC_VER > 1500)
++#if (defined(_MSC_VER) && (_MSC_VER > 1500)) || defined(_LIBCPP_VERSION)
+ #else
+ }
+ #endif
+@@ -823,9 +832,15 @@
+ {
+ typedef typename MeshType::VertexPointer VertexPointer;
+ typedef typename MeshType::CoordType CoordType;
++#if !defined(_LIBCPP_VERSION)
+ typedef typename std::tr1::unordered_map<const InterceptType*,size_t> VertexTable;
+ typedef typename std::tr1::unordered_map<vcg::Point3i,float> SamplesTable;
+ typedef typename std::tr1::unordered_set<vcg::Point3i> CellsSet;
++#else
++ typedef typename std::unordered_map<const InterceptType*,size_t> VertexTable;
++ typedef typename std::unordered_map<vcg::Point3i,float> SamplesTable;
++ typedef typename std::unordered_set<vcg::Point3i> CellsSet;
++#endif
+
+ void clear() {
+ _vertices.clear();
diff --git a/cad/meshlab/files/patch-vcglib-vcg-complex-algorithms_subset.h b/cad/meshlab/files/patch-vcglib-vcg-complex-algorithms_subset.h
deleted file mode 100644
index a7b1290e93d3..000000000000
--- a/cad/meshlab/files/patch-vcglib-vcg-complex-algorithms_subset.h
+++ /dev/null
@@ -1,17 +0,0 @@
---- ../../vcglib/vcg/complex/algorithms/subset.h.orig 2013-10-31 09:34:59.000000000 +0100
-+++ ../../vcglib/vcg/complex/algorithms/subset.h 2013-10-31 09:35:06.000000000 +0100
-@@ -86,12 +86,12 @@
- return (v<o.v);
- }
-
-- bool operator ==(const InsertedV & o)
-+ bool operator ==(const InsertedV & o) const
- {
- return (v==o.v);
- }
-
-- bool operator !=(const InsertedV & o)
-+ bool operator !=(const InsertedV & o) const
- {
- return (v!=o.v);
- }
diff --git a/cad/meshlab/files/patch-vcglib-vcg-math_base.h b/cad/meshlab/files/patch-vcglib-vcg-math_base.h
deleted file mode 100644
index 1a7a65d64d6f..000000000000
--- a/cad/meshlab/files/patch-vcglib-vcg-math_base.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- ../../vcglib/vcg/math/base.h.orig 2012-04-05 11:04:15.000000000 +0200
-+++ ../../vcglib/vcg/math/base.h 2013-10-31 11:09:34.000000000 +0100
-@@ -94,7 +94,9 @@
- /// static_assert: implemented as a macro for "assert", but it is separated for clarity.
- /// Should be used for checking integrity constraints that can be tested at complile time,
- /// as the ones involving templated constants in templated classes.
-+#if 0
- #define static_assert assert
-+#endif
-
- #ifdef __BORLANDC__
- float sqrtf (float v) {return sqrt(v);}
diff --git a/cad/meshlab/files/patch-vcglib-vcg-space_deprecated_point.h b/cad/meshlab/files/patch-vcglib-vcg-space_deprecated_point.h
index a5ac6a15107e..220bf6713507 100644
--- a/cad/meshlab/files/patch-vcglib-vcg-space_deprecated_point.h
+++ b/cad/meshlab/files/patch-vcglib-vcg-space_deprecated_point.h
@@ -1,5 +1,5 @@
---- ../../vcglib/vcg/space/deprecated_point.h.orig 2012-07-31 08:25:21.000000000 +0200
-+++ ../../vcglib/vcg/space/deprecated_point.h 2014-06-10 17:19:15.000000000 +0200
+--- ../../vcglib/vcg/space/deprecated_point.h.orig 2014-04-01 17:10:03.000000000 +0200
++++ ../../vcglib/vcg/space/deprecated_point.h 2015-01-24 23:55:25.000000000 +0100
@@ -59,6 +59,10 @@
#include <vcg/math/base.h>
#include <vcg/space/space.h>
@@ -10,21 +10,21 @@
+
namespace vcg {
- namespace ndim{
+ namespace ndim{
@@ -164,14 +168,14 @@
}
inline const S &X() const { return _v[0]; }
- inline const S &Y() const { return _v[1]; }
-- inline const S &Z() const { static_assert(N>2); return _v[2]; }
-+ inline const S &Z() const { static_assert(N>2, "No Z coordinate in R² space"); return _v[2]; }
- /// W is in any case the last coordinate.
- /// (in a 2D point, W() == Y(). In a 3D point, W()==Z()
- /// in a 4D point, W() is a separate component)
- inline const S &W() const { return _v[N-1]; }
- inline S &X() { return _v[0]; }
- inline S &Y() { return _v[1]; }
-- inline S &Z() { static_assert(N>2); return _v[2]; }
-+ inline S &Z() { static_assert(N>2, "No Z coordinate in R² space"); return _v[2]; }
- inline S &W() { return _v[N-1]; }
- inline const S * V() const
- {
+ inline const S &Y() const { return _v[1]; }
+- inline const S &Z() const { static_assert(N>2); return _v[2]; }
++ inline const S &Z() const { static_assert(N>2, "No Z coordinate in R² space"); return _v[2]; }
+ /// W is in any case the last coordinate.
+ /// (in a 2D point, W() == Y(). In a 3D point, W()==Z()
+ /// in a 4D point, W() is a separate component)
+ inline const S &W() const { return _v[N-1]; }
+ inline S &X() { return _v[0]; }
+ inline S &Y() { return _v[1]; }
+- inline S &Z() { static_assert(N>2); return _v[2]; }
++ inline S &Z() { static_assert(N>2, "No Z coordinate in R² space"); return _v[2]; }
+ inline S &W() { return _v[N-1]; }
+ inline const S * V() const
+ {
diff --git a/cad/meshlab/files/patch-vcglib-wrap-gl-trimesh.h b/cad/meshlab/files/patch-vcglib-wrap-gl-trimesh.h
deleted file mode 100644
index 56e36789e70d..000000000000
--- a/cad/meshlab/files/patch-vcglib-wrap-gl-trimesh.h
+++ /dev/null
@@ -1,18 +0,0 @@
---- ../../vcglib/wrap/gl/trimesh.h.orig 2013-11-16 21:32:47.000000000 +0100
-+++ ../../vcglib/wrap/gl/trimesh.h 2013-11-16 21:33:23.000000000 +0100
-@@ -895,6 +895,7 @@
- #define VCTRACE (void)0
- //#define VCTRACE TRACE
-
-+/* dead code
- template<class MESH_TYPE>
- void Crease(MESH_TYPE &m, typename MESH_TYPE::scalar_type angleRad)
- {
-@@ -1006,6 +1007,7 @@
- m.vert.math::Swap(newvert);
- m.vn=m.vert.size();
- }
-+*/
-
- /*
- Secondo tipo di crease angle. ha bisogno del per wedge normal
diff --git a/cad/meshlab/pkg-plist b/cad/meshlab/pkg-plist
index 6cdc60a9d397..154a0af00cce 100644
--- a/cad/meshlab/pkg-plist
+++ b/cad/meshlab/pkg-plist
@@ -13,6 +13,7 @@ lib/meshlab/plugins/libedit_paint.so
lib/meshlab/plugins/libedit_pickpoints.so
lib/meshlab/plugins/libedit_point.so
lib/meshlab/plugins/libedit_quality.so
+lib/meshlab/plugins/libedit_referencing.so
lib/meshlab/plugins/libedit_select.so
lib/meshlab/plugins/libedit_texture.so
lib/meshlab/plugins/libfilter_aging.so
@@ -25,9 +26,12 @@ lib/meshlab/plugins/libfilter_color_projection.so
lib/meshlab/plugins/libfilter_colorize.so
lib/meshlab/plugins/libfilter_colorproc.so
lib/meshlab/plugins/libfilter_create.so
+lib/meshlab/plugins/libfilter_createiso.so
+lib/meshlab/plugins/libfilter_csg.so
lib/meshlab/plugins/libfilter_dirt.so
lib/meshlab/plugins/libfilter_fractal.so
lib/meshlab/plugins/libfilter_func.so
+lib/meshlab/plugins/libfilter_geodesic.so
lib/meshlab/plugins/libfilter_img_patch_param.so
lib/meshlab/plugins/libfilter_isoparametrization.so
lib/meshlab/plugins/libfilter_layer.so
@@ -48,8 +52,6 @@ lib/meshlab/plugins/libfilter_texture.so
lib/meshlab/plugins/libfilter_trioptimize.so
lib/meshlab/plugins/libfilter_unsharp.so
lib/meshlab/plugins/libfilter_zippering.so
-lib/meshlab/plugins/libfiltercreateiso.so
-lib/meshlab/plugins/libfiltergeodesic.so
lib/meshlab/plugins/libio_3ds.so
lib/meshlab/plugins/libio_base.so
lib/meshlab/plugins/libio_bre.so
@@ -61,6 +63,7 @@ lib/meshlab/plugins/libio_json.so
lib/meshlab/plugins/libio_m.so
lib/meshlab/plugins/libio_pdb.so
lib/meshlab/plugins/libio_tri.so
+lib/meshlab/plugins/libio_txt.so
lib/meshlab/plugins/libio_u3d.so
lib/meshlab/plugins/libio_x3d.so
lib/meshlab/plugins/librender_gdp.so