aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2013-08-27 12:22:46 +0800
committermaho <maho@FreeBSD.org>2013-08-27 12:22:46 +0800
commitc10b2c3a45319089c6357a34faf49c41f3bcf255 (patch)
tree102ee50b8a6569563162e34fc8252011aadb5945 /cad
parentb6125a8afab3044de26b7b5118f6c37d59ea56f1 (diff)
downloadfreebsd-ports-gnome-c10b2c3a45319089c6357a34faf49c41f3bcf255.tar.gz
freebsd-ports-gnome-c10b2c3a45319089c6357a34faf49c41f3bcf255.tar.zst
freebsd-ports-gnome-c10b2c3a45319089c6357a34faf49c41f3bcf255.zip
Now metis-edf is selectable.
Diffstat (limited to 'cad')
-rw-r--r--cad/calculix/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/cad/calculix/Makefile b/cad/calculix/Makefile
index faf47fb27957..82ad6ecbf482 100644
--- a/cad/calculix/Makefile
+++ b/cad/calculix/Makefile
@@ -32,7 +32,6 @@ LICENSE= GPLv2
LIB_DEPENDS= arpack.1:${PORTSDIR}/math/arpack \
spooles.1:${PORTSDIR}/math/spooles \
- metis.1:${PORTSDIR}/math/metis4 \
taucs.1:${PORTSDIR}/math/taucs
USE_BZIP2= yes
@@ -58,6 +57,17 @@ CCX_VER= ccx_${PORTVERSION}
CGX_VER= cgx_2.6
.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
+
+OPTIONS_DEFINE= METIS METIS_EDF
+OPTIONS_DEFAULT=METIS
+
+.if ${PORT_OPTIONS:MMETIS}
+LIB_DEPENDS+= metis.1:${PORTSDIR}/math/metis4
+.endif
+.if ${PORT_OPTIONS:MMETIS_EDF}
+LIB_DEPENDS+= metis.1:${PORTSDIR}/math/metis-edf
+.endif
.if exists(${LOCALBASE}/lib/libatlas.so) && !defined(WITH_BLAS)
WITH_ATLAS= yes