aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2017-01-08 19:22:15 +0800
committerwen <wen@FreeBSD.org>2017-01-08 19:22:15 +0800
commitc2a865fee65ef793a8a7d687c4001ea54d48a1a4 (patch)
tree44f096833088f2164a2a37dfeaebee7c1400d295 /cad
parent67fb2f4cf037a19230928b9a22325903cedc2fee (diff)
downloadfreebsd-ports-gnome-c2a865fee65ef793a8a7d687c4001ea54d48a1a4.tar.gz
freebsd-ports-gnome-c2a865fee65ef793a8a7d687c4001ea54d48a1a4.tar.zst
freebsd-ports-gnome-c2a865fee65ef793a8a7d687c4001ea54d48a1a4.zip
- Update to 20170104 snapshot
- Pass maintainership to submitter - Add python pivy as a runtime dependency PR: 214239 Submitted by: tj+freebsd_bugs@a13.fr
Diffstat (limited to 'cad')
-rw-r--r--cad/freecad/Makefile8
-rw-r--r--cad/freecad/distinfo6
-rw-r--r--cad/freecad/pkg-plist48
3 files changed, 44 insertions, 18 deletions
diff --git a/cad/freecad/Makefile b/cad/freecad/Makefile
index c462f5b182f7..83844e781536 100644
--- a/cad/freecad/Makefile
+++ b/cad/freecad/Makefile
@@ -1,11 +1,10 @@
# $FreeBSD$
PORTNAME= FreeCAD
-DISTVERSION= 0.17.g20161104
-PORTREVISION= 3
+DISTVERSION= 0.17.g20170104
CATEGORIES= cad
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= tj+freebsd_ports@a13.fr
COMMENT= General purpose 3D CAD modeller
LICENSE= LGPL20+
@@ -29,9 +28,10 @@ LIB_DEPENDS= libexpat.so:textproc/expat2 \
libarea.so:devel/libarea \
libmed.so:french/med \
libshiboken-${PYTHON_VERSION}.so:devel/shiboken
+RUN_DEPENDS= pivy>0:graphics/py-pivy
USE_GITHUB= yes
-GH_TAGNAME= 0ea7373
+GH_TAGNAME= f6f8363
USES= compiler:c++11-lib cmake:outsource jpeg python localbase
USE_XORG= ice sm x11 xext xt
diff --git a/cad/freecad/distinfo b/cad/freecad/distinfo
index 2093508a856c..8b8f16f11641 100644
--- a/cad/freecad/distinfo
+++ b/cad/freecad/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1478289051
-SHA256 (FreeCAD-FreeCAD-0.17.g20161104-0ea7373_GH0.tar.gz) = ac4edbe9dce171f3a57fcde5487fe07dedbfb1b4b083027c270fa338a9e4af36
-SIZE (FreeCAD-FreeCAD-0.17.g20161104-0ea7373_GH0.tar.gz) = 115122637
+TIMESTAMP = 1483532864
+SHA256 (FreeCAD-FreeCAD-0.17.g20170104-f6f8363_GH0.tar.gz) = 61322ef4d6fd961c773fdc21f2e0f2085928a4e2fd687a2d0c4b5307839c17f5
+SIZE (FreeCAD-FreeCAD-0.17.g20170104-f6f8363_GH0.tar.gz) = 115628747
diff --git a/cad/freecad/pkg-plist b/cad/freecad/pkg-plist
index c573ef2246dc..168e5c948183 100644
--- a/cad/freecad/pkg-plist
+++ b/cad/freecad/pkg-plist
@@ -67,10 +67,15 @@ FreeCAD/Mod/Fem/FemAnalysis.py
FreeCAD/Mod/Fem/FemBeamSection.py
FreeCAD/Mod/Fem/FemCommands.py
FreeCAD/Mod/Fem/FemConstraintSelfWeight.py
+FreeCAD/Mod/Fem/FemGmshTools.py
FreeCAD/Mod/Fem/FemInputWriter.py
FreeCAD/Mod/Fem/FemInputWriterCcx.py
FreeCAD/Mod/Fem/FemInputWriterZ88.py
+FreeCAD/Mod/Fem/FemMaterial.py
FreeCAD/Mod/Fem/FemMaterialMechanicalNonlinear.py
+FreeCAD/Mod/Fem/FemMesh2Mesh.py
+FreeCAD/Mod/Fem/FemMeshGmsh.py
+FreeCAD/Mod/Fem/FemMeshRegion.py
FreeCAD/Mod/Fem/FemMeshTools.py
FreeCAD/Mod/Fem/FemSelectionObserver.py
FreeCAD/Mod/Fem/FemShellThickness.py
@@ -81,20 +86,26 @@ FreeCAD/Mod/Fem/FemToolsCcx.py
FreeCAD/Mod/Fem/FemToolsZ88.py
FreeCAD/Mod/Fem/Init.py
FreeCAD/Mod/Fem/InitGui.py
-FreeCAD/Mod/Fem/MechanicalMaterial.py
FreeCAD/Mod/Fem/TaskPanelFemBeamSection.ui
+FreeCAD/Mod/Fem/TaskPanelFemMaterial.ui
+FreeCAD/Mod/Fem/TaskPanelFemMeshGmsh.ui
+FreeCAD/Mod/Fem/TaskPanelFemMeshRegion.ui
FreeCAD/Mod/Fem/TaskPanelFemShellThickness.ui
FreeCAD/Mod/Fem/TaskPanelFemSolverCalculix.ui
-FreeCAD/Mod/Fem/TaskPanelMechanicalMaterial.ui
FreeCAD/Mod/Fem/TaskPanelShowResult.ui
FreeCAD/Mod/Fem/TestFem.py
FreeCAD/Mod/Fem/_CommandAnalysis.py
FreeCAD/Mod/Fem/_CommandBeamSection.py
+FreeCAD/Mod/Fem/_CommandClearMesh.py
FreeCAD/Mod/Fem/_CommandConstraintSelfWeight.py
FreeCAD/Mod/Fem/_CommandControlSolver.py
+FreeCAD/Mod/Fem/_CommandFEMMesh2Mesh.py
+FreeCAD/Mod/Fem/_CommandMaterial.py
FreeCAD/Mod/Fem/_CommandMaterialMechanicalNonlinear.py
-FreeCAD/Mod/Fem/_CommandMechanicalMaterial.py
-FreeCAD/Mod/Fem/_CommandMeshFromShape.py
+FreeCAD/Mod/Fem/_CommandMeshGmshFromShape.py
+FreeCAD/Mod/Fem/_CommandMeshNetgenFromShape.py
+FreeCAD/Mod/Fem/_CommandMeshRegion.py
+FreeCAD/Mod/Fem/_CommandPrintMeshInfo.py
FreeCAD/Mod/Fem/_CommandPurgeResults.py
FreeCAD/Mod/Fem/_CommandRunSolver.py
FreeCAD/Mod/Fem/_CommandShellThickness.py
@@ -103,23 +114,29 @@ FreeCAD/Mod/Fem/_CommandSolverCalculix.py
FreeCAD/Mod/Fem/_CommandSolverZ88.py
FreeCAD/Mod/Fem/_FemBeamSection.py
FreeCAD/Mod/Fem/_FemConstraintSelfWeight.py
+FreeCAD/Mod/Fem/_FemMaterial.py
FreeCAD/Mod/Fem/_FemMaterialMechanicalNonlinear.py
+FreeCAD/Mod/Fem/_FemMeshGmsh.py
+FreeCAD/Mod/Fem/_FemMeshRegion.py
FreeCAD/Mod/Fem/_FemShellThickness.py
FreeCAD/Mod/Fem/_FemSolverCalculix.py
FreeCAD/Mod/Fem/_FemSolverZ88.py
-FreeCAD/Mod/Fem/_MechanicalMaterial.py
FreeCAD/Mod/Fem/_TaskPanelFemBeamSection.py
+FreeCAD/Mod/Fem/_TaskPanelFemMaterial.py
+FreeCAD/Mod/Fem/_TaskPanelFemMeshGmsh.py
+FreeCAD/Mod/Fem/_TaskPanelFemMeshRegion.py
FreeCAD/Mod/Fem/_TaskPanelFemShellThickness.py
FreeCAD/Mod/Fem/_TaskPanelFemSolverCalculix.py
-FreeCAD/Mod/Fem/_TaskPanelMechanicalMaterial.py
FreeCAD/Mod/Fem/_TaskPanelShowResult.py
FreeCAD/Mod/Fem/_ViewProviderFemBeamSection.py
FreeCAD/Mod/Fem/_ViewProviderFemConstraintSelfWeight.py
+FreeCAD/Mod/Fem/_ViewProviderFemMaterial.py
FreeCAD/Mod/Fem/_ViewProviderFemMaterialMechanicalNonlinear.py
+FreeCAD/Mod/Fem/_ViewProviderFemMeshGmsh.py
+FreeCAD/Mod/Fem/_ViewProviderFemMeshRegion.py
FreeCAD/Mod/Fem/_ViewProviderFemShellThickness.py
FreeCAD/Mod/Fem/_ViewProviderFemSolverCalculix.py
FreeCAD/Mod/Fem/_ViewProviderFemSolverZ88.py
-FreeCAD/Mod/Fem/_ViewProviderMechanicalMaterial.py
FreeCAD/Mod/Fem/ccxDatReader.py
FreeCAD/Mod/Fem/ccxFrdReader.py
FreeCAD/Mod/Fem/convert2TetGen.py
@@ -267,28 +284,31 @@ FreeCAD/Mod/PartDesign/fcgear/svggear.py
FreeCAD/Mod/Path/Init.py
FreeCAD/Mod/Path/InitGui.py
FreeCAD/Mod/Path/PathCommands.py
-FreeCAD/Mod/Path/PathScripts/DogboneDressup.py
-FreeCAD/Mod/Path/PathScripts/DragknifeDressup.py
FreeCAD/Mod/Path/PathScripts/PathAreaUtils.py
FreeCAD/Mod/Path/PathScripts/PathArray.py
FreeCAD/Mod/Path/PathScripts/PathCommands.py
FreeCAD/Mod/Path/PathScripts/PathComment.py
FreeCAD/Mod/Path/PathScripts/PathCompoundExtended.py
-FreeCAD/Mod/Path/PathScripts/PathCopy.py
FreeCAD/Mod/Path/PathScripts/PathContour.py
+FreeCAD/Mod/Path/PathScripts/PathCopy.py
FreeCAD/Mod/Path/PathScripts/PathCustom.py
FreeCAD/Mod/Path/PathScripts/PathDressup.py
+FreeCAD/Mod/Path/PathScripts/PathDressupDogbone.py
+FreeCAD/Mod/Path/PathScripts/PathDressupDragknife.py
+FreeCAD/Mod/Path/PathScripts/PathDressupHoldingTags.py
FreeCAD/Mod/Path/PathScripts/PathDrilling.py
FreeCAD/Mod/Path/PathScripts/PathEngrave.py
FreeCAD/Mod/Path/PathScripts/PathFacePocket.py
FreeCAD/Mod/Path/PathScripts/PathFaceProfile.py
FreeCAD/Mod/Path/PathScripts/PathFixture.py
FreeCAD/Mod/Path/PathScripts/PathFromShape.py
+FreeCAD/Mod/Path/PathScripts/PathGeom.py
FreeCAD/Mod/Path/PathScripts/PathHop.py
FreeCAD/Mod/Path/PathScripts/PathInspect.py
FreeCAD/Mod/Path/PathScripts/PathJob.py
FreeCAD/Mod/Path/PathScripts/PathKurveUtils.py
FreeCAD/Mod/Path/PathScripts/PathLoadTool.py
+FreeCAD/Mod/Path/PathScripts/PathMillFace.py
FreeCAD/Mod/Path/PathScripts/PathPlane.py
FreeCAD/Mod/Path/PathScripts/PathPocket.py
FreeCAD/Mod/Path/PathScripts/PathPost.py
@@ -297,17 +317,22 @@ FreeCAD/Mod/Path/PathScripts/PathPreferences.py
FreeCAD/Mod/Path/PathScripts/PathPreferencesPathJob.py
FreeCAD/Mod/Path/PathScripts/PathProfile.py
FreeCAD/Mod/Path/PathScripts/PathProfileEdges.py
-FreeCAD/Mod/Path/PathScripts/PathRemote.py
FreeCAD/Mod/Path/PathScripts/PathSanity.py
FreeCAD/Mod/Path/PathScripts/PathSelection.py
FreeCAD/Mod/Path/PathScripts/PathSimpleCopy.py
FreeCAD/Mod/Path/PathScripts/PathStock.py
FreeCAD/Mod/Path/PathScripts/PathStop.py
FreeCAD/Mod/Path/PathScripts/PathSurface.py
+FreeCAD/Mod/Path/PathScripts/PathTestUtils.py
FreeCAD/Mod/Path/PathScripts/PathToolLenOffset.py
FreeCAD/Mod/Path/PathScripts/PathToolLibraryManager.py
FreeCAD/Mod/Path/PathScripts/PathUtils.py
FreeCAD/Mod/Path/PathScripts/PostUtils.py
+FreeCAD/Mod/Path/PathScripts/TestPathApp.py
+FreeCAD/Mod/Path/PathScripts/TestPathDepthParams.py
+FreeCAD/Mod/Path/PathScripts/TestPathDressupHoldingTags.py
+FreeCAD/Mod/Path/PathScripts/TestPathGeom.py
+FreeCAD/Mod/Path/PathScripts/TestPathPost.py
FreeCAD/Mod/Path/PathScripts/TooltableEditor.py
FreeCAD/Mod/Path/PathScripts/__init__.py
FreeCAD/Mod/Path/PathScripts/centroid_post.py
@@ -327,6 +352,7 @@ FreeCAD/Mod/Path/PathScripts/opensbp_post.py
FreeCAD/Mod/Path/PathScripts/opensbp_pre.py
FreeCAD/Mod/Path/PathScripts/rml_post.py
FreeCAD/Mod/Path/PathScripts/slic3r_pre.py
+FreeCAD/Mod/Path/PathScripts/test_linuxcnc_00.ngc
FreeCAD/Mod/Plot/InitGui.py
FreeCAD/Mod/Plot/Plot.py
FreeCAD/Mod/Plot/PlotGui.py