aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2020-11-27 04:46:02 +0800
committerThierry Thomas <thierry@FreeBSD.org>2020-11-27 04:46:02 +0800
commitd50519a41dc5fc322076bf0e9b9e2e184f4f6bc7 (patch)
treeaaddd8ff0212cc22e4435cb87b578da7c1715eea /cad
parent058e5ba0ff29ae64383b8392f23facad616be8c9 (diff)
downloadfreebsd-ports-gnome-d50519a41dc5fc322076bf0e9b9e2e184f4f6bc7.tar.gz
freebsd-ports-gnome-d50519a41dc5fc322076bf0e9b9e2e184f4f6bc7.tar.zst
freebsd-ports-gnome-d50519a41dc5fc322076bf0e9b9e2e184f4f6bc7.zip
Upgrade Code_Aster to 14.6.0-1.
This implies: - french /aster builds fine with clang, but it seg-faults: switched to Gcc - ASTK is upgraded to 2019.0-1 - math/mumps is upgraded to 5.1.2-aster7 - TFEL/MFront is now required, but when the compilers of tfel and aster are different, it cannot be linked . recopopy science/tfel to science/tfel-edf and depends on science/tfel-edf . science/tfel-edf is built by Gcc, from the sources included in Aster's tarball . register the conflicts
Diffstat (limited to 'cad')
-rw-r--r--cad/astk-serveur/Makefile25
1 files changed, 13 insertions, 12 deletions
diff --git a/cad/astk-serveur/Makefile b/cad/astk-serveur/Makefile
index 163e478ea05e..f820116a1cca 100644
--- a/cad/astk-serveur/Makefile
+++ b/cad/astk-serveur/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= astk
-DISTVERSION= 2019.0-1
-PORTREVISION= 1
+DISTVERSION= 2020.0-1
CATEGORIES= cad
.if !defined(CLIENT_SEUL)
PKGNAMESUFFIX= -serveur
@@ -52,11 +51,10 @@ SUB_LIST= inst_dir=${inst_dir} tools_dir=${tools_dir}
LINSTDIR= aster/ASTK
inst_dir= ${PREFIX}/${LINSTDIR}
aster_dir= ${LOCALBASE}/aster/${vaster}
-S_SCRIPTS= bin/as_run bin/parallel_cp asrun/installation.py \
- share/codeaster/asrun/data/mpirun_template
-S_PYLIBS= share/codeaster/asrun/examples/alamain.py \
- unittest/datafiles/config_serveurs unittest/010_misc.py \
- unittest/015_package.py unittest/run_test.py
+S_SCRIPTS= bin/as_run bin/parallel_cp
+S_PYLIBS= share/codeaster/asrun/examples/alamain.py \
+ unittest/010_misc.py unittest/015_package.py \
+ unittest/run_test.py
C_SCRIPTS= bin/astk bin/bsf
tools_dir= ${LOCALBASE}/aster/outils
conf_dir= ${WRKSRC}/etc/astkrc
@@ -85,7 +83,7 @@ WITH_PBS= yes
WITH_MPI= yes
. endif
. if defined(WITH_MPI)
-RUN_DEPENDS+= ${HOME_MPI}/bin/mpirun:net/mpich2
+RUN_DEPENDS+= ${HOME_MPI}/bin/mpirun:net/mpich
HOME_MPI= ${LOCALBASE}
PLIST_SUB+= MPI=""
. else
@@ -188,7 +186,8 @@ do-configure:
.if !defined(CLIENT_SEUL)
. for scripts in ${S_SCRIPTS}
${REINPLACE_CMD} -e "s|?SHELL_EXECUTION?|${SHELL_INSTALL_ASTER}|" \
- -e "s|?ASTER_ROOT?|${PREFIX}/aster|" ${WRKSRC}/${scripts}
+ -e "s|?ASTER_ROOT?|${PREFIX}/aster|;s|python3|${PYTHON_CMD}|" \
+ ${WRKSRC}/${scripts}
. endfor
${REINPLACE_CMD} -e "s|?ASTER_VERSION?|${vaster}|" \
-e 's|#?vers : VVV?|vers : ${vaster}|' \
@@ -229,10 +228,11 @@ do-configure:
-e "s|/opt/aster|${aster_dir}|" ${WRKSRC}/${libs}
. endfor
. if defined(WITH_PBS)
-. for cf in etc/asrun unittest/datafiles/config_serveurs
${REINPLACE_CMD} -e "s|batch : non|batch : oui|" \
- ${WRKSRC}/${cf}
-. endfor
+ ${WRKSRC}/etc/asrun
+. else
+ ${REINPLACE_CMD} -e "s|batch : oui|batch : non|" \
+ ${WRKSRC}/unittest/datafiles/config_serveurs
. endif
. if defined(MAKE_JOBS_NUMBER) && ! defined(PACKAGE_BUILDING)
${REINPLACE_CMD} \
@@ -276,6 +276,7 @@ do-configure:
.for sh in ${BASH2RC3}
${REINPLACE_CMD} -e 's|/bin/bash|${SHELL_INSTALL_ASTER}|' ${WRKCONF}/${sh}
.endfor
+ ${FIND} ${WRKSRC} -name "*.bak" -delete
do-install:
${MKDIR} ${STAGEDIR}${inst_dir}